Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox can't play audio on this page

  • 3 replies
  • 1 has this problem
  • 13 views
  • آخر ردّ كتبه cor-el

more options

Refer to this page: https://humanum.arts.cuhk.edu.hk/Lexis/lexi-can/

It is a Chinese page for searching for pronunciation. However, I am unable to playback any audio on the page.


Steps to reproduce:

1. On the left input field below "輸入漢字,查取粵音", enter a word such as "簞"

2. The page updates, with word information on the right. Click on the speaker icon on the right. (2nd column, 2nd row of the table)

3. No audio is produced.


When I used Google Chrome, the page played audio without issue.

Attached screenshots

Modified by jk192564

All Replies (3)

more options

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

more options

I've tried starting in safe mode, but the problem is still there. I don't see a shield icon on the left of the address bar either.

more options

That website tries to use the QuickTime plugin to play a WAV file (sound/daan1.wav; audio/x-wav) via an EMBED tag.

<a href="sound.php?s=daan1" target="sound"><img src="img/sounder.gif" border="0"></a>
<embed src="sound/daan1.wav" autoplay="true" controller="true" pluginspage="http://www.apple.com/quicktime/download/" width="200" height="16">

Firefox is able to play this file if I change the code to an AUDIO tag.

<audio src="https://humanum.arts.cuhk.edu.hk/Lexis/lexi-can/sound/daan1.wav" autoplay="true" width="300" controls="true">

I don't know of a way to fix this easily, so maybe contact the website and ask them to look into this.