ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hyperlinks in email will not open in Firefox

  • 9 ردود
  • 1 has this problem
  • 2181 views
  • آخر ردّ كتبه Indie1138

more options

Since update to 61.0.1 hyperlinks in my mail client won't open in firefox. I have to cut and paste them to open the links. If I change my default browser to Edge or IE they work correctly just as expected. change back to Firefox as default browser and links stop working, This is a a firefox issue not a mail client or windows issue.

الحل المُختار

Let's try re-installing Firefox.

  1. In the Windows app settings panel, uninstall Firefox.
  2. Reboot your PC.
  3. If it exists, delete the folder "C:\Program Files\Mozilla Firefox\"
  4. Install the latest version of Firefox. Here is a direct link: https://download.mozilla.org/?product=firefox-latest-ssl&os=win64&lang=en-US
Read this answer in context 👍 1

All Replies (9)

more options

Awesome, you send me a mail link to verify my question that links don't work, great job!!

more options

Indie1138 said

you send me a mail link to verify my question that links don't work

That would be the forum automatically doing its job.

What mail client are you using? Or are you using an e-mail program? Make sure that Firefox is listed as your default in the settings of the computer.

more options

Setting firefox as default has no effect.

more options

Hi Indie1138, Could you try setting another browser as the default, then setting Firefox back as the default?

more options

Since update to 61.0.1 hyperlinks in my mail client won't open in firefox. I have to cut and paste them to open the links.

If I change my default browser to Edge or IE they work correctly just as expected. change back to Firefox as default browser and links stop working,

This is a a firefox issue not a mail client or windows issue.

more options

Could you try the solutions in the following article, and see if any of them help: Setting Firefox as the default browser does not work - What to do

One way to make sure it is a Firefox issue is to try clicking on links in a different application. This will help narrow down where the cause is.

And if your mail client is Thunderbird, we can just move this thread to the Thunderbird forum. :)

more options

Already tried that first. The mail client is eM Client it was working fine until the update. It works fine when you set default browser to MS Edge.

more options

الحل المُختار

Let's try re-installing Firefox.

  1. In the Windows app settings panel, uninstall Firefox.
  2. Reboot your PC.
  3. If it exists, delete the folder "C:\Program Files\Mozilla Firefox\"
  4. Install the latest version of Firefox. Here is a direct link: https://download.mozilla.org/?product=firefox-latest-ssl&os=win64&lang=en-US
more options

yes that seemed to help