ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

SSL Error with Firefox

  • 3 ردود
  • 1 has this problem
  • 34 views
  • آخر ردّ كتبه jscher2000

more options

SSL_ERROR_RX_RECORD_TOO_LONG

The issue arose today (06/27/2018)

https://i.imgur.com/JyKPlfF.png

It seems to be mostly Google sites. Searching from the address bar in particular has a 100% failure rate. Although even in writing this message, I had to submit it twice as a result of the error the first time.. Has happened on multiple other sites, but unable to reproduce error since (this is why I decided to create my own topic, as Google seems to be the worst, but it's not exclusive.)

Troubleshooting info provided.

As per the other threads that I read involving suggestions:

It is *ONLY* happening with Firefox. Tested with Chrome, and Lord help me, even Edge.

Firefox is not running a proxy

Safe mode did not rectify the issue

Avast was disabled, did not rectify the issue (Avast is the only security software outside of Defender)

ISP is Spectrum/TWC, using OpenDNS Primary/backup DNS servers - attempted Google DNS as well as default DNS, same error.

Tracert to Google.com produces no timeouts.

Clearing cache (Cookies/site data) did not improve situation.

Modified by SSGTSemperFi

All Replies (3)

more options

hi, thanks for reporting the problem, so far we have heard about this from avast/avg users whose security software is meddling with encrypted connections. firefox 61 introduced the better security protocol tls 1.3 & apparently avast can't cope with that yet.

as a workaround, please try to disable the scanning of https connections as described in https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message#w_avast-and-avg-security-products

more options

philipp said

hi, thanks for reporting the problem, so far we have heard about this from avast/avg users whose security software is meddling with encrypted connections. firefox 61 introduced the better security protocol tls 1.3 & apparently avast can't cope with that yet. as a workaround, please try to disable the scanning of https connections as described in https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message#w_avast-and-avg-security-products

Hiya Philipp,

Thanks for the response!

Disabling scanning appears to have helped significantly, however the error still persists. (as a side note, would there be a reason that disabling avast wouldn't disable the scanning and/or why the issue was still present with Avast disabled as a whole?)

more options

Hi SSGTSemperFi, I don't use Avast, but the key feature here -- the one that sets up as a "man in the middle" of your browser connections -- is the Web Shield. It may be possible to turn some features off while others continue to run.