ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot disable containers

  • 12 ردًا
  • 1 has this problem
  • 7 views
  • آخر ردّ كتبه CDNDaddyBear

more options

This is extremely frustrating. I cannot seem to disable or do anything with "containers" on FireFox.

Here's my story. I belong to an on-line Karaoke website that works with Flash. In order to be heard I have to enable "STEREO MIX" and make it my default communications device. This has been NO problem up until now. For some reason, in the sound mixer, there is a sound item called "firefox Container". The sound from the site "bounces" on that item rather than the Firefox slider. Muting the container only kills the sound.

How do I get rid of the container and get my sound coming through the Firefox icon? I've tried to look for my containers and I have them, but I cannot seem to disable them at all. I've included a pic of my volume mixer. There you can see the container and the Firefox logo but I cannot change the sound to the Firefox.

Thank you so much for any help.

Attached screenshots

All Replies (12)

more options

Adaware Ad Block 2.0.2.7 (AdBlockerLavaSoftFF@lavasoft.com) Adaware Web Protection 1.0.6.0 (@adaware_webprotection) Avast Online Security 18.3.24 (wrc@avast.com)

! problem nay be your Adaware and the other is Avast. To Test please disable Avast. Then do this please and Test : Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu , click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

more options

First of all, thanks for your kind reply.

I disabled Avast. I disabled AdAware Restarted Firefox is safe mode - no addons Flash would not run at all Restarted FireFox in regular mode Flash Runs As soon as flash runs and I use it for music, the plug-in container pops up again and the sound is going through the container and not the FireFox itself. That is silent and muting does nothing. This did not do this before, I don't understand what is happening now.

Thanks for your anticipated help.

more options

Additionally:

I went to YouTube to play a video, and the sound comes from the FireFox icon. The container does not open up. What could this be?

more options

That is the plugin-container that is used by a plugin like Shockwave Flash plugin. So there is probably a website open that uses the Flash plugin to play a media file.

You can set Flash to "Ask to Activate" to disable Flash from running.

more options

Yes. The Karaoke site I am using uses Flash. But previous to this, it had no problem running the flash sound through the regular Firefox volume control. This is just happening in the past couple days. How do I force Flash to play volume through the regular website volume control?

EDIT: I sent a bug report to Adobe mentioning this problem. I can see from other users that they too cannot force audio to play outside the container. It is not VIDEO related so my card (GEForce 210) is not the problem. Perhaps they might have some help.

Modified by CDNDaddyBear

more options

That would be correct as Firefox has a Sandbox that would be holding that but it is supplied by Adobe when Flash is installed.

If this Karaoke site does not need a login what is the URL please ?

Let's try getting rid of years of updated Flash : https://helpx.adobe.com/flash-player/kb/uninstall-flash-player-windows.html

Then a nice clean install : https://get.adobe.com/flashplayer/otherversions/

This should go in when finished as Click to Play unless you have changed settings.

more options

Thank you for your suggestion. I followed all the instructions for removing Flash from my system altogether. I deleted the directories as well.

The URL for the Karaoke website is www.singsnap.com - but you do need a login in order to get into the chat services.

I received a reply on Adobe Flash forum that told me that it could be a problem between the 32 bit version and the 64 bit version. They suggested I download the 32 bit version and install it. They advised I could probably keep them separate. Unfortunately, the 32 bit version of FireFox also puts the Flash into a container.

Still hoping.

more options

Hmm, the slider for Flash in 32-bit Firefox used to say Flash, due to the way protected mode worked in 32-bit. It wasn't under Firefox in recent years, I don't think.

If we assume there's no way to get Flash audio to be under a Firefox slider -- for you or anyone else -- maybe we can turn to the next question: what problem were you trying to solve by changing that?

Is the problem that Flash is not receiving input from your microphone, or that your headphones are not receiving output from Flash? Or something else?

more options

After re-reading your post and the thread on Adobe's forums and SingSnap help, I feel I don't understand what Stereo Mix does. It receives audio input from your microphone, and it receives audio output from applications, at the same time? I'm not sure whether Flash needs to view it as an input device or an output device. Hmm...

Does it matter if you "Set as default device" on Stereo Mix before you start Firefox, or before Firefox launches any Flash content?


For 32-bit Firefox, SingSnap suggests disabling the Flash protected mode feature if Flash cannot receive microphone input. But that doesn't sound like the problem...

more options

jscher2000 said

Hmm, the slider for Flash in 32-bit Firefox used to say Flash, due to the way protected mode worked in 32-bit. It wasn't under Firefox in recent years, I don't think.
      • I was using the 64 bit FireFox. I have been using this site for years and up until very recently, I have always had the music coming from Flash going through the slider with Firefox on it. *******
If we assume there's no way to get Flash audio to be under a Firefox slider -- for you or anyone else -- maybe we can turn to the next question: what problem were you trying to solve by changing that? Is the problem that Flash is not receiving input from your microphone, or that your headphones are not receiving output from Flash? Or something else?

The computer is getting input from the microphone.

more options

jscher2000 said

After re-reading your post and the thread on Adobe's forums and SingSnap help, I feel I don't understand what Stereo Mix does. It receives audio input from your microphone, and it receives audio output from applications, at the same time? I'm not sure whether Flash needs to view it as an input device or an output device. Hmm...
        • Stero Mix is a recording device. It mixes sound from one website puts it together with the microphone and then sends that due back to the people who are listening to the song. Without Stereo Mix, they only get the microphone input and not the song playing on another site. With SM enabled and the default communication device this is acheived. Also, the SM is set to "listen to".****
Does it matter if you "Set as default device" on Stereo Mix before you start Firefox, or before Firefox launches any Flash content?

For 32-bit Firefox, SingSnap suggests disabling the Flash protected mode feature if Flash cannot receive microphone input. But that doesn't sound like the problem...

        • No that is not the problem. The problem is that whereas before Firefox sent the sound coming from Flash to the slider controlling Firefox. When singing live, I check to make sure that both the Firefox slider is "hearing" music by the jumping meter and Stereo Mix also bounces along with the Firefox slider. I've never encountered the CONTAINER before this. And again, I have been with Sing Snap for years.**

Modified by CDNDaddyBear

more options

I've done as much as I can. I really cannot understand why FireFox now wants to put the sound into a container. I even disabled the "block intrusive content" but it still opens up in a container that the Stereo Mix cannot get to.

I am at a loss as to why this, after the years I've been on SingSnap, it wants to put the sound into a container.

Anyone else have any idea?