ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Since latest update (now on 60.0.2 64bit) gifs, animations, videos very slow and jerky

  • 12 ردًا
  • 2 have this problem
  • 1142 views
  • آخر ردّ كتبه crueby1

more options

I have tried turning off addons, tried safe mode, no change. Previously everything was fine till update.

Now, videos like on youtube run at a very low framerate, animated icons just crawl, countdowns that should be one per second are running at one per 5 seconds, everything that should be moving is very slow. Browsing to new pages is fine. Have tried some of the suggested changes to settings, nothing helps.

الحل المُختار

Well, seem to have a solution. Got a suggestion offline to try this command then reboot:

bcdedit /set useplatformclock true

Problem is now completely gone, all animations and videos running smooth again in Firefox, like it was a couple weeks ago. No idea what changed to cause this but that command worked.

Thanks to all for your assistance!

Read this answer in context 👍 0

All Replies (12)

more options

Hi please see this, if make changes restart Firefox and test : https://www.reddit.com/r/firefox/comments/76bzmi/possible_solution_to_choppy_1080p_60_fps_youtube/

more options

Pkshadow said

Hi please see this, if make changes restart Firefox and test : https://www.reddit.com/r/firefox/comments/76bzmi/possible_solution_to_choppy_1080p_60_fps_youtube/

Just made those setting changes, restarted, and tested - no change to video playback or to animated icons at all. I have also tried turning hardware decoding on and off, tried different numbers of processes in the advanced settings too - none had any effect on this problem.

more options

Hi crueby1!

I read an article on the Mozilla Support Page and it says that Firefox Quantum will no longer be supporting NPAPI plugins like Adobe Flash, Shockwave Flash, and Silverlight, because there are more and more static pages on the internet, and I think that a solution to this problem is to downgrade to Firefox ESR or older. (but don't got back to those really old versions like 10.0) The page with the different versions of Firefox is https://ftp.mozilla.org/pub/firefox/releases/ . I recommend scrolling down to Firefox 52.0 and installing that.

You also may need to load the plugins manually, so you can access that page at https://support.mozilla.org/en-US/kb/npapi-plugins

more options

ThePriusMan said

Hi crueby1! I read an article on the Mozilla Support Page and it says that Firefox Quantum will no longer be supporting NPAPI plugins like Adobe Flash, Shockwave Flash, and Silverlight, because there are more and more static pages on the internet, and I think that a solution to this problem is to downgrade to Firefox ESR or older. (but don't got back to those really old versions like 10.0) The page with the different versions of Firefox is https://ftp.mozilla.org/pub/firefox/releases/ . I recommend scrolling down to Firefox 52.0 and installing that. You also may need to load the plugins manually, so you can access that page at https://support.mozilla.org/en-US/kb/npapi-plugins

I'd rather not downgrade to an older version (again - had to do that a couple years ago) just to work around a bug that I am trying to report and hopefully get fixed!

more options

So then give us a link to the troublesome video or site so others can run to see if the problem shows up on their side to know if this is a Site or ISP or Browser caused problem.

more options

WestEnd said

So then give us a link to the troublesome video or site so others can run to see if the problem shows up on their side to know if this is a Site or ISP or Browser caused problem.

Sure thing - it is on any video, animation, icon, whatever. Here are two simple examples, checked them on other browsers to see the difference, the speed of them on the current Firefox is 1/3 to 1/4 as on other browsers. The video difference is very clear too.

simple animation: https://tenor.com/view/emoji-silly-gif-10474657

videos: https://www.youtube.com/watch?v=ET36Cl1T4mw https://www.youtube.com/watch?v=ocen9JeWzdk

Videos.animations run fine in standalone players and other browsers (chrome, IE).

more options

No problem loading those sites. So what A/V and Firewall and addons do you have installed?

more options

WestEnd said

No problem loading those sites. So what A/V and Firewall and addons do you have installed?

Loading the sites is not the issue, everything does load okay, no errors. Its once they are loaded, anything moving (in images, videos, animations, whatever) is going at 1/4 to 1/3 the speed it does in any other browser or on any other device.

I ran with it in safe mode, same behavior, and also tried it with all add-ons off in normal mode, again no change. I just have the addons it came with, have not added any other video ones. I do have flash addon, but it is disabled by default, must ask to enable. My firewall is AVG Internet Security.

more options

Additional easy way to see this problem - go to eBay, into an auction listing, and look at the countdown timer till the auction ends (days, hours, minutes, seconds) - the seconds numbers count down by 1 number every 4 seconds. Does that help narrow where the issue would be?

more options

HI, 2 things answer is your using NoScript

I would think the other answer is with your Video Card Drivers, there is a couple errors in them. I have HD 7970 and get updates monthly. Here is your info on that : adapterDescription: AMD Radeon HD 7400 Series driverDate: 8-3-2015 Suggest updating and save full installer as will be out EOL soon if not already for you : https://support.amd.com/en-us/download

See what happens after updating and turn off NoScript

more options

Hi Pkshadow - Just doublechecked on the display driver, AMD has not put one out for this card in a couple years, and I have their latest posted version already. I had tried it with addons disabled before, safe mode too. Just in case, tried that again, turned off all the addons including noscript, no difference in the behavior. Hope its not the graphics card, dont want to have to start upgrading hardware if I dont have to, it works fine in all other applications, including Autodesk CAD, movie players, etc. Any way to narrow it down for sure? Even simple things like the timer countdown in ebay auctions run slow, as I mentioned the other day. Very odd - they were fine till recently. Thanks for your help, any other suggestions? Chris

more options

الحل المُختار

Well, seem to have a solution. Got a suggestion offline to try this command then reboot:

bcdedit /set useplatformclock true

Problem is now completely gone, all animations and videos running smooth again in Firefox, like it was a couple weeks ago. No idea what changed to cause this but that command worked.

Thanks to all for your assistance!