Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Amazon slow after Quantum upgrade

  • 2 replies
  • 1 has this problem
  • 486 views
  • آخر ردّ كتبه mizring

more options

Ever since I upgraded to Quantum (Mac OS 10.13.3), the Amazon website is extremely slow. Every single page stalls/hangs and I have to wait several seconds to continue. This does not seem to happen with other websites, and it does not happen in other browsers. It is extremely irritating since I am often on Amazon. I've tried restarting in safe mode and the problem persists.

Chosen solution

Hi, separate security issue, please update your Flash 26.0 r0 Flash Player Version: 29.0.0.171 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Try after updating.

Also if still not working properly : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Hi, separate security issue, please update your Flash 26.0 r0 Flash Player Version: 29.0.0.171 Current Version https://get.adobe.com/flashplayer/otherversions/ Step 1: Select Operating System Step 2: Select A Version (Firefox, . . . .) Note: Other software is offered in the download. <Windows Only>

Try after updating.

Also if still not working properly : SAFE MODE

In Firefox Safe mode these changes are effective:

  • all extensions are disabled (about:addons)
  • default theme is used (no persona)
  • userChrome.css and userContent.css are ignored (chrome folder)
  • default toolbar layout is used (file: localstore-safe.rdf)
  • Javascript JIT compilers are disabled (prefs: javascript.options.*jit)
  • hardware acceleration is disabled (Options > Advanced > General)
  • plugins are not affected
  • preferences are not affected

TEST''''is issue still there ?

more options

Thank you. Still slower than it used to be, but this has definitely helped.