ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Flash Display

  • 31 ردًا
  • 1 has this problem
  • 273 views
  • آخر ردّ كتبه jchris1_2000

more options

When I used Firefox 60 and 60.0.1 It had some flash games images distorted and would have a line going across the screen. Site with loading and display issues from title image, to load circle, and in game items.

Modified by jchris1_2000

الحل المُختار

As a test for 60.0.2 (not Nightly), can you try this?

  1. In the address bar, type about:config, press Enter and accept the warning/risk.
  2. In the Search field, type webgl.angle.force-warp or a part of it.
  3. Double-click the line to set this preference’s value to true (it should currently be false and not displayed in bold).
  4. Restart Firefox and see if the issue still occurs.

Also, What’s the name or URL of the game?

Read this answer in context 👍 1

All Replies (11)

more options

Thank you for the feedback, this may be valuable info.

If the issue started in Nightly builds the same day as reported in the bug (March 3), I’d say you’re most likely affected by it, also looking at the screenshot.

Could you please download the next 2 FF Nightly versions to verify?
March 2 build March 4 build

Unzip each of them in separate folders, e.g. C:\Program Files\firefox_march_2 and C:\Program Files\firefox_march_4. Easiest would be to rename the unpacked firefox folders from the zip after unpacking them into C:\Program Files\.

For both version’s firefox.exe files, create startup shortcuts on your desktop and modify them (right-click > Properties > Target field) so they contain -no-remote -p.

"C:\Program Files\firefox_march_2\firefox.exe" -no-remote -p

At first launch using the shortcut, you will see the Profile Manager. Create a profile called test and then run Firefox by clicking Start Nightly. After creating the profile, both shortcuts can be modified to include the profile name so Nightly will run without starting the Profile manager.

"C:\Program Files\firefox_march_2\firefox.exe" -no-remote -p test

You may need to disable hardware acceleration for the new profile, unless you never had to, but doing so may be best in order to exclude that and reproduce like in the bug. Do not launch the regular 59 or 60 esr version, uninstalling them is not necessary.

Could you let us know if the issue reported does not occur in the March 2 build but does in the March 4 build? Also, what’s the name of the game and where to find it?

When in doubt about the game being Flash or not, you may want to uninstall Flash temporarily or set it to Never activate in Nightly’s Add-on Manager > Plugins.

more options

I had that when it came out and ran it, version 58 all, and version 59 all with no trouble as stated earlier. version 60 is where the display is having issues. I have not used nightly in over a year so it is not where this started.

Modified by jchris1_2000

more options

My question is, could you run both nightly versions above sequentially and verify whether the issue occurs in the latest build, but not the older one? Your feedback would be appreciated.

more options

Mach 2 works fine. Mach 4 has the same issue.

more options

Thank you, that kind of verifies it is the same bug. I suggest to keep an eye on it for now - let’s hope it will be fixed or at least provide a workaround.

more options

so in the time being I should use Mach 2 until I see a Firefox update?

more options

I’m afraid using the March 2 build would be your best bet, yes, or stick with Firefox 59, which will likely be disadvised by others. Also keep an eye on the bug (you can create a Bugzilla account and follow it if you like), as this issue will not get fixed in release versions until the bug is, or a workaround will be provided there. I haven’t been able to change a preference in Firefox so far in order to find one. Yet I’m sure other games will be affected too, thanks to your report in fact. ;)

The issue clearly occurs on G4x integrated graphics chipsets with the Intel driver(s) reported but possibly for other chipsets/drivers too (still unsure - and it’s not a Flash issue), and the question is whether or not developers will or can fix that without blaming those chipsets or drivers. Of course my hopes are they provide a fool-proof fix knowing the issue will not occur on any chipset, but that may be hard. Given that someone wrote "We may need to push you off the GPU onto WARP to ensure things render properly.", I hope that will be what they do and will work at least, if there is no other option.

Note that hardware acceleration is also limited for this chipset ever since Firefox 38, caused by another bug in the past. I wasn’t happy with that either (especially after explicitely buying that mainboard brand new a few years before then, and knowing hardware acceleration is supported for this chipset as of a specific driver version), yet the reason for that was certain drivers are pushed beyond their limitations, sort of. Another option for you would therefore be to add a separate graphics card with better quality and more recent drivers, which is likely impossible for laptops.

more options

Tonnes said

Also keep an eye on the bug (you can create a Bugzilla account and follow it if you like)

You only need a Bugzilla account to post things. If you just want to keep an eye on it, no account is needed.

more options

You need a Bugzilla account to add your email to the CC list to be notified when changes are made to the bug.

more options

الحل المُختار

As a test for 60.0.2 (not Nightly), can you try this?

  1. In the address bar, type about:config, press Enter and accept the warning/risk.
  2. In the Search field, type webgl.angle.force-warp or a part of it.
  3. Double-click the line to set this preference’s value to true (it should currently be false and not displayed in bold).
  4. Restart Firefox and see if the issue still occurs.

Also, What’s the name or URL of the game?

Modified by Tonnes

more options

Set force warp to version 61.0.1 and restarted The different games on their sites work fine now. I also tried on Nightly 63.0a1 and everything works. One site is https://www.nutaku.net/games/kamihime-r The other links are adult themed like the games so was asked to remove them already. Thanks for the help.

Modified by jchris1_2000

  1. 1
  2. 2