Search Support

What level of encryption does my firefox have? (Yahoo!edition yahoo-1.20)

  • 4 replies
  • 2 have this problem
  • 387 views
  • آخر ردّ كتبه FredMcD

more options

I need to use a website which requires me to have a browser with 128-bit encryption. I don't know what my firefox browser's level is. the "about firefox" box on my desktop says my current is Yahoo!edition yahoo-1.20. It also tells me it can't be updated. Thank you. PS: I've tried to use safari to go to this US government agency website, but safari won't "safely" open that page. I can get to that .gov website with firefox, but need to know answer to level of encryption.

Chosen solution

Firefox has supported 256-bit encryption for a very long time if the site provides support so the old Firefox 48.0.2 have certainly supports 128-bit.

https://www.fortify.net/sslcheck.html

Read this answer in context 👍 0

All Replies (4)

more options

Chosen Solution

Firefox has supported 256-bit encryption for a very long time if the site provides support so the old Firefox 48.0.2 have certainly supports 128-bit.

https://www.fortify.net/sslcheck.html

more options

Note that you can find the official Firefox version here:

more options

Hello,

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.