ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

CloudFlare keeps repating browser check on Mozilla Firefox

  • 42 ردًا
  • 1 has this problem
  • 282 views
  • آخر ردّ كتبه Hadong

more options

I have trouble accessing some websites where is CloudFlare protection. It keeps repeating and repeating check of browser and it never ends. Example of website which don't work: https://ddlcmods.fun/ . My computer was completely reinstalled week ago to Windows 10 and Firefox is fresh too so there can't be problems with them. I was googling it and found that can be problem with time zones which I tried to change and no luck. Also something with DNS where I don't try because I'm afraid of doing something wrong. And I tried same website with Windows edge, there was no problem, it successfully passed check. I hope for fast response. Here is screenshot of problem below.

All Replies (20)

more options

GµårÐïåñ said

I can access the site just fine in my regular profile, after waiting a few seconds for the Cloudflare bouncing balls to do their thing it redirects just fine to the site. Can you check your DNS servers, it might be it is having edge access issues and is not resolving correctly. Try something like 1.0.0.1 or 8.8.8.8 and if that works, then you know it's probably your DNS or a regional issue.

Okay, but I'll need explanation about because I don't know how to do that...

EDIT: I tried googling about DNS and found something, I enabled that thing and enteret 8,8,8,8 in first section and 8,8,4,4 in second. Nothing changed. Also restarted PC after that. What about region? I'm in Latvia, before PC reinstall site was working. Screenshot below.

Modified by KaiminsLV

more options

KaiminsLV said

Okay, but I'll need explanation about because I don't know how to do that... EDIT: I tried googling about DNS and found something, I enabled that thing and enteret 8,8,8,8 in first section and 8,8,4,4 in second. Nothing changed. Also restarted PC after that. What about region? I'm in Latvia, before PC reinstall site was working. Screenshot below.

Ok, I am glad you found how to change it. Google servers are pretty global so that should have fixed any regional issues but there are some regional nonsense that can sometimes cause issues none the less.

So, go into that DNS screen in your picture, click on Advanced, then go to the DNS tab where you can add more servers without just limiting yourself to two. Add them in this order and see if anything changes:

1.0.0.1 8.8.8.8 208.67.222.222 209.244.0.3 1.1.1.1 8.8.4.4 208.67.220.220 209.244.0.4

These include very large DNS networks, and also a few backbone providers which should pretty much guarantee you find anything. Although later, you might want to trim your list down a bit, while also redundancy doesn't hurt.

Also, try and clear our your DNS cache and reset your winsock while you are at it.

1. Change the DNS servers (add them to your list) 2. Open a command prompt as administrator and enter: ipconfig /flushdns 3. After it tells you its done, enter: netsh winsock reset 4. When done, restart your machine

Try then and see what happens.

Modified by GµårÐïåñ

more options

I done everything you said there from end to start ( I flushed that DNS and then I added IP's, is that okay?). I don't know how, but it still not fixed the problem. Any other suggestions? Thank you that you are helping me with my shitty problem :D

more options

Unfortunately I can't think of anything else without some context. Try using an EU specific DNS server in the mix, and/or a good Latvian DNS server that is 100% redundant.

Take a look here to get started or Google it. https://public-dns.info/nameserver/lv.html

more options

Works for me.

Checking your browser before accessing ddlcmods.fun.

This process is automatic. Your browser will redirect to your requested content shortly.

Please allow up to 5 seconds…
DDoS protection by Cloudflare

Note that you need to allow cookies to make this work. I see a cookie named cf_clearance, so it sounds that when this cookie isn't created then you can't proceed from the checking.

more options

cor-el said

Works for me.
Checking your browser before accessing ddlcmods.fun.

This process is automatic. Your browser will redirect to your requested content shortly.

Please allow up to 5 seconds…
DDoS protection by Cloudflare

Note that you need to allow cookies to make this work. I see a cookie named cf_clearance, so it sounds that when this cookie isn't created then you can't proceed from the checking.

How do I check if my cookies are enabled? I think they are. I took screenshot of that section in Firefox.

more options

Do you see cookies from ddlcmods.fun if you click Manage Data or check this in the Storage Inspector?

Did you check the cookie exceptions?

Are you using any extensions that deal with cookies?

more options

Screenshots of things you asked there below...


EDIT: Done checking with everything in that article, tried safe mode and performance thing, didn't help.

Modified by KaiminsLV

more options

Did you check in the Storage Inspector what cookies Firefox creates for that domain (you need to open the website in a tab)?

more options

cor-el said

Did you check in the Storage Inspector what cookies Firefox creates for that domain (you need to open the website in a tab)?

I already posted screenshot of Storage in that website. I'll post another screenshot of that..

more options

Sorry, I missed the lower part of that rather large screenshot. I only see one cookie in the screenshot and not the second cookie (cf_clearance) I mentioned above that gets created once the check has passed.


The Network Monitor shows this request to submit the challenge form.

There are additional parameters under the Cookies and Params tab.

  • http://ddlcmods.fun/cdn-cgi/l/chk_jschl?jschl_vc=<data>

The server responds with a Set-Cookie header and a location header (302 Moved Temporarily).

  • Set-Cookie : cf_clearance
  • Location: http://ddlcmods.fun/

Modified by cor-el

more options

I don't get what you actually wanted me to do now, so I just post screenshots of that Network tab.

more options

Hmm 503 means Service Unavailable and I get that if I block cookies. I see that the cf_clearance cookie isn't created and isn't send with the second request when following the location header.

To get success both cookies will have to be send to the server. Request cookies: __cfduid: <data> cf_clearance: <data>

So it looks that something is blocking the creation of these cookies.


You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox from this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.


You can create a new profile to test if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

more options

Okay so, I done that "Forget about website" step, that didn't work.

And I already tried before creating new profile in that menu and it didn't helped too.

more options

Does Google translate give you page content?

Boot the computer in Windows Safe mode with network support to see if that has effect in case security software is causing problems.

more options

Yes, page content is shown in Google translate, screenshot of that below.. Note that links are working too with translate.

Booted PC into Safe mode with Networking and problem is still there.

Modified by KaiminsLV

more options

Im suprised no one has mentioned it yet, but this problem is NOT firefox related at all!

The site in question (and others mentioned) have set their site to "Under Attack Mode" in the cloudflare dashboard which checks every visitor, everytime they visit.

Google, Yahoo, Yandex, Bing etc. bots are whitelisted by Cloudflare and won't be checked using this option. (however you can block everything manually if you wish).

There is no fix, but reaching out to the site owners, and ask them to disable the "Under Attack Mode" and instead employ their own security rules through Cloudflare.

You probably won't have much luck though, as most of these site owners don't know what they're doing, and thus simply checks "Under Attack Mode" to be safe.

Edit: As for ddlcmods. fun i've tested it in 5 different browsers now, including Edge multiple times and got the browser check everytime, even with persistent cookies, and privacy clearout disabled.

Modified by Hadong

more options

Hadong said

Im suprised no one has mentioned it yet, but this problem is NOT firefox related at all! The site in question (and others mentioned) have set their site to "Under Attack Mode" in the cloudflare dashboard which checks every visitor, everytime they visit. Google, Yahoo, Yandex, Bing etc. bots are whitelisted by Cloudflare and won't be checked using this option. (however you can block everything manually if you wish). There is no fix, but reaching out to the site owners, and ask them to disable the "Under Attack Mode" and instead employ their own security rules through Cloudflare. You probably won't have much luck though, as most of these site owners don't know what they're doing, and thus simply checks "Under Attack Mode" to be safe. Edit: As for ddlcmods. fun i've tested it in 5 different browsers now, including Edge multiple times and got the browser check everytime, even with persistent cookies, and privacy clearout disabled.

Yeah, maybe you're right, but in my case, if you read this discussion properly, then in edge that site is working and in translator it's showing site's content and even I can access links in there using translator. And this started after I reinstalled my PC to Win10 from Win7, there were no problems with that. I was using chrome and firefox before.

more options

KaiminsLV said

Yeah, maybe you're right, but in my case, if you read this discussion properly, then in edge that site is working and in translator it's showing site's content and even I can access links in there using translator. And this started after I reinstalled my PC to Win10 from Win7, there were no problems with that. I was using chrome and firefox before.

Well it doesn't for me, that site always brings up the cloudflare check in all browsers i tested (including edge).

Yes of course, i already mentioned why google translator and the likes are working in my last reply: "Google, Yahoo, Yandex, Bing etc. bots are whitelisted by Cloudflare and won't be checked using this option."

Im 100% sure, the Cloudflare checks have nothing to do with your Win7 to Win10 upgrade, since i get checked from any and all ip's + all browser i've tested (Im on Win7 x64).

Probably they just didn't have the "I'm Under Attack" mode turned on before.

more options

Hadong said

KaiminsLV said
Yeah, maybe you're right, but in my case, if you read this discussion properly, then in edge that site is working and in translator it's showing site's content and even I can access links in there using translator. And this started after I reinstalled my PC to Win10 from Win7, there were no problems with that. I was using chrome and firefox before.

Well it doesn't for me, that site always brings up the cloudflare check in all browsers i tested (including edge).

Yes of course, i already mentioned why google translator and the likes are working in my last reply: "Google, Yahoo, Yandex, Bing etc. bots are whitelisted by Cloudflare and won't be checked using this option."

Im 100% sure, the Cloudflare checks have nothing to do with your Win7 to Win10 upgrade, since i get checked from any and all ip's + all browser i've tested (Im on Win7 x64).

Probably they just didn't have the "I'm Under Attack" mode turned on before.

I don't think so, I tried that site on other PC with Firefox too, it was working. Same in mobile.

Okay, if you think that it has nothing to do with Firefox at all but with my PC, then what solution can solve this? Contacting their website directly?

  1. 1
  2. 2
  3. 3