X
Tap here to go to the mobile version of the site.

منتدى الدعم

Video playback not working in Firefox Quantum eg on Al Jazeera English website

Posted

Example problem page: https://www.aljazeera.com/programmes/insidestory/2018/04/palestinian-journalists-targeted-israeli-snipers-180428181902831.html

When I press the play button in Firefox Quantum 59.0.2 (64-bit) playback is not instigated. Nothing happens. This has been occurring since I updated to Quantum. I cannot see that there are any add-ons / plugins I require to make the iFrame play.

Image 1 below shows the black iFrame screen that accompanies the malfunction in Firefox.

Image 2 below shows the IFrame screen as it appears in Google Chrome (in which the video playback is functioning normally).

Please help?

Example problem page: https://www.aljazeera.com/programmes/insidestory/2018/04/palestinian-journalists-targeted-israeli-snipers-180428181902831.html When I press the play button in Firefox Quantum 59.0.2 (64-bit) playback is not instigated. Nothing happens. This has been occurring since I updated to Quantum. I cannot see that there are any add-ons / plugins I require to make the iFrame play. Image 1 below shows the black iFrame screen that accompanies the malfunction in Firefox. Image 2 below shows the IFrame screen as it appears in Google Chrome (in which the video playback is functioning normally). Please help?
Attached screenshots

Additional System Details

Installed Plug-ins

  • Shockwave Flash 29.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:59.0) Gecko/20100101 Firefox/59.0

More Information

FredMcD
  • Top 10 Contributor
4271 solutions 59900 answers

That web page uses; Brightcove Player Version 6.18.1 I had no problem with it.

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: Tracking Protection {web link}

That web page uses; Brightcove Player Version 6.18.1 I had no problem with it. Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? --------------- One issue that seems more common lately is Firefox's Tracking Protection feature. When it is blocking content in a page, a shield icon will appear at the left end of the address bar next to the padlock icon. This article has more info on managing this feature: [https://support.mozilla.org/en-US/kb/tracking-protection Tracking Protection] {web link}

Question owner

Thanks for your help on this.

I restarted Firefox in Safe Mode but it did not fix the problem.

There is no shield icon appearing in the address bar.

I emailed Brightcove as Al Jazeera English is not responding to my calls for help. Brightcove said they will not deal directly with Al Jazeera customers, so I am at a loss as to know what to do next to fix the problem.

Thanks for your help on this. I restarted Firefox in Safe Mode but it did not fix the problem. There is no shield icon appearing in the address bar. I emailed Brightcove as Al Jazeera English is not responding to my calls for help. Brightcove said they will not deal directly with Al Jazeera customers, so I am at a loss as to know what to do next to fix the problem.
FredMcD
  • Top 10 Contributor
4271 solutions 59900 answers

What is Brightcove?

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

What is Brightcove? Start your '''Computer''' in safe mode with network support. Then start Firefox. Try '''Secure''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Question owner

As you stated above, Brightcove is the player.

I was not able to follow your instructions because my version of Windows 10 seems not to allow me to connect to the internet in 'Safe Mode with networking'. I followed the instructions at https://community.spiceworks.com/how_to/125006-how-to-restore-wi-fi-connection-in-windows-10-safe-mode but was not able to view available network connections from the Logon screen. If you have any further thoughts on how I might do this, I would be grateful to hear them.

I'm not sure what you mean by 'Secure websites'. Can you explain this?

Many thanks

As you stated above, Brightcove is the player. I was not able to follow your instructions because my version of Windows 10 seems not to allow me to connect to the internet in 'Safe Mode with networking'. I followed the instructions at https://community.spiceworks.com/how_to/125006-how-to-restore-wi-fi-connection-in-windows-10-safe-mode but was not able to view available network connections from the Logon screen. If you have any further thoughts on how I might do this, I would be grateful to hear them. I'm not sure what you mean by 'Secure websites'. Can you explain this? Many thanks
FredMcD
  • Top 10 Contributor
4271 solutions 59900 answers

I called for more help.

A secured website has an address that starts with; https: meaning it is secured from the bad stuff.

I called for more help. A secured website has an address that starts with; https: meaning it is secured from the bad stuff.
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159015 answers

I have third-party cookies disabled by default and notice this message in the Web Console.

VIDEOJS: WARN:  DOMException: The operation is insecure.

This usually means that you need to allow third-party cookies for specific domain(s). A quick test shows that it work when I enable all third-party cookies.

I need to create an "allow for session" cookie exception to make the player work.

I have third-party cookies disabled by default and notice this message in the Web Console. VIDEOJS: WARN: DOMException: The operation is insecure. This usually means that you need to allow third-party cookies for specific domain(s). A quick test shows that it work when I enable all third-party cookies. I need to create an "allow for session" cookie exception to make the player work. *https://players.brightcove.net

Modified by cor-el

Question owner

Thanks for your help with this.

Yes, in Firefox Options > Privacy & Security > Browser Privacy I have third-party cookies set to 'Never'. Are you suggesting I should change this? I can see where I can add an exception for website cookies, but not for third-party cookies. Should I change a setting here? (see attachment 1)

I can now see a shield icon in the address bar, but cannot fathom which setting/s I should change here either. You can see the settings I currently have in attachments 2 & 3. Can you let me know which setting/s (if any) I should change here in order to enable the video to play?

Thanks for your help with this. Yes, in Firefox Options > Privacy & Security > Browser Privacy I have third-party cookies set to 'Never'. Are you suggesting I should change this? I can see where I can add an exception for website cookies, but not for third-party cookies. Should I change a setting here? (see attachment 1) I can now see a shield icon in the address bar, but cannot fathom which setting/s I should change here either. You can see the settings I currently have in attachments 2 & 3. Can you let me know which setting/s (if any) I should change here in order to enable the video to play?
FredMcD
  • Top 10 Contributor
4271 solutions 59900 answers

First, allow 3rd party cookies. If this solves the problem, then we can figure out which cookies need to be allowed.

First, allow 3rd party cookies. If this solves the problem, then we can figure out which cookies need to be allowed.

Question owner

Thanks. Having to enable all third-party cookies is not ideal for me. I wish Firefox enabled us to make third-party cookie exceptions for specific sites rather than having a one-size fits all approach. If this is all that Firefox can offer, I suppose I have no choice.

Thanks. Having to enable all third-party cookies is not ideal for me. I wish Firefox enabled us to make third-party cookie exceptions for specific sites rather than having a one-size fits all approach. If this is all that Firefox can offer, I suppose I have no choice.
FredMcD
  • Top 10 Contributor
4271 solutions 59900 answers

FredMcD said

First, allow 3rd party cookies. If this solves the problem,
then we can figure out which cookies need to be allowed.
''FredMcD [[#answer-1106495|said]]'' <blockquote> First, allow 3rd party cookies. If this solves the problem,<br> then we can figure out which cookies need to be allowed. </blockquote>
cor-el
  • Top 10 Contributor
  • Moderator
17578 solutions 159015 answers

You only need to create an allow for session exception for the domain I mentioned to make this website work. Exception rules for a specific domain are automatically applied to cookies loaded by other domains, so if a website needs to access data from other domains (cross domain access) then this allow exception makes it possible.


Click the cookie Exceptions button to open the exceptions window. Paste this URL in the web address field and click the "Allow for Session" button to create the new exception.

Click "Save Changes" to confirm the new rule.

You only need to create an allow for session exception for the domain I mentioned to make this website work. Exception rules for a specific domain are automatically applied to cookies loaded by other domains, so if a website needs to access data from other domains (cross domain access) then this allow exception makes it possible. ---- Click the cookie Exceptions button to open the exceptions window. Paste this URL in the web address field and click the "Allow for Session" button to create the new exception. *https://players.brightcove.net Click "Save Changes" to confirm the new rule.