X
Tap here to go to the mobile version of the site.

منتدى الدعم

Running OSX10.6.8, USPS says they don't support old firefox will I have to switch to Safari?

Posted

Got a message today that as of May 1, 2018 USPS.COM will only support current firefox software. I am running an old MAC computer with OSX 10.6.8. I tried to upgrade on you site and it said my MAC is not compatible. Does that mean that after 15 years of firefox I must not switch to Safari? Bummer. Guess us old people are out of luck. It has been a great run. Thanks for the service.

Got a message today that as of May 1, 2018 USPS.COM will only support current firefox software. I am running an old MAC computer with OSX 10.6.8. I tried to upgrade on you site and it said my MAC is not compatible. Does that mean that after 15 years of firefox I must not switch to Safari? Bummer. Guess us old people are out of luck. It has been a great run. Thanks for the service.

Additional System Details

Installed Plug-ins

  • Adobe® Acrobat® Plug-in for Web Browsers, Version 11.0.03
  • The Flip4Mac WMV Plugin allows you to view Windows Media content using QuickTime.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 29.0 r0
  • Plugin for Wacom tablets.
  • iPhoto6

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:48.0) Gecko/20100101 Firefox/48.0

More Information

James
  • Top 25 Contributor
  • Moderator
1603 solutions 11348 answers

https://support.mozilla.org/en-US/kb/firefox-osx - Firefox support has ended for Mac OS X 10.6, 10.7 and 10.8

Firefox 45.9.0esr will be the most up to date version with security fixes that will run on OS X 10.6, 10.7 and 10.8 as Firefox 49.0 and later requires OSX 10.9 or later.

http://archive.mozilla.org/pub/firefox/releases/45.9.0esr/mac/ http://archive.mozilla.org/pub/firefox/releases/45.9.0esr/mac/en-US/

The Firefox 48.0.2 was released August 24, 2016 and is missing several security updates that the Firefox 45.9.0esr released on April 19, 2017 has.

You could perhaps use a useragent switcher extension to make Firefox send a useragent of a more current version of Firefox when using the USPS site.

https://addons.mozilla.org/en-US/firefox/search/?q=useragent

Chrome, Chromium and Opera dropped support of OS X 10.6, 10.7 and 10.8 back in April 2016.

https://support.mozilla.org/en-US/kb/firefox-osx - Firefox support has ended for Mac OS X 10.6, 10.7 and 10.8 Firefox '''45.9.0esr''' will be the most up to date version with security fixes that will run on OS X 10.6, 10.7 and 10.8 as Firefox 49.0 and later requires OSX 10.'''9''' or later. http://archive.mozilla.org/pub/firefox/releases/45.9.0esr/mac/ http://archive.mozilla.org/pub/firefox/releases/45.9.0esr/mac/en-US/ The Firefox 48.0.2 was released August 24, 2016 and is missing several security updates that the Firefox 45.9.0esr released on April 19, 2017 has. You could perhaps use a useragent switcher extension to make Firefox send a useragent of a more current version of Firefox when using the USPS site. https://addons.mozilla.org/en-US/firefox/search/?q=useragent Chrome, Chromium and Opera dropped support of OS X 10.6, 10.7 and 10.8 back in April 2016.

Modified by James