Search Support

Beware of phishing attacks: Mozilla will never ask you to call a number or visit a non-Mozilla website. Please ignore such requests.

Learn More

Insecure connectoin on one website after another.

  • 11 replies
  • 1 has this problem
  • 60 views
  • آخر ردّ كتبه cor-el

more options

All websites are giving me an error. City & state governments and websites I used yesterday, etc.

I don't want to do anything foolish, but this has become tedious.

I have none of the AVs listed in your instructions and Avira never presented problems before.

This is just one example: budget.weho.org uses an invalid security certificate. The certificate is only valid for the following names: *.herokuapp.com, herokuapp.com Error code: SSL_ERROR_BAD_CERT_DOMAIN

Chosen solution

You really need to use the HTTP protocol to access this website, so you will have to add an exception in HTTPS Everywhere.

Read this answer in context 👍 0

All Replies (11)

more options

CiaoBella1 said

SSL_ERROR_BAD_CERT_DOMAIN

Is this the only error message from all of the websites?


There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

https://support.mozilla.org/en-US/kb/secure-connection-failed-error-message

https://support.mozilla.org/en-US/kb/connection-untrusted-error-message

http://kb.mozillazine.org/Error_loading_websites


  • uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN
  • configured their website improperly

How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

more options

No, there were different certificates listed and there were other messages. Here is one more: Your connection is not secure The owner of budget.weho.org has configured their website improperly. To protect your information from being stolen, Firefox has not connected to this website.

i contacted someone at the Wisconsin state website and she said she'd been using it all day. I got in when I tried the last time. Are instructions specific to other AV are relevant to Avira?

I read the longest solution - your last link - and I cannot see how any apply to my computer and me. That's why I wrote.

Thank you.

more options

CiaoBella1 said

The owner of budget.weho.org has configured their website improperly

Look at the last entries of my post above.

I read the longest solution - your last link - and I cannot see how any apply to my computer and me.

The problem is likely caused by your protection programs.

FredMcD said

There is security software like . . . . . . that intercept secure
connections and send their own certificate.

What protection programs are you using? Contact their support.

more options

Avira.

Thank you.

more options

Keep us posted.

more options

I just got insecure connections to Mozilla Forum and trying to access my IP address.

I cannot figure out what to do with Avira. No settings have changed and I have real-time protection enabled without much else. Avira forum seem useless.

I give up for a while.

Thank you.

more options

Update Avira. If the problem is still there, disable it as a test.

more options

CiaoBella1 said

budget.weho.org uses an invalid security certificate. The certificate is only valid for the following names: *.herokuapp.com, herokuapp.com Error code: SSL_ERROR_BAD_CERT_DOMAIN

Usually, the BAD_CERT_DOMAIN error indicates the site is not set up for HTTPS and is meant to be accessed using HTTP.

Are you using any extensions that "upgrade" HTTP connects to HTTPS? Those could cause this problem because although the server has HTTPS, it isn't a certificate Firefox can trust.

If the site doesn't involve sensitive information, try using just HTTP (i.e., edit the S out of the protocol part of the address).

more options

jscher2000 - HTTPS Everywhere. But I got it using Mozilla forum...

Thank you,

more options

Fred McD.

I will try disabling Avira. Keep you posted.

Thank you.

more options

Chosen Solution

You really need to use the HTTP protocol to access this website, so you will have to add an exception in HTTPS Everywhere.