ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Location sharing not working and also not prompting

  • 9 ردود
  • 1 has this problem
  • 1195 views
  • آخر ردّ كتبه nilueps

more options

I cannot share my location on websites such as maps.google.com or openstreetmap.org

Firefox does not prompt me to share my location and even if I give permission manually, it still doesn't work.

Refreshing Firefox made no difference.

"geo.enabled" is set to **true**

الحل المُختار

Solution found! The issue was related to the resistFingerprinting variable.

Navigating to about:config and setting privacy.resistFingerprinting back to false fixed the issue.

Read this answer in context 👍 0

All Replies (9)

more options
more options

I tried everything on that page, to no avail.

more options

I called for more help.

more options

Some websites do not use Geoloaction, but do a reverse DNS look up to determine your location. Only when Geolocation is used you will be prompted to allow to share your location.

You can use websites like these to see how your location is reported via a reverse DNS look up of your IP:

more options

These two websites give conflicting results, but I am using a VPN so that is not so surprising.

My question pertains to websites which DO use geolocation.

So far I have tried running in safe mode, with add-ons disabled and refreshing firefox but none of these fix the issue.

Should I simply re-install firefox completely?

more options

Anyone?

Following suggestions on another thread, I deleted the permissions.sqlite file from my profile folder and allowed firefox to rebuild it.

Still no change.

To reiterate:

  • Geolocation is enable, but does not work and does not prompt me to allow or deny location sharing.
  • A look at any site's individual permissions shows that it is set to 'Always ask' but it doesn't.
  • Furthermore, setting the site's permissions to 'Allow' has no visible effect.
  • No information or error message shows up in the console.
  • I get the same result with or without my VPN active.

Halp!

Modified by nilueps

more options

I already wrote above that the two websites you mentioned aren't using Geolocation, but use the IP to find your location, so it won't help trying to fix or force Geolocation.

The first link (yougetsignal) uses your IP and doesn't prompt you. The second link (whatismyipaddress) uses Geolocation and prompts you.

more options

So, your first link (yougetsignal) returns the wrong position (wrong city altogether)

The second link (whatismyipaddress) returns the right city but the location is not precise and it does NOT prompt me to use geolocation.

I googled "geolocation example" and every site I try either throws some kind of "Failed" "Unable to retrive location" error (https://developer.mozilla.org/en-US/docs/Web/API/Geolocation/Using_geolocation) or doesn't react at all.

I tried reinstalling Firefox yesterday and the problem seemed to be fixed. But today it is misbehaving again.

Ideas?

Modified by nilueps

more options

الحل المُختار

Solution found! The issue was related to the resistFingerprinting variable.

Navigating to about:config and setting privacy.resistFingerprinting back to false fixed the issue.