X
Tap here to go to the mobile version of the site.

منتدى الدعم

Hardware Acceleration is causing my desktop pc to freeze when enabled. Using latest 58.0.2 X64bit ver.

Posted

Hardware Acceleration is causing my desktop pc to freeze when enabled. Using latest 58.0.2 X64bit ver. whole browser is lagging when scroll up or down the page with heavy graphic contents if I disable it. this is first time I experiencing this problem.

Hardware Acceleration is causing my desktop pc to freeze when enabled. Using latest 58.0.2 X64bit ver. whole browser is lagging when scroll up or down the page with heavy graphic contents if I disable it. this is first time I experiencing this problem.

Chosen solution

found the cause ....

was doing all sort of things and just tried reverted back nvidia drivers. no lockup since....... using latest FF ver59.0.1

so indeed it was nvidia's drivers. thanks who ever trying to help.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:58.0) Gecko/20100101 Firefox/58.0

More Information

FredMcD
  • Top 10 Contributor
4258 solutions 59615 answers

Hello,

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps:

In Firefox 54 and below:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the Advanced panel and the General tab.
  3. Uncheck Use hardware acceleration when available.
  4. Close Firefox completely and then restart Firefox to see if the problem persists.

In Firefox 55 and above:

  1. Click the menu button New Fx Menu and select Options (Windows) or Preferences (Mac, Linux).
  2. Select the General panel.
  3. Under Performance, uncheck Use recommended performance settings. Additional settings will be displayed.
    Fx55Performance-disableHWA
  4. Uncheck Use hardware acceleration when available.
  5. Close Firefox completely and then restart Firefox to see if the problem persists.

Did this fix your problems? Please report back to us!

If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles:

Thank you.

Hello, Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches. You will need to restart Firefox for this to take effect so save all work first (e.g., mail you are composing, online documents you're editing, etc.,) and then perform these steps: '''In Firefox 54 and below:''' # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''Advanced'' panel and the ''General'' tab. # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. '''In Firefox 55 and above''': # Click the menu button [[Image:New Fx Menu]] and select ''Options'' (Windows) or ''Preferences'' (Mac, Linux). # Select the ''General'' panel. # Under '''Performance''', uncheck ''Use recommended performance settings''. Additional settings will be displayed. #;[[Image:Fx55Performance-disableHWA|width=500]] # Uncheck '''Use hardware acceleration when available'''. # Close Firefox completely and then restart Firefox to see if the problem persists. Did this fix your problems? Please report back to us! If the problem is resolved, you should check for updates for your graphics driver by following the steps mentioned in these Knowledge base articles: * [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems#w_turn-off-hardware-acceleration]] * [[Upgrade your graphics drivers to use hardware acceleration and WebGL]] Thank you.

Question owner

thanks for replying..... when I disable hardware acc, whole browser incl tabs/ scroll pages lags. so when is enabled, all the lagging goes away but it freezes the pc when watching certain videos on the websites.

using latest driver for asus strix gtx1060. also tried with extensions disabled, that only 2 of them installed.

I also have notice that hardware acc enabled doesn't stress the gpu at all

thanks for replying..... when I disable hardware acc, whole browser incl tabs/ scroll pages lags. so when is enabled, all the lagging goes away but it freezes the pc when watching certain videos on the websites. using latest driver for asus strix gtx1060. also tried with extensions disabled, that only 2 of them installed. I also have notice that hardware acc enabled doesn't stress the gpu at all

Modified by Xtffox

FredMcD
  • Top 10 Contributor
4258 solutions 59615 answers

Type about:support in the address bar and press Enter. Under the main banner, press the button; Copy Text To Clipboard.. Now in the Reply Box on the forum page, do a right-click in the box and select Paste.

This will show us your system details. No Personal Information Is Collected.


Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Type '''about:support''' in the address bar and press '''Enter.''' Under the main banner, press the button; '''Copy Text To Clipboard.'''. Now in the Reply Box on the forum page, do a right-click in the box and select '''Paste.''' This will show us your system details. '''No Personal Information Is Collected.''' ----------------- [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

I tried safe mode that disables the extensions+hardware acceleration. but in normal mode when I disable hardware acceleration, the problem goes away but whole experience of browsing is laggy and sluggish video playback.

so no need to run in safe mode. as I discover the problem.

sys 3930k Rampage iv Gene corsair vengeance pro 2x8gb Asus strix gtx1060 6G Ax1200i win8.1 x64

hope this is right info

I tried safe mode that disables the extensions+hardware acceleration. but in normal mode when I disable hardware acceleration, the problem goes away but whole experience of browsing is laggy and sluggish video playback. so no need to run in safe mode. as I discover the problem. sys 3930k Rampage iv Gene corsair vengeance pro 2x8gb Asus strix gtx1060 6G Ax1200i win8.1 x64 hope this is right info
FredMcD
  • Top 10 Contributor
4258 solutions 59615 answers

I called for more help.

I called for more help.

Question owner

did the same freeze with latest developer edition with all the settings on default, no extensions no tabs. everytime this freeze happenes on fmovies site when I move the mouse on the movies title.

just don't understand why this does that....

did the same freeze with latest developer edition with all the settings on default, no extensions no tabs. everytime this freeze happenes on fmovies site when I move the mouse on the movies title. just don't understand why this does that....
Shadow110 1072 solutions 14836 answers

Please : Go the 3 Bar Menu then Options --> General --> Performance and untick everything except Hardware Acceleration. Change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please.

INCREASE VIRTUAL RAM Please follow along with this How to Video on Youtube https://www.youtube.com/watch?v=3DNVRGbeiMM Do everything that is asked of you EXCEPT enter the MAX Size in Both Boxes and save.

Please let us know if this solved your issue or if need further assistance.

Please : Go the 3 Bar Menu then Options --> General --> Performance and untick everything except Hardware Acceleration. Change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. INCREASE VIRTUAL RAM Please follow along with this How to Video on Youtube https://www.youtube.com/watch?v=3DNVRGbeiMM Do everything that is asked of you EXCEPT enter the MAX Size in Both Boxes and save. Please let us know if this solved your issue or if need further assistance.

Question owner

Pkshadow said

Please : Go the 3 Bar Menu then Options --> General --> Performance and untick everything except Hardware Acceleration. Change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. INCREASE VIRTUAL RAM Please follow along with this How to Video on Youtube https://www.youtube.com/watch?v=3DNVRGbeiMM Do everything that is asked of you EXCEPT enter the MAX Size in Both Boxes and save. Please let us know if this solved your issue or if need further assistance.

all these suggestions did not solve the problem and is still freeze until I unselect the hardware acceleration.

so I went back in advance options for page file and set all default. and disabled hardware acceleration. all good now.

I also notice when FF freeze out the gpu gets heatup and the gpu fans spins up until I force restart the pc...

''Pkshadow [[#answer-1086251|said]]'' <blockquote> Please : Go the 3 Bar Menu then Options --> General --> Performance and untick everything except Hardware Acceleration. Change the recommended size lower then see how it runs. Note: 1 = No Multiprocessor = slow again. Try 2 Restart Firefox after making these changes please. INCREASE VIRTUAL RAM Please follow along with this How to Video on Youtube https://www.youtube.com/watch?v=3DNVRGbeiMM Do everything that is asked of you EXCEPT enter the MAX Size in Both Boxes and save. Please let us know if this solved your issue or if need further assistance. </blockquote> all these suggestions did not solve the problem and is still freeze until I unselect the hardware acceleration. so I went back in advance options for page file and set all default. and disabled hardware acceleration. all good now. I also notice when FF freeze out the gpu gets heatup and the gpu fans spins up until I force restart the pc...
Shadow110 1072 solutions 14836 answers

Hi, glad you solved it with turning it off. Could have left page file.

Am thinking you are at then possible life span of the video card and maybe the computer. I have no information on your video card/drivers. If there are updates I would suggest installing them and if there is not to reinstall the drivers you have or are on the site in case of errors.

Please consider turning on send info to Mozilla within Firefox before posting a question as Would have been able to see make of card drivers and any errors and looked for the drivers for you.

Video card Drivers are the many issues and causes of problems.

If your above answer is the Solution to the issue could you please Mark Your answer.

Hi, glad you solved it with turning it off. Could have left page file. Am thinking you are at then possible life span of the video card and maybe the computer. I have no information on your video card/drivers. If there are updates I would suggest installing them and if there is not to reinstall the drivers you have or are on the site in case of errors. Please consider turning on send info to Mozilla within Firefox before posting a question as Would have been able to see make of card drivers and any errors and looked for the drivers for you. Video card Drivers are the many issues and causes of problems. If your above answer is the Solution to the issue could you please Mark Your answer.

Question owner

If it is video card or other component/ related then chrome should also freeze. but in this case it didn't. I installed chrome to test for very same reason.

might be nvidia driver related but I will test further and see....

thinking going back to chrome but I don't like the layout and few other text that they use..


don't know what else to say or do...

If it is video card or other component/ related then chrome should also freeze. but in this case it didn't. I installed chrome to test for very same reason. might be nvidia driver related but I will test further and see.... thinking going back to chrome but I don't like the layout and few other text that they use.. don't know what else to say or do...

Modified by Xtffox

Shadow110 1072 solutions 14836 answers

Xtffox said

If it is video card or other component/ related then chrome should also freeze. but in this case it didn't. I installed chrome to test for very same reason. might be nvidia driver related but I will test further and see.... thinking going back to chrome but I don't like the layout and few other text that they use.. don't know what else to say or do...

Have you updated the Video Card Drivers ? If they can not be updated then is rather old and might be time for a new card.

''Xtffox [[#answer-1086593|said]]'' <blockquote> If it is video card or other component/ related then chrome should also freeze. but in this case it didn't. I installed chrome to test for very same reason. might be nvidia driver related but I will test further and see.... thinking going back to chrome but I don't like the layout and few other text that they use.. don't know what else to say or do... </blockquote> Have you updated the Video Card Drivers ? If they can not be updated then is rather old and might be time for a new card.

Question owner

card is few months old using latest drivers from nvidia.I even tried old drivers but no luck... plays most intensive games without glitch.

card is few months old using latest drivers from nvidia.I even tried old drivers but no luck... plays most intensive games without glitch.

Question owner

still no luck. will keep this thread rolling ...

still no luck. will keep this thread rolling ...

Modified by Xtffox

FredMcD
  • Top 10 Contributor
4258 solutions 59615 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.

Question owner

no go this is so frustrating is still freeze HWA enabled.... this seems nvidia problem but I don't think they will bother to fix this

no go this is so frustrating is still freeze HWA enabled.... this seems nvidia problem but I don't think they will bother to fix this

Question owner

I won't give up on this. will do more testing until it get resolved

I won't give up on this. will do more testing until it get resolved
Shadow110 1072 solutions 14836 answers

Version 50.0.2 released this date : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do :

Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer

Please let us know if this solved your issue or if need further assistance.

Version 50.0.2 released this date : uninstall Firefox. Then Delete the Mozilla Firefox Folders in C:\Program Files , C:\Program Files(x86) & C:\ProgramData Then restart system. Then run Windows Disk Cleanup. (Note: This should be Pinned and run Weekly, If never done below expect 10's of gig's) Then run it again and click the button that says Cleanup System Files. Note: your Firefox Profile is saved. But you should make a back up before you do : *https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles *https://support.mozilla.org/en-US/kb/export-firefox-bookmarks-to-backup-or-transfer Reinstall with Current Release Firefox 59.0.2 with a Full Version Installer *https://www.mozilla.org/firefox/all/ Please let us know if this solved your issue or if need further assistance.

Chosen Solution

found the cause ....

was doing all sort of things and just tried reverted back nvidia drivers. no lockup since....... using latest FF ver59.0.1

so indeed it was nvidia's drivers. thanks who ever trying to help.

found the cause .... was doing all sort of things and just tried reverted back nvidia drivers. no lockup since....... using latest FF ver59.0.1 so indeed it was nvidia's drivers. thanks who ever trying to help.

Modified by Xtffox

HalDav 0 solutions 1 answers

Hello everybody. Let's see if we can clear up the confusion here...

This issue began for me with a windows 10 update. It has to do with the way graphics are handled in the security codebase. I went through and undid the updates until firefox worked again, A security update caused it on windows 10. My firefox version is very old, but it allows extensions newer versions don't. It responded the same as the new version of firefox though when I tried to open it up. Before the Win10 update, firefox could fly faster than anything on my laptop. I checked with some macs too, and they also had a "Security Update". Both had sections related to FLASH and both had the same problem with NVIDIA cards. So there it is. Much of the FRAME and CSS implentations from FLASH that are also integrated into HTML5 now have to jump through more hoops before they get to your graphics card. Other browsers prevent the crash by turning off acceleration on the NVIDIA cards. It sounds like a buffering issue to me. There's been a lot of commotion about buffer security and triple buffering in accelerated graphic implementations. If you have an intel computer of 3 years or younger, you can set the computer to use your intel (or AMD) CPU and set the shared ram to MAX value in your EFI\BIOS. On a MAC, just turn off the Acceleration in firefox for now. I haven't played with the preference pane for the nvidia, on mac, but you should be able to set firefox to run with your intel or AMD internal CPU with about 2gb ram shared. IT's decent performance, not super exciting, but can run faster for much of FULL HD video; however, for 2k\4k and higher hd, turning off acceleration and using the NVIDIA is still faster, and it works fairly smooth. Only gaming suffers so far, for me.

Give it a little time, about 2-5 weeks, and usually there's an update that fixes the driver so that it will comply with the new security encapsulations, and function normally. I've seen this before, and usually the change in visual lag is slight, after 2 or 3 restarts, it's unnoticeable. With new drivers, especially the ones coded for today's users, there's a lot of self adjustment that occurs as they get running. Run your most intensive stuff for a few days and restart every chance you get. It will help max out the performance of the card and driver.

Hello everybody. Let's see if we can clear up the confusion here... This issue began for me with a windows 10 update. It has to do with the way graphics are handled in the security codebase. I went through and undid the updates until firefox worked again, A security update caused it on windows 10. My firefox version is very old, but it allows extensions newer versions don't. It responded the same as the new version of firefox though when I tried to open it up. Before the Win10 update, firefox could fly faster than anything on my laptop. I checked with some macs too, and they also had a "Security Update". Both had sections related to FLASH and both had the same problem with NVIDIA cards. So there it is. Much of the FRAME and CSS implentations from FLASH that are also integrated into HTML5 now have to jump through more hoops before they get to your graphics card. Other browsers prevent the crash by turning off acceleration on the NVIDIA cards. It sounds like a buffering issue to me. There's been a lot of commotion about buffer security and triple buffering in accelerated graphic implementations. If you have an intel computer of 3 years or younger, you can set the computer to use your intel (or AMD) CPU and set the shared ram to MAX value in your EFI\BIOS. On a MAC, just turn off the Acceleration in firefox for now. I haven't played with the preference pane for the nvidia, on mac, but you should be able to set firefox to run with your intel or AMD internal CPU with about 2gb ram shared. IT's decent performance, not super exciting, but can run faster for much of FULL HD video; however, for 2k\4k and higher hd, turning off acceleration and using the NVIDIA is still faster, and it works fairly smooth. Only gaming suffers so far, for me. Give it a little time, about 2-5 weeks, and usually there's an update that fixes the driver so that it will comply with the new security encapsulations, and function normally. I've seen this before, and usually the change in visual lag is slight, after 2 or 3 restarts, it's unnoticeable. With new drivers, especially the ones coded for today's users, there's a lot of self adjustment that occurs as they get running. Run your most intensive stuff for a few days and restart every chance you get. It will help max out the performance of the card and driver.