X
Tap here to go to the mobile version of the site.

منتدى الدعم

Why can I play only Youtube videos in Facebook for months now?

Posted

In Facebook, if someone posts a Youtube video, it plays with no problem. But for months now, no other type of video will play. When I click on, a new page opens on top of the old one with a large viewing screen and an arrow to click to play. Every time I click on it, it simply refreshes but does not play. I just updated the newest Adobe Flash player and restarted three times. Firefox is updated. I have Windows Vista.

In Facebook, if someone posts a Youtube video, it plays with no problem. But for months now, no other type of video will play. When I click on, a new page opens on top of the old one with a large viewing screen and an arrow to click to play. Every time I click on it, it simply refreshes but does not play. I just updated the newest Adobe Flash player and restarted three times. Firefox is updated. I have Windows Vista.

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.5.4"
  • Coupons, Inc. Coupon Printer Plugin
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_18 for Mozilla browsers
  • Shockwave Flash 28.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • 5.1.50906.0
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

FredMcD
  • Top 10 Contributor
4267 solutions 59835 answers

Make sure you are not blocking content.

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

Make sure you are not blocking content. [https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

Yes, the problem is still there. I also cleared my cookies and cache a few minutes ago. Still won't play videos.

Yes, the problem is still there. I also cleared my cookies and cache a few minutes ago. Still won't play videos.
FredMcD
  • Top 10 Contributor
4267 solutions 59835 answers

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key; <Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager. ''' Hot key; '''<Control> ''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins. ''' Make sure the ones you want to use are set to '''Ask''' or '''Allow. ''' ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and '''Left-click''' the icon. Select '''Permissions. ''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow. '''

Question owner

First off, how do I know which plugins I want to allow? I changed the ones that mentioned Adobe and Shockwave to "always allow" but I don't know if any others are related to my problem. Second, when you say "go to the web page" which web page do you mean? Facebook, the one I'm having trouble with? Or some other web page?

First off, how do I know which plugins I want to allow? I changed the ones that mentioned Adobe and Shockwave to "always allow" but I don't know if any others are related to my problem. Second, when you say "go to the web page" which web page do you mean? Facebook, the one I'm having trouble with? Or some other web page?
FredMcD
  • Top 10 Contributor
4267 solutions 59835 answers

TerryRA said

when you say "go to the web page" which web page do you mean?

Any website you are having trouble with.

''TerryRA [[#answer-1084093|said]]'' <blockquote> when you say "go to the web page" which web page do you mean? </blockquote> Any website you are having trouble with.

Question owner

Ok, I tried that on a couple of videos. It says (Facebook) "You have not granted this site any special permissions." But on the Add-ons Manager menu, there is no Facebook listed. The reason I am really confused is because I used to have no problem. Then about a year or so ago, I sometimes had a problem playing videos that some friends would post from their own phones (homemade). Then, no videos would play for a time, then they'd play again. I did nothing to the inner workings of my computer to change anything, so I imagine it was some type of automatic update or something that did it. But now it's been like this for a couple of months, and it's really irritating never knowing what people are talking about in the videos, and not being able to see recipe or other instructional videos. But Youtube videos play just fine.

Ok, I tried that on a couple of videos. It says (Facebook) "You have not granted this site any special permissions." But on the Add-ons Manager menu, there is no Facebook listed. The reason I am really confused is because I used to have no problem. Then about a year or so ago, I sometimes had a problem playing videos that some friends would post from their own phones (homemade). Then, no videos would play for a time, then they'd play again. I did nothing to the inner workings of my computer to change anything, so I imagine it was some type of automatic update or something that did it. But now it's been like this for a couple of months, and it's really irritating never knowing what people are talking about in the videos, and not being able to see recipe or other instructional videos. But Youtube videos play just fine.

Modified by TerryRA

FredMcD
  • Top 10 Contributor
4267 solutions 59835 answers

TerryRA said

Ok, I tried that on a couple of videos. It says (Facebook) "You have not granted this site any special permissions." But on the Add-ons Manager menu, there is no Facebook listed.

In this case, not the Add-ons Manager, but the webpage. It's possible you need to go to a Facebook page to set this.

''TerryRA [[#answer-1084120|said]]'' <blockquote> Ok, I tried that on a couple of videos. It says (Facebook) "You have not granted this site any special permissions." But on the Add-ons Manager menu, there is no Facebook listed. </blockquote> In this case, not the Add-ons Manager, but the webpage. It's possible you need to go to a Facebook page to set this.