X
Tap here to go to the mobile version of the site.

منتدى الدعم

How do I stop automatic downloads? Settings does not do it.

Posted

Apart from switching to Chrome, how can I stop automatic downloads? I don't want the latest Firefox. I am happy with 56. Please don't tell me it "contains vulnerabilities and exploits...etc" as so does 59 which you will fix with 60 which will also contain them which you will fix with 61 etc. I hate the latest one because it is so slow - it pauses 5 seconds with each scroll movement. Firefox 56 and Chrome work fine so it's not the computer. I am sick of reloading 56. What about having a proper Do Not Initiate Downloads system? Is it so hard? You are certainly pushing me into Chrome, which I don't like much.

Apart from switching to Chrome, how can I stop automatic downloads? I don't want the latest Firefox. I am happy with 56. Please don't tell me it "contains vulnerabilities and exploits...etc" as so does 59 which you will fix with 60 which will also contain them which you will fix with 61 etc. I hate the latest one because it is so slow - it pauses 5 seconds with each scroll movement. Firefox 56 and Chrome work fine so it's not the computer. I am sick of reloading 56. What about having a proper Do Not Initiate Downloads system? Is it so hard? You are certainly pushing me into Chrome, which I don't like much.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 28.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:56.0) Gecko/20100101 Firefox/56.0

More Information

FredMcD
  • Top 10 Contributor
4247 solutions 59408 answers

First, Type about:preferences#advanced<enter> in the address bar. Under Advanced, Select Update.

[v56+] Type about:preferences#general<enter> in the address bar. Select Update.

Select Never Check For Updates.

Also turn off Use a background service to install updates <Windows Only>

First, Type '''about:preferences#advanced'''<enter> in the address bar. Under '''Advanced, ''' Select '''Update. ''' [v56+] Type '''about:preferences#general'''<enter> in the address bar. Select '''Update. ''' Select '''Never Check For Updates.''' Also turn off '''Use a background service to install updates''' <Windows Only>

Question owner

I have done all of that some weeks/months ago. It does not work. Unfortunately the unwanted update just keeps coming back. I think you are saying Chrome is the answer.

I have done all of that some weeks/months ago. It does not work. Unfortunately the unwanted update just keeps coming back. I think you are saying Chrome is the answer.
FredMcD
  • Top 10 Contributor
4247 solutions 59408 answers

I called for more help.

What are you using as your home page?

I called for more help. What are you using as your home page?

Question owner

My home page is set to Google (Australia). I see that many other people have this updating issue and it does not appear to have a solution. I appreciate that you are trying to be helpful though.

My home page is set to Google (Australia). I see that many other people have this updating issue and it does not appear to have a solution. I appreciate that you are trying to be helpful though.
WestEnd
  • Top 25 Contributor
60 solutions 5379 answers

erussell said

You are certainly pushing me into Chrome, which I don't like much.

FYI Chrome does update behind the scene but it will not tell you that upfront. There is a way but that isn't advised on here.

''erussell [[#question-1205875|said]]'' <blockquote> You are certainly pushing me into Chrome, which I don't like much. </blockquote> FYI Chrome does update behind the scene but it will not tell you that upfront. There is a way but that isn't advised on here.

Modified by WestEnd

Question owner

1. Yes I know that but at least it doesn't stop dead when you scroll. 2. "There is a way" to do what?

1. Yes I know that but at least it doesn't stop dead when you scroll. 2. "There is a way" to do what?
FredMcD
  • Top 10 Contributor
4247 solutions 59408 answers

Some Windows users have gone as far as deleting this folder in the computers Programs Folder; Mozilla Maintenance Service

Some Windows users have gone as far as deleting this folder in the computers Programs Folder; Mozilla Maintenance Service

Question owner

Thanks - I'll give it a try.

Thanks - I'll give it a try.
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

What security software do you have?

We have seen issues reported with AVG/Avast security software.

What security software do you have? We have seen issues reported with AVG/Avast security software.

Question owner

I use Eset and i'm fairly sure that's not the problem. FredMcD's suggestion is working so far.

I use Eset and i'm fairly sure that's not the problem. FredMcD's suggestion is working so far.
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Note that you can uninstall Mozilla Maintenance Service via the Windows Control Panel, so no need to remove this folder manually since that leaves traces in the Windows Registry.

Note that you can uninstall Mozilla Maintenance Service via the Windows Control Panel, so no need to remove this folder manually since that leaves traces in the Windows Registry.

Question owner

Thanks - I will do that too

Thanks - I will do that too

Helpful Reply

Unfortunately getting rid of this Maintenance Programme does not stop the latest Firefox downloading.

I find it quite obnoxious of any company to insist you do what they want rather than what you want, especially when what they want is for me to use what is, in my hands, an inferior product. 5 seconds per scroll movement is quite unacceptable.

Unfortunately getting rid of this Maintenance Programme does not stop the latest Firefox downloading. I find it quite obnoxious of any company to insist you do what they want rather than what you want, especially when what they want is for me to use what is, in my hands, an inferior product. 5 seconds per scroll movement is quite unacceptable.