X
Tap here to go to the mobile version of the site.

منتدى الدعم

Fresh firefox profile crashes on certain sites when not in safe mode

Posted

Hi, my installation of Firefox 52.4.1 ESR is crashing reproducibly when I'm not using Safe Mode on certain sites, like Google Maps and Reddit.

I have created a completely new profile without add-ons and themes, and disabled hardware acceleration. Firefox still crashes on these sites. Only starting Firefox in Safe Mode solves the problem.

The problem only occurs on my tower PC which has a NVIDIA GPU, and not on my Thinkpad. Both are running the exact same Firefox version on Arch Linux with identical add-ons and user profiles. So it may be problem with video acceleration, but as I stated, I disabled HW acceleration. Btw. the problem doesn't occur with Firefox Quantum which I don't want to use until the most important add-ons are ported.

Anybody got an idea?

Hi, my installation of Firefox 52.4.1 ESR is crashing reproducibly when I'm not using Safe Mode on certain sites, like Google Maps and Reddit. I have created a completely new profile without add-ons and themes, and disabled hardware acceleration. Firefox still crashes on these sites. Only starting Firefox in Safe Mode solves the problem. The problem only occurs on my tower PC which has a NVIDIA GPU, and not on my Thinkpad. Both are running the exact same Firefox version on Arch Linux with identical add-ons and user profiles. So it may be problem with video acceleration, but as I stated, I disabled HW acceleration. Btw. the problem doesn't occur with Firefox Quantum which I don't want to use until the most important add-ons are ported. Anybody got an idea?

Additional System Details

Installed Plug-ins

  • Shockwave Flash 27.0 r0

Application

  • Firefox 52.4.1
  • User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:52.0) Gecko/20100101 Firefox/52.0
  • Support URL: https://support.mozilla.org/1/firefox/52.4.1/Linux/en-US/

Extensions

  • Application Update Service Helper 2.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.10 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA Corporation -- GeForce GTX 750 Ti/PCIe/SSE2
  • adapterDeviceID: GeForce GTX 750 Ti/PCIe/SSE2
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: NVIDIA Corporation
  • crashGuards: []
  • currentAudioBackend: pulse
  • driverDate:
  • driverVersion: 4.6.0 NVIDIA 387.22
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 1
  • supportsHardwareH264: No
  • webgl2Renderer: NVIDIA Corporation -- GeForce GTX 750 Ti/PCIe/SSE2
  • webglRenderer: NVIDIA Corporation -- GeForce GTX 750 Ti/PCIe/SSE2
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Basic

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4274 solutions 59942 answers

Helpful Reply

In the address bar, type about:crashes<enter>. Note: If any reports do not have BP- in front of the numbers/letters, click it to submit them.

The crash report is several pages of data. We need the report numbers to see the whole report.

Using your mouse, mark the most recent 7 - 10 crash reports, and copy them. Now go to the reply box and paste them in.

aboutcrashesFx29

For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

In the address bar, type '''about:crashes'''<enter>. '''Note: ''' If any reports do not have '''BP-''' in front of the numbers/letters, click it to submit them. '''The crash report is several pages of data. We ''' '''need the report numbers to see the whole report. ''' Using your mouse, '''mark''' the '''most recent 7 - 10''' crash reports, and copy them. Now go to the reply box and paste them in. ;[[Image:aboutcrashesFx29|width=500]] For more help on crash reports, see; https://support.mozilla.org/en-US/kb/firefox-crashes-asking-support

Question owner

The crash reports are: bp-359d39f3-a6cd-4811-a11a-775660171203 bp-ad823262-03f2-468b-86cc-c4cec0171203 bp-044a82be-7961-4811-bd39-4c41e0171203

Btw. I was being imprecise about the crash. For the fresh profile I was setting up, only the tab is crashing and not all of firefox.

The crash reports are: bp-359d39f3-a6cd-4811-a11a-775660171203 bp-ad823262-03f2-468b-86cc-c4cec0171203 bp-044a82be-7961-4811-bd39-4c41e0171203 Btw. I was being imprecise about the crash. For the fresh profile I was setting up, only the tab is crashing and not all of firefox.
FredMcD
  • Top 10 Contributor
4274 solutions 59942 answers

Product Firefox Release Channel esr Version 52.4.1esr Build ID 20171005074949 OS Linux OS Version 0.0.0 Linux 4.13.12-1-ARCH #1 SMP PREEMPT Wed Nov 8 11:54:06 CET 2017 x86_64

bp-359d39f3-a6cd-4811-a11a-775660171203 Signature: mozilla::WebGLContext::CreateShaderValidator


I did not notice you are using Linux. I called for more help.

Product Firefox Release Channel esr Version 52.4.1esr Build ID 20171005074949 OS Linux OS Version 0.0.0 Linux 4.13.12-1-ARCH #1 SMP PREEMPT Wed Nov 8 11:54:06 CET 2017 x86_64 bp-359d39f3-a6cd-4811-a11a-775660171203 Signature: mozilla::WebGLContext::CreateShaderValidator ----------------- I did not notice you are using Linux. I called for more help.
cor-el
  • Top 10 Contributor
  • Moderator
17591 solutions 159130 answers

Helpful Reply

Try to update to Firefox 52.5.0 to see if that has effect.

This is a problem with WebGL as you can see by the signature of the crash reports.

  • Firefox 52.4.1esr Crash Report [@ mozilla::WebGLContext::CreateShaderValidator ]

You can disable WebGL as a test and check graphics section on the about:support page for messages about WebGL.

Try to update to Firefox 52.5.0 to see if that has effect. This is a problem with WebGL as you can see by the signature of the crash reports. *Firefox 52.4.1esr Crash Report [@ mozilla::WebGLContext::CreateShaderValidator ] You can disable WebGL as a test and check graphics section on the about:support page for messages about WebGL. * https://developer.mozilla.org/WebGL
cor-el
  • Top 10 Contributor
  • Moderator
17591 solutions 159130 answers

Some webgl pref that you can look at on the about:config page.

  • webgl.disabled
  • webgl.enable-webgl2
  • webgl.disable-angle
  • webgl.disable-extensions
  • webgl.enable-debug-renderer-info
Some <b>webgl</b> pref that you can look at on the about:config page. *webgl.disabled *webgl.enable-webgl2 *webgl.disable-angle *webgl.disable-extensions *webgl.enable-debug-renderer-info

Question owner

Hi,

updating Firefox didn't help.

Setting webgl.disabled or webgl.disable-extensions to true both seems to solve the crashing, however e.g. Google Maps renders rather blurry now, so this is only a workaround. Does it use a Software rasterizer now? Is there any chance to get WebGL working again?

Hi, updating Firefox didn't help. Setting webgl.disabled or webgl.disable-extensions to true both seems to solve the crashing, however e.g. Google Maps renders rather blurry now, so this is only a workaround. Does it use a Software rasterizer now? Is there any chance to get WebGL working again?
Shadow110 1072 solutions 14836 answers

It comes down to age of video card and age of video card drivers. If can not update the drivers and if card is 5yrs old it is time to update card.

That is unfortunately the realities of tech changes and life span of usefulness.

When buy top of the line and keep motherboard and video it runs a lot longer. You get what you pay for if buy Dell or Lenivo(sp). I built my own from parts I ordered. You can order all you need then have someone assemble it for you. My Motherboard was 450.00 so yea get what pay for.

It comes down to age of video card and age of video card drivers. If can not update the drivers and if card is 5yrs old it is time to update card. That is unfortunately the realities of tech changes and life span of usefulness. When buy top of the line and keep motherboard and video it runs a lot longer. You get what you pay for if buy Dell or Lenivo(sp). I built my own from parts I ordered. You can order all you need then have someone assemble it for you. My Motherboard was 450.00 so yea get what pay for.

Question owner

Pkshadow said

It comes down to age of video card and age of video card drivers. If can not update the drivers and if card is 5yrs old it is time to update card. That is unfortunately the realities of tech changes and life span of usefulness. When buy top of the line and keep motherboard and video it runs a lot longer. You get what you pay for if buy Dell or Lenivo(sp). I built my own from parts I ordered. You can order all you need then have someone assemble it for you. My Motherboard was 450.00 so yea get what pay for.

None of my PC's components are bottom-shelf. The 750ti is still an acceptable video card for today's standards (can play AAA titles in Full HD, that's totally okay), a comparable video card with as little power consumption still has to be released, and unfortunately that's not the 1050ti.

My drivers are of course the newest drivers that all modern nvidia cards are using.

On the other hand it's absolutely incomprehensible that an application like a web browser shouldn't also run on much much worse hardware than mine. In contrast to the posts of cor-el and FredMcD your comments are neither helpful nor in any way qualified.

Finally, since then problem is only occurring on the ESR version which I'm going to continue using until Quantum has at least the Add-Ons that I really need to work, it's obvious that it's a bug in Firefox and not my video card or its drivers.

''Pkshadow [[#answer-1044594|said]]'' <blockquote> It comes down to age of video card and age of video card drivers. If can not update the drivers and if card is 5yrs old it is time to update card. That is unfortunately the realities of tech changes and life span of usefulness. When buy top of the line and keep motherboard and video it runs a lot longer. You get what you pay for if buy Dell or Lenivo(sp). I built my own from parts I ordered. You can order all you need then have someone assemble it for you. My Motherboard was 450.00 so yea get what pay for. </blockquote> None of my PC's components are bottom-shelf. The 750ti is still an acceptable video card for today's standards (can play AAA titles in Full HD, that's totally okay), a comparable video card with as little power consumption still has to be released, and unfortunately that's not the 1050ti. My drivers are of course the newest drivers that all modern nvidia cards are using. On the other hand it's absolutely incomprehensible that an application like a web browser shouldn't also run on much much worse hardware than mine. In contrast to the posts of cor-el and FredMcD your comments are neither helpful nor in any way qualified. Finally, since then problem is only occurring on the ESR version which I'm going to continue using until Quantum has at least the Add-Ons that I really need to work, it's obvious that it's a bug in Firefox and not my video card or its drivers.

Modified by felsenhower

smorele 44 solutions 310 answers

Hello, if an up to date drivers do not help, have you tried to downgrade your drivers? Try to use the previous version and tell us if it helps. Another point, do you install drivers from your distribution sources or do you compile them from manufacturer sources?

Hello, if an up to date drivers do not help, have you tried to downgrade your drivers? Try to use the previous version and tell us if it helps. Another point, do you install drivers from your distribution sources or do you compile them from manufacturer sources?

Question owner

smorele said

Hello, if an up to date drivers do not help, have you tried to downgrade your drivers? Try to use the previous version and tell us if it helps. Another point, do you install drivers from your distribution sources or do you compile them from manufacturer sources?

I tried a few different driver versions, but none of these solved the problem. I am using the regular Nvidia drivers from the Arch repos which is recommended.

After all this shouldn't matter since it is a problem that occurred since a certain version and is not present anymore in the new Firefox, so the driver is not to blame. I guess I'll just give up at this point, accept the situation and wait until the new Firefox becomes usable for me.

''smorele [[#answer-1045271|said]]'' <blockquote> Hello, if an up to date drivers do not help, have you tried to downgrade your drivers? Try to use the previous version and tell us if it helps. Another point, do you install drivers from your distribution sources or do you compile them from manufacturer sources? </blockquote> I tried a few different driver versions, but none of these solved the problem. I am using the regular Nvidia drivers from the Arch repos which is recommended. After all this shouldn't matter since it is a problem that occurred since a certain version and is not present anymore in the new Firefox, so the driver is not to blame. I guess I'll just give up at this point, accept the situation and wait until the new Firefox becomes usable for me.
Shadow110 1072 solutions 14836 answers

There is increased use of CPU and ram in all Versions due to HTML5 Video Please follow the directions to get the best performance out of your Video Card : Noticed in the 1st post in your Video Card Driver section that Hardware Acceleration for the card was turned off and by Platform which is you and Firefox.

  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]}
  • info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'}

Now no idea what is being said but will hold true I think if have not done any of the below.

Can you turn Hardware Acceleration back on please and try :

  • Copy/Paste about:preferences in to the Address Bar then Enter.
  • Go down the list to Performance and Un Tick : Use Recommended *Performance Settings then Tick use Hardware Acceleration When *Available.

Then leave Recommended Performace Settings UN Ticked and TEST If you have support for and the Content Box shows more than 1 then set it at 1 and Test.

Then Turn On Open GL : In the address bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. Click I accept the risk! to continue to the about:config page.

  • In the Filter/Search box, type webgl.disabled.
  • Doubleclick on the webgl.disabled item to switch it to False to turn it on.
  • Check what cor-el posted while your in there.


Please let us know if this solved your issue or if need further assistance.

There is increased use of CPU and ram in all Versions due to HTML5 Video Please follow the directions to get the best performance out of your Video Card : Noticed in the 1st post in your Video Card Driver section that Hardware Acceleration for the card was turned off and by Platform which is you and Firefox. * featureLog: {u'fallbacks': [], u'features': [{u'status': u'blocked', u'description': u'Compositing', u'log': [{u'status': u'blocked', u'message': u'Acceleration blocked by platform', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'unavailable', u'description': u'OpenGL Compositing', u'log': [{u'status': u'unavailable', u'message': u'Hardware compositing is disabled', u'type': u'default'}], u'name': u'OPENGL_COMPOSITING'}]} *info: {u'ApzWheelInput': 1, u'ApzTouchInput': 1, u'CairoUseXRender': 0, u'AzureFallbackCanvasBackend': u'none', u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'skia', u'AzureContentBackend': u'skia'} Now no idea what is being said but will hold true I think if have not done any of the below. Can you turn Hardware Acceleration back on please and try : *Copy/Paste about:preferences in to the Address Bar then Enter. *Go down the list to Performance and Un Tick : Use Recommended *Performance Settings then Tick use Hardware Acceleration When *Available. Then leave Recommended Performace Settings UN Ticked and TEST If you have support for and the Content Box shows more than 1 then set it at 1 and Test. Then Turn On Open GL : In the address bar, type about:config and press Enter. The about:config "This might void your warranty!" warning page may appear. Click I accept the risk! to continue to the about:config page. *In the Filter/Search box, type webgl.disabled. *Doubleclick on the webgl.disabled item to switch it to False to turn it on. *Check what cor-el posted while your in there. Please let us know if this solved your issue or if need further assistance.