ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I restore the ability for autocomplete to work with ctrl+enter?

  • 4 ردود
  • 1 has this problem
  • 1 view
  • آخر ردّ كتبه Shadow110

more options

As of Firefox 56 whenever starting to type an address and letting it autocomplete and then pressing ctrl+enter or altgr+enter firefox will prefix www. and postfix .com around the letters you typed ignoring the autocomplete function.

Example: Typing "go" autocompletes to "google.com" In Firefox 55 pressing ctrl+enter or altgr+enter would open google.com in the same or a new tab respectively. In Firefox 56 doing the same results in opening go.com instead.

This is a behaviour that has annoyed me a lot in Chrome for years but it seems lately Firefox is copying more and more of Chromes annoyances. (Mozilla, if we liked the stuff Chrome had to offer we'd be using Chrome.)

Does anyone know of a way to fix it, maybe through some about:config magic or a plug-in? For now I've just reverted to Firefox 55.

As of Firefox 56 whenever starting to type an address and letting it autocomplete and then pressing ctrl+enter or altgr+enter firefox will prefix www. and postfix .com around the letters you typed ignoring the autocomplete function. Example: Typing "go" autocompletes to "google.com" In Firefox 55 pressing ctrl+enter or altgr+enter would open google.com in the same or a new tab respectively. In Firefox 56 doing the same results in opening go.com instead. This is a behaviour that has annoyed me a lot in Chrome for years but it seems lately Firefox is copying more and more of Chromes annoyances. (Mozilla, if we liked the stuff Chrome had to offer we'd be using Chrome.) Does anyone know of a way to fix it, maybe through some about:config magic or a plug-in? For now I've just reverted to Firefox 55.

Modified by Tharkon

All Replies (4)

more options

Please consider turning on send info to Mozilla before posting a question. This helps us help you. As I have no info from your system that would help see things that cause issues. It shows this was sent using version 55 ??? And that is all the info I have.

As for fixing that, do not think so. Maybe be something once figure out release. You are right as to more like chrome https://www.theinquirer.net/inquirer/news/3020724/firefox-quantum-everything-you-need-to-know-ahead-of-next-weeks-release

Note : Firefox 57 Quantum release date Nov 14th https://www.mozilla.org/en-US/firefox/quantum/ Note : Legacy Extensions will be disabled and or removed.

Please let us know if this solved your issue or if need further assistance.

more options

You can consider to create a bookmark that links to "https://ww.google.com" and give it a 'go' keyword. That will always work.

Ctrl+Enter does a keyword fixup and possibly add a .www prefix and add a .com postfix. This doesn't necessarily include doing an an autocomplete.

more options

Pkshadow, I was not aware of such an option and don't see it now either. I edited the question and clicked share information but nothing seemed to happen. What information would you need? I tested the problem by switching back and forth between 56 and 55 without changing anything else so I know it's related to something that came with 56. The info about 57 being so much faster is good news, and much needed after all the bad news we've had so far about 57. Still not sure if it's a good move though sacrificing that much versatility, people who prefer speed over versatility would be using Chrome already.

cor-el, google.com was just an example, there are a lot of websites like this, and in my opinion this change renders the autocomplete of website addresses useless. The reason I use altgr+enter instead of alt+enter is because altgr is closer to enter than alt is.

more options

This is what you need to do to send data. It will only take effect on the next question you send. Or can leave it off till need to send a question then turn it on. https://support.mozilla.org/en-US/kb/share-telemetry-data-mozilla-help-improve-firefox

fyi: There is what is called the W3C.org (World Wide Web Consortium) that sets the standards and practises for web browsers, web pages, delivery, code and for future and Mozilla adheres to the rules made. So in other words forced on but it had to be done for security reasons as well.

Modified by Shadow110