X
Tap here to go to the mobile version of the site.

منتدى الدعم

Com a versão 55.0.3 do Firefox não recebo mais a confirmação para geolocalização mesmo configurada no site.

Posted

Desenvolvo um site e na parte da Geolocalização utilizo JavaScript e com a versão 55.0.3 (64bits) parou de funcionar mesmo com a Permissão do site marcada para "Perguntar sempre" ele não pergunta e se marcar para "Permitir" ele não funciona, depois de testar verifiquei que com a versão 50.0.2 (32bits) funciona normalmente fazendo sempre a pergunta para "Compartilhar a localização".

Desenvolvo um site e na parte da Geolocalização utilizo JavaScript e com a versão 55.0.3 (64bits) parou de funcionar mesmo com a Permissão do site marcada para "Perguntar sempre" ele não pergunta e se marcar para "Permitir" ele não funciona, depois de testar verifiquei que com a versão 50.0.2 (32bits) funciona normalmente fazendo sempre a pergunta para "Compartilhar a localização".

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.07
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • Google Update
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • NVIDIA 3D Vision Streaming plugin for Mozilla browsers
  • NVIDIA 3D Vision plugin for Mozilla browsers
  • Shockwave Flash 11.8 d800

Application

  • Firefox 50.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.0.2/WINNT/pt-BR/

Extensions

  • Adblock Plus 2.9.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: NVIDIA GeForce GT 430
  • adapterDescription2: NVIDIA GeForce 7300 SE/7200 GS
  • adapterDeviceID: 0x0de1
  • adapterDeviceID2: 0x01d3
  • adapterDrivers: nvd3dumx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um
  • adapterDrivers2: nvd3dumx,nvd3dum
  • adapterRAM: 1024
  • adapterRAM2: 256
  • adapterSubsysID: 123119da
  • adapterSubsysID2: 0000000c
  • adapterVendorID: 0x10de
  • adapterVendorID2: 0x10de
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.15063.413
  • driverDate: 1-30-2015
  • driverDate2: 1-30-2015
  • driverVersion: 9.18.13.908
  • driverVersion2: 9.18.13.908
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'description': u'Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'description': u'Direct3D11 Compositing', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'description': u'Direct3D9 Compositing', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'description': u'Direct2D', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'DIRECT2D'}, {u'status': u'available', u'description': u'Direct3D11 hardware ANGLE', u'log': [{u'status': u'available', u'type': u'default'}], u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1'}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D11 API
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (NVIDIA GeForce GT 430 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes
Zilmar
  • Moderator
94 solutions 738 answers

Olá Relder!

Eu não sou dev, mas sugiro que dê uma olhada na documentação da MDN sobre isso: https://developer.mozilla.org/pt-BR/docs/Web/API/Navigator/geolocation

Se você já estiver seguindo as recomendações e isso aparentar ser um bug, sugiro reportá-lo no https://bugzilla.mozilla.org/

Caso precise de ajuda pra reportar o bug, só dar um toque que te ajudo!

Abraço

Olá Relder! Eu não sou dev, mas sugiro que dê uma olhada na documentação da MDN sobre isso: https://developer.mozilla.org/pt-BR/docs/Web/API/Navigator/geolocation Se você já estiver seguindo as recomendações e isso aparentar ser um bug, sugiro reportá-lo no https://bugzilla.mozilla.org/ Caso precise de ajuda pra reportar o bug, só dar um toque que te ajudo! Abraço