X
Tap here to go to the mobile version of the site.

منتدى الدعم

I have Firefox 20 and need to upgrade to 31 or higher for my bank I can't seem to get it to work

Posted

I have tried to download but there is always an error message. I am new to this sort of thing.

I have tried to download but there is always an error message. I am new to this sort of thing.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202
  • The IcedTea-Web Plugin executes Java applets.
  • Gecko Media Player 0.9.9.2Video Player Plug-in for QuickTime, RealPlayer and Windows Media Player streams using MPlayer
  • 4.0.51204.0
  • This plug-in detects the presence of iTunes when opening iTunes Store URLs in a web page with Firefox.

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux i686; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158576 answers

Verify that you meet the System Requirements (GTK+ and GLib) for the current Firefox release.

Verify that you meet the System Requirements (GTK+ and GLib) for the current Firefox release. *https://download-installer.cdn.mozilla.net/pub/firefox/releases/ *https://www.mozilla.org/en-US/firefox/releases/