X
Tap here to go to the mobile version of the site.

منتدى الدعم

silverlight

Posted

Firefox version 52 ESR Win XP OS. Silverlight plug-in stopped working just yesterday on Netflix and my Win XP Pro OS. I have uninstalled the older version and downloaded the correct version I need 5.1.4.1.2 and it is installed but still doesn't work with Netflix. I cannot find in the registry Netflix and Silverlight permission to run the plug in. This is a problem and needs to be fixed. I don't have the money or means to upgrade my OS at this time. I have no tv either. I have been in contact with Microsoft and Netflix and they determined that the problem lies with Mozilla. I cannot use any other browser as Chrome does not work with Netflix and Win XP either due to unable to update WidevineCdm on XP.

Firefox version 52 ESR Win XP OS. Silverlight plug-in stopped working just yesterday on Netflix and my Win XP Pro OS. I have uninstalled the older version and downloaded the correct version I need 5.1.4.1.2 and it is installed but still doesn't work with Netflix. I cannot find in the registry Netflix and Silverlight permission to run the plug in. This is a problem and needs to be fixed. I don't have the money or means to upgrade my OS at this time. I have no tv either. I have been in contact with Microsoft and Netflix and they determined that the problem lies with Mozilla. I cannot use any other browser as Chrome does not work with Netflix and Win XP either due to unable to update WidevineCdm on XP.

Chosen solution

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key;’’'<Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • Google Update
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Shockwave Flash 26.0 r0
  • 5.1.41212.0
  • VLC media player Web Plugin
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

Chosen Solution

Type about:addons<enter> in the address bar to open the Add-ons Manager. Hot key;’’'<Control> (Mac=<Command>) <Shift> A)

On the left side of the page, select Plugins. Make sure the ones you want to use are set to Ask or Allow. ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and Left-click the icon. Select Permissions. In the menu, Make sure the ones you want to use are set to Ask or Allow.

Type '''about:addons'''<enter> in the address bar to open the '''Add-ons Manager. ''' Hot key;’’'<Control> ''(Mac=<Command>)'' <Shift> A)''' On the left side of the page, select '''Plugins. ''' Make sure the ones you want to use are set to '''Ask''' or '''Allow. ''' ++++++++++++++++++++++++++++++++++++++++ Go to the web page. Once the page is loading, mouse to the address bar and '''Left-click''' the icon. Select '''Permissions. ''' In the menu, Make sure the ones you want to use are set to '''Ask''' or '''Allow. '''

Question owner

Thank you for the additional information to locate permissions on Netflix, however, that did not solve the problem I have followed your steps and shut down and reopened netflix and I still get the request to download silverlight. I have attached a screen shot showing the permissions and the site results. Thank you again.

Thank you for the additional information to locate permissions on Netflix, however, that did not solve the problem I have followed your steps and shut down and reopened netflix and I still get the request to download silverlight. I have attached a screen shot showing the permissions and the site results. Thank you again.
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers
Hmm. I just used this link and was told to download Silverlight. https://www.microsoft.com/getsilverlight/get-started/install/default.aspx I did. But when I run the installer, it told me that version of Silverlight was already installed. Here are other links you can check out; https://support.mozilla.org/kb/Using+the+Silverlight+plugin+with+Firefox https://www.microsoft.com/en-us/Search/result.aspx?q=Silverlight http://social.technet.microsoft.com/wiki/contents/articles/30387.silverlight-troubleshooting-installation.aspx
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

I checked with my Firefox ESR. Silverlight 5 (5.1.50907.0)

I checked with my Firefox ESR. Silverlight 5 (5.1.50907.0)
cor-el
  • Top 10 Contributor
  • Moderator
17537 solutions 158575 answers

Make sure that DRM is enabled and that you have the Widevine plugin.

Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components.

Make sure that DRM is enabled and that you have the Widevine plugin. Try to toggle DRM off/on to see if that makes Firefox (re)load DRM components. *Options/Preferences -> Content: Play DRM *https://support.mozilla.org/en-US/kb/enable-drm

Question owner

FredMcD Mozilla says version 5.1412 silverlight is the minimum that will work so that's why I installed that version. I went from 5.13. I can try and find the 5.15 version. What the problem is with direct link on microsoft is it reads my computer version and downloads the 513 because that is the last compatible version for xp. I have to download from filehorse to get newer than 5.13 versions of silverlight. I will try the link you sent me for 5.15. I did try technet troubleshooting already. Cor-el Thank you, however, If you read the OP I stated that I cannot update or download the plugin Widevine for Chrome because I'm running win xp. I will try the DRM toggle however the article support is for firefox 51 and I'm running 52. I really don't want to use chrome anyway but I tried. Thank you for your help I will try all of this tomorrow and get back to you. Netflix said they are aware that their xp customers are having this problem. Antiquated systems I suppose. I wish I could upgrade to win 10 from xp since it's free right now, but even too old version to do that.

FredMcD Mozilla says version 5.1412 silverlight is the minimum that will work so that's why I installed that version. I went from 5.13. I can try and find the 5.15 version. What the problem is with direct link on microsoft is it reads my computer version and downloads the 513 because that is the last compatible version for xp. I have to download from filehorse to get newer than 5.13 versions of silverlight. I will try the link you sent me for 5.15. I did try technet troubleshooting already. Cor-el Thank you, however, If you read the OP I stated that I cannot update or download the plugin Widevine for Chrome because I'm running win xp. I will try the DRM toggle however the article support is for firefox 51 and I'm running 52. I really don't want to use chrome anyway but I tried. Thank you for your help I will try all of this tomorrow and get back to you. Netflix said they are aware that their xp customers are having this problem. Antiquated systems I suppose. I wish I could upgrade to win 10 from xp since it's free right now, but even too old version to do that.

Question owner

FIXED!! Ok. I had completed FredMcD's 1st suggestion about the permissions location check box. I uploaded the screen shot previously but it cut off the permission box showing the "allow". It still wasn't working. At that point I put my computer on standby for several hours. I just got back on to check this support feed. I have not done any other troubleshooting since and I just pulled up netflix to take a better screen shot of the permissions box and voila! it's working! Solved, yet still a mystery. Thank you, group hug :)

FIXED!! Ok. I had completed FredMcD's 1st suggestion about the permissions location check box. I uploaded the screen shot previously but it cut off the permission box showing the "allow". It still wasn't working. At that point I put my computer on standby for several hours. I just got back on to check this support feed. I have not done any other troubleshooting since and I just pulled up netflix to take a better screen shot of the permissions box and voila! it's working! Solved, yet still a mystery. Thank you, group hug :)
FredMcD
  • Top 10 Contributor
4259 solutions 59635 answers

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily.

Thank you for contacting Mozilla Support.

I am glad to hear that your problem has been resolved. If you haven't already, please select the answer that solves the problem. This will help other users with similar problems find the solution more easily. Thank you for contacting Mozilla Support.

Question owner

I selected the solution answer, I didn't try the others offered so I don't know if they would help as well. I am letting Netflix know the solution that worked for me as well as the other solutions that have been offered here so that the problem can be resolved within their support center.

I love Mozilla.

I selected the solution answer, I didn't try the others offered so I don't know if they would help as well. I am letting Netflix know the solution that worked for me as well as the other solutions that have been offered here so that the problem can be resolved within their support center. I love Mozilla.