X
Tap here to go to the mobile version of the site.

منتدى الدعم

Firefox believes that a certificate from one site belongs to another site

Posted

Hi,

I own the following website: http://antarkia.training

It is a private site of my business where we use an e-Learning platform named Moodle.

For years, I've used Firefox to acces it, including today in the morning.

But some hours later, I can't acces it, because Firefox "thinks" it is using a secure connection (https), and it is not "well configured".

When I check the error information, I find this (I'm translating from Spanish):

antarkia.training uses an unvalid security certificate. The certificate is only valid for the following names: training.uwpd.wisc.edu, www.training.uwpd.wisc.edu Code error: SSL_ERROR_BAD_CERT_DOMAIN

The domain https://training.uwpd.wisc.edu/ also uses a Moodle platform, that I checked some days ago.

If I add the exception to Firefox, instead of seeing the "antarkia.training" Moodle webpage, I see the "training.uwpd.wisc.edu" Moodle webpage.

I've cleared the cache, cookies, etc., as well as all the exceptions I've created in Firefox, through the advanced options of the configuration (preferences) area.

Any suggestions will be appreciated.

PS If I usea another browser (Google Chrome, Opera, SeaMonkey), everything works well).

David Hernández

Hi, I own the following website: http://antarkia.training It is a private site of my business where we use an e-Learning platform named Moodle. For years, I've used Firefox to acces it, including today in the morning. But some hours later, I can't acces it, because Firefox "thinks" it is using a secure connection (https), and it is not "well configured". When I check the error information, I find this (I'm translating from Spanish): antarkia.training uses an unvalid security certificate. The certificate is only valid for the following names: training.uwpd.wisc.edu, www.training.uwpd.wisc.edu Code error: SSL_ERROR_BAD_CERT_DOMAIN The domain https://training.uwpd.wisc.edu/ also uses a Moodle platform, that I checked some days ago. If I add the exception to Firefox, instead of seeing the "antarkia.training" Moodle webpage, I see the "training.uwpd.wisc.edu" Moodle webpage. I've cleared the cache, cookies, etc., as well as all the exceptions I've created in Firefox, through the advanced options of the configuration (preferences) area. Any suggestions will be appreciated. PS If I usea another browser (Google Chrome, Opera, SeaMonkey), everything works well). David Hernández

Chosen solution

Dear FredMCD,

Thank you for your quick response and also for the links.

You're not gonna believe this, but here's the way I solved the reported issue:

1) I checked the links you sent me, andI verified that there were no problems regarding antivirus software, a corporate proxy, etc.

2) I found the way to disable the "autocomplete mode" in Firefox:

about:config / browser.urlbar.autoFill / false

This solution worked for me.

Reference: https://support.mozilla.org/es/questions/1019210#answer-627032#answer-627032

3) Nevertheless, I was wandering why some hours before, everything was working well.

Did I check a dangerous website? Did I open an e-Mail with virus? Did I install a new software or updated a Firefox plugin?

No, I didn't.

4) For some reason the shortcuts of my keyboard stopped working (the virus hypothesis was begining to be the most probable, but where did I get the virus....mmmm...)

5) Searching the web, in order to solve the problem of the shortcuts, I read a message related to some special configurations of some keyboards, that are used to enhance the experience wiht videogames.

6) Right now, I don't play videogames, although it was one of my passinos when I was younger.

7) Nevertheless, I checked my keyboard configuration, and nothing was wrong in its software, but I found something "weird" in the hardware.

8) I use the "sleep mode" with some frequency, and the last time I used it, the button that I have to press to enable/disable it, was a little bit stuck.

After "liberating" or "releasing" it (I don't know the right word in English), everything worked fine (both the Firefox issue reported here, as well as the shortcut problem).

9) Strange way of solving a technical problem, isn't it? :-)

Again, thank you very much for your kind help.

David Hernández

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • npdivxplayerplugin
  • DivX Web Player version 2.0.0.254
  • Version 5.41.3.0
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.71.2 for Mozilla browsers
  • 6.0.12.448
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • Shockwave Flash 26.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0
  • 5.1.30514.0
  • SpawnApps Plugin
  • VLC media player Web Plugin
  • NPWLPG
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:52.0) Gecko/20100101 Firefox/52.0

More Information

FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

Helpful Reply

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate.

https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites

uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN configured their website improperly How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites

https://support.cdn.mozilla.net/media/uploads/images/thumbnails/2017-06-07-08-34-22-cb6da3.png

https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

There is security software like Avast, Kaspersky, BitDefender and ESET that intercept secure connections and send their own certificate. https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can https://support.mozilla.org/en-US/kb/firefox-and-other-browsers-cant-load-websites uses an invalid security certificate SSL_ERROR_BAD_CERT_DOMAIN configured their website improperly How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites https://support.cdn.mozilla.net/media/uploads/images/thumbnails/2017-06-07-08-34-22-cb6da3.png https://support.mozilla.org/en-US/kb/troubleshoot-SEC_ERROR_UNKNOWN_ISSUER

Chosen Solution

Dear FredMCD,

Thank you for your quick response and also for the links.

You're not gonna believe this, but here's the way I solved the reported issue:

1) I checked the links you sent me, andI verified that there were no problems regarding antivirus software, a corporate proxy, etc.

2) I found the way to disable the "autocomplete mode" in Firefox:

about:config / browser.urlbar.autoFill / false

This solution worked for me.

Reference: https://support.mozilla.org/es/questions/1019210#answer-627032#answer-627032

3) Nevertheless, I was wandering why some hours before, everything was working well.

Did I check a dangerous website? Did I open an e-Mail with virus? Did I install a new software or updated a Firefox plugin?

No, I didn't.

4) For some reason the shortcuts of my keyboard stopped working (the virus hypothesis was begining to be the most probable, but where did I get the virus....mmmm...)

5) Searching the web, in order to solve the problem of the shortcuts, I read a message related to some special configurations of some keyboards, that are used to enhance the experience wiht videogames.

6) Right now, I don't play videogames, although it was one of my passinos when I was younger.

7) Nevertheless, I checked my keyboard configuration, and nothing was wrong in its software, but I found something "weird" in the hardware.

8) I use the "sleep mode" with some frequency, and the last time I used it, the button that I have to press to enable/disable it, was a little bit stuck.

After "liberating" or "releasing" it (I don't know the right word in English), everything worked fine (both the Firefox issue reported here, as well as the shortcut problem).

9) Strange way of solving a technical problem, isn't it? :-)

Again, thank you very much for your kind help.

David Hernández

Dear FredMCD, Thank you for your quick response and also for the links. You're not gonna believe this, but here's the way I solved the reported issue: 1) I checked the links you sent me, andI verified that there were no problems regarding antivirus software, a corporate proxy, etc. 2) I found the way to disable the "autocomplete mode" in Firefox: about:config / browser.urlbar.autoFill / false This solution worked for me. Reference: https://support.mozilla.org/es/questions/1019210#answer-627032#answer-627032 3) Nevertheless, I was wandering why some hours before, everything was working well. Did I check a dangerous website? Did I open an e-Mail with virus? Did I install a new software or updated a Firefox plugin? No, I didn't. 4) For some reason the shortcuts of my keyboard stopped working (the virus hypothesis was begining to be the most probable, but where did I get the virus....mmmm...) 5) Searching the web, in order to solve the problem of the shortcuts, I read a message related to some special configurations of some keyboards, that are used to enhance the experience wiht videogames. 6) Right now, I don't play videogames, although it was one of my passinos when I was younger. 7) Nevertheless, I checked my keyboard configuration, and nothing was wrong in its software, but I found something "weird" in the hardware. 8) I use the "sleep mode" with some frequency, and the last time I used it, the button that I have to press to enable/disable it, was a little bit stuck. After "liberating" or "releasing" it (I don't know the right word in English), everything worked fine (both the Firefox issue reported here, as well as the shortcut problem). 9) Strange way of solving a technical problem, isn't it? :-) Again, thank you very much for your kind help. David Hernández

Modified by David Hernández

FredMcD
  • Top 10 Contributor
4230 solutions 59034 answers

That was very good work. Well done. Please flag your last post as Solved Problem so others will know.

That was very good work. Well done. Please flag your last post as '''Solved Problem''' so others will know.