ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Widevine Video Optimizer can not intall to Firefox ESR 52.2.1

  • 4 ردود
  • 14 have this problem
  • 115 views
  • آخر ردّ كتبه iamsimakov

more options

Hello! I try to look video with Widevine Classic Encryption. It's corporate link and I can not give it. I try open page with Widevine Video Optimizer plugin and it suggest me install plugin by link https://tools.google.com/dlpage/widevine/thankyou.html Plugin can not install by this link with text: Pluggin can not be installed because extension is damaged on this site.(rough description error)

OS Windows 7 Firefox version ESR 52.2.1 (64-bit)

What do you think about it? And would like to anybody can repeat this actions and install Widevine Video Optimizer.

Hello! I try to look video with Widevine Classic Encryption. It's corporate link and I can not give it. I try open page with Widevine Video Optimizer plugin and it suggest me install plugin by link https://tools.google.com/dlpage/widevine/thankyou.html Plugin can not install by this link with text: Pluggin can not be installed because extension is damaged on this site.(rough description error) OS Windows 7 Firefox version ESR 52.2.1 (64-bit) What do you think about it? And would like to anybody can repeat this actions and install Widevine Video Optimizer.

الحل المُختار

Thank you guys for your time. I just make downgrade to 50.1 version of Firefox. I tried before it downloading libs and put it to system32 folder and I tried to download folder with plugin's files and restart Firefox after each action but nothing. Now I solve my problem while Firefox is 50.1 version. When it will be updated I do not know what I will do. But now thanks to all.

Read this answer in context 👍 2

All Replies (4)

more options

That extension was not submitting for verification so it cannot be installed. It appears to contain a three-year-old plugin which may be obsolete now... I don't know.

Is this different from the DRM-related Widevine plugin that Firefox normally is able to install automatically? On my 32-bit Firefox, I have a gmp-widevinecdm folder in my Firefox profile with these contents:

gmp-widevinecdm\1.4.8.903

07/15/2016  06:03 PM         5,790,712 widevinecdm.dll
07/15/2016  06:03 PM             2,472 widevinecdm.dll.lib

If that will solve the problem, hopefully a volunteer can help you find a better download source (or figure out why Firefox isn't getting it automatically). See also: Watch DRM content on Firefox.

However, if you want to try the old one, perhaps -- I HAVE NOT TRIED THIS MYSELF -- you could:

  • If your system does not recognize the .xpi file as a ZIP archive, you may need to rename it with a .zip extension
  • In the xpi/zip file, click into the plugins folder and extract the npwidevinemediaoptimizer.dll file to a convenient location
  • Move the dll to the folder that opens when you use this shortcut:
    %APPDATA%\Mozilla\plugins
  • Exit Firefox and start it up again, which should trigger Firefox to discover that plugin there

Any luck?

more options

The extension is signed (I see a META-INF folder), so I don't think that there is a problem in that area, but I think that it would only have worked in a 32 bit Firefox version as it seems to be rather old (only mentions Windows 7 and 8) and the install.rdf file shows maxVersion 19*.

Firefox should be able to play DRM protected content with the built-in Widevine plugin.

Modified by cor-el

more options

This document contains working download DLLs for ZIP files whose contents appear to match what I have in my profile folder (at least as far as 32-bit Firefox for Windows is concerned):

https://bug1287925.bmoattachments.org/attachment.cgi?id=8779046

32-bit Firefox for Windows: WINNT_x86-msvc > fileUrl 64-bit Firefox for Windows: WINNT_x86_64-msvc > fileUrl

The links redirect, so if your Firefox or external software blocks redirects, that could be a problem.

more options

الحل المُختار

Thank you guys for your time. I just make downgrade to 50.1 version of Firefox. I tried before it downloading libs and put it to system32 folder and I tried to download folder with plugin's files and restart Firefox after each action but nothing. Now I solve my problem while Firefox is 50.1 version. When it will be updated I do not know what I will do. But now thanks to all.