ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Push Notification - How can I Disable the Pop Up?

  • 12 ردًا
  • 144 have this problem
  • 142 views
  • آخر ردّ كتبه jimpit

more options

Hi!

Since an FF update, I receive more and more push notification popups ('Would you like to receive notifications...'). It asks to en/disable it for a specific website but than it comes on another one. I don't want this feature and I never have asked for it.

How can I disable this pop up once and forever? I tried dom.webnotifications.serviceworker.enabled to false and dom.webnotifications.enabled to false, but the notification popups contnue to disturb me. I simply don't want to be asked.

Dimi (FF 51.0.1 32 bit on win 7 64)

Hi! Since an FF update, I receive more and more push notification popups ('Would you like to receive notifications...'). It asks to en/disable it for a specific website but than it comes on another one. I don't want this feature and I never have asked for it. How can I disable this pop up once and forever? I tried dom.webnotifications.serviceworker.enabled to false and dom.webnotifications.enabled to false, but the notification popups contnue to disturb me. I simply don't want to be asked. Dimi (FF 51.0.1 32 bit on win 7 64)

الحل المُختار

Thank you, jscher2000!

Step 5 works.

@FF programmers: If you add a new feature like a pop up that might disturb users, please always add a simple ‘always off’-switch. Thank you.

Dimi

Read this answer in context 👍 22

All Replies (12)

more options

Did you check the permissions for this website in "Tools -> Page Info -> Permissions" ?

See also notification.feature.enabled


Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Some sites now show their own fancy, graphical panel to tempt you into accepting notifications BEFORE triggering Firefox's permission request mechanism. (Comparison image attached.) Sites usually remember your selection using a cookie, so if you delete cookies regularly (or block them), you'll see the question again and again. It can get annoying.

There is no built-in setting to suppress these pre-check overlays. You can hide them using an add-on such as uBlock Origin or another element hiding extension, although poorly designed sites might stop working while waiting for your response...

(Older response with tons of settings details: https://support.mozilla.org/questions/1165867#answer-981820)

Modified by jscher2000 - Support Volunteer

more options

Thank you for the information. Nothing works. The Firefox's permission request mechanism cannot be switched off.

In uBlock, I did not find a fitting switch. Is there any?

The notification feature seems to be poorly designed. They simply forgot to give the user the possibility to fully switch it off.

Either they implement it soon, or I have to go back to FF 43.

Dimi

more options

DimiSp said

Nothing works. The Firefox's permission request mechanism cannot be switched off.

What page are you using for testing?

In uBlock, I did not find a fitting switch. Is there any?

It's not a setting for whether sites can request to send notifications, it is a feature that lets you zap parts of a page you never want to see. Check this article for more info: https://www.ghacks.net/2017/02/21/ublock-origin-how-to-remove-any-element-from-a-page-permanently/

The notification feature seems to be poorly designed. They simply forgot to give the user the possibility to fully switch it off.

The three settings in the post I linked to should cover every possibility that is a Firefox dialog. It would be helpful to see the problem display if they aren't working for you.

more options

Hi Jscher2000

Thank you.

The pop up comes from the FF address bar for instance at www.wallstreet-online.de.

I want to block these pop ups totally - for all websites at once.

Dimi

more options

DimiSp said

The pop up comes from the FF address bar for instance at www.wallstreet-online.de.

I had to use numbered step (5) to stop the prompt on that site (numbered steps (1) through (4) were not enough): https://support.mozilla.org/questions/1165867#answer-981820

more options

الحل المُختار

Thank you, jscher2000!

Step 5 works.

@FF programmers: If you add a new feature like a pop up that might disturb users, please always add a simple ‘always off’-switch. Thank you.

Dimi

more options

"The notification feature seems to be poorly designed. They simply forgot to give the user the possibility to fully switch it off. "

After the last FF update, I'm receiving UNWANTED 'Notifications'. I don't want ANY notifications. EVER ! Now, I can't delete the list of 'Notifications' no matter what I try. THIS IS A VERY POORLY-DESIGNED FEATURE. Please include a "KILL SWITCH" button or link to totally eliminate the feature !!!

more options

Hi jimpit, where are you getting unwanted notifications? Do you want to give URLs of specific pages for people to check?

Also, did you try the steps here: https://support.mozilla.org/questions/1165867#answer-981820

more options

Thanks for helping... Performed the all-Site Persistent Disable...

about:config webno

Changed #3 and #4 to 'False' I hope that will prevent any additional notifications.

NOW, HOW DO I DELETE THE 5 OR 6 NOTIFICATIONS LISTED UNDER THE NOTIFICATIONS 'BELL'??? .

more options

jimpit said

NOW, HOW DO I DELETE THE 5 OR 6 NOTIFICATIONS LISTED UNDER THE NOTIFICATIONS 'BELL'???

Where is the bell? Is it part of Firefox's interface, or in a web page, or outside of Firefox?

more options

WOW, jscher2000 ! Many thanks for your questions ! If I weren't so frigging DENSE I woulda' realized my problem isn't at all related to Firefox ! My home page is YAHOO.com... and the 'BELL' (and list of notifications) is a part of YAHOO'S home page !!! I gotta chase the Yahoo gurus to find a solution.

Many thanks again for your help !!! Regards, Jim