X
Tap here to go to the mobile version of the site.

منتدى الدعم

Occasional long delays from clicking on a link and the link opening

Posted

Over the past couple of weeks we've been noticing occasional long delays from clicking on a link and the link opening. We are a small office an run a variety of XP and Win7 machines with Firefox 52 & 53. It happens more often on some machines than others, the delay is also variable from about 15 seconds to about 120 seconds, again that delay seems consistent per machine.

I've been using our Intranet to try and isolate the problem, after clicking on a link the status bar at the bottom shows "waiting for intranet...." and that sits there until the page loads. The Intranet server is in the same subnet as the workstations.

I have tried the following :- 1) Changing DNS name for the server IP. I have also done an NSLOOKUP in a command shell in the background whilst waiting. 2) Disabled Proxy settings in the OS. Also set FF to be no proxy. 3) MS Internet Explorer appears to be OK. I can access the Intranet from the same PC whilst FF is waiting 4) Running FF in Safe Mode 5) Trying FF Portable 6) Disabled anti virus 7) Disabled FF Health Report, Block Dangerous Content, 8) Set geo.enabled = false

I've used a network sniffer and can see the initial GET is not sent until after the delay so it does not look like a network problem. There is quite a bit of FF traffic though, for example detectportal and self-repair at mozilla.com.

I'm really stumped, it seems the randomly FF is just sat twiddling its thumbs before contacting the target website.

Over the past couple of weeks we've been noticing occasional long delays from clicking on a link and the link opening. We are a small office an run a variety of XP and Win7 machines with Firefox 52 & 53. It happens more often on some machines than others, the delay is also variable from about 15 seconds to about 120 seconds, again that delay seems consistent per machine. I've been using our Intranet to try and isolate the problem, after clicking on a link the status bar at the bottom shows "waiting for intranet...." and that sits there until the page loads. The Intranet server is in the same subnet as the workstations. I have tried the following :- 1) Changing DNS name for the server IP. I have also done an NSLOOKUP in a command shell in the background whilst waiting. 2) Disabled Proxy settings in the OS. Also set FF to be no proxy. 3) MS Internet Explorer appears to be OK. I can access the Intranet from the same PC whilst FF is waiting 4) Running FF in Safe Mode 5) Trying FF Portable 6) Disabled anti virus 7) Disabled FF Health Report, Block Dangerous Content, 8) Set geo.enabled = false I've used a network sniffer and can see the initial GET is not sent until after the delay so it does not look like a network problem. There is quite a bit of FF traffic though, for example detectportal and self-repair at mozilla.com. I'm really stumped, it seems the randomly FF is just sat twiddling its thumbs before contacting the target website.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 25.0 r0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:53.0) Gecko/20100101 Firefox/53.0

More Information

FredMcD
  • Top 10 Contributor
4246 solutions 59404 answers

This could be a bottleneck with your modem/WiFi or ISP. Have your ISP test your service.

As a test shut down all computers but for one. Is the problem still there?

This could be a bottleneck with your modem/WiFi or ISP. Have your ISP test your service. As a test shut down all computers but for one. Is the problem still there?

Question owner

I can't edit the above so am sorry the formatting of the list didn't come out. I've two more points to add. 1) I've also disabled Certificates: Query OCSP responder... and that hasn't changed anything

2) Whilst it's waiting I can open a new tab and use about:preferences and also about:config. That looks like it's not the core of the browser getting stuck.

I can't edit the above so am sorry the formatting of the list didn't come out. I've two more points to add. 1) I've also disabled Certificates: Query OCSP responder... and that hasn't changed anything 2) Whilst it's waiting I can open a new tab and use about:preferences and also about:config. That looks like it's not the core of the browser getting stuck.

Question owner

FredMcD said

This could be a bottleneck with your modem/WiFi or ISP. Have your ISP test your service. As a test shut down all computers but for one. Is the problem still there?

Hi, thanks for the ideas but as I said this is also affecting our Intranet which is on the same LAN as the workstations, all CAT5 cabling via a single core switch. The modem/WiFi/ISP are not in the link at all for this problem. Machines have been rebooted.

''FredMcD [[#answer-972464|said]]'' <blockquote> This could be a bottleneck with your modem/WiFi or ISP. Have your ISP test your service. As a test shut down all computers but for one. Is the problem still there? </blockquote> Hi, thanks for the ideas but as I said this is also affecting our Intranet which is on the same LAN as the workstations, all CAT5 cabling via a single core switch. The modem/WiFi/ISP are not in the link at all for this problem. Machines have been rebooted.

Question owner

With Firefox 53.0.3 64bit running Win7 x64 I've just had a pause of about 5-10 seconds, I wasn't monitoring but became aware of the delay. The webpage has a processing timer and that responded in under 0.25 of a second. This does look like the same problem but because of the shorter delay it's less intrusive. CPU is a 2.9GHz i5

It feels that we are more likely to have this delay on first use after starting FF. I think all/most users in our business are affected with a varying frequency. The length of delay, one user is about 120 seconds (dual Xeon 5160 so quite a bit older than the i5), appears to be consistent to that user/machine so possibly related to CPU speed?

With Firefox 53.0.3 64bit running Win7 x64 I've just had a pause of about 5-10 seconds, I wasn't monitoring but became aware of the delay. The webpage has a processing timer and that responded in under 0.25 of a second. This does look like the same problem but because of the shorter delay it's less intrusive. CPU is a 2.9GHz i5 It feels that we are more likely to have this delay on first use after starting FF. I think all/most users in our business are affected with a varying frequency. The length of delay, one user is about 120 seconds (dual Xeon 5160 so quite a bit older than the i5), appears to be consistent to that user/machine so possibly related to CPU speed?

Question owner

I can confirm that this problem does not affect Opera or MSIE 11, it's only FireFox.

Unless we can find a solution then after many years it's going to be time to move away from FF as this makes it unusable.

I can confirm that this problem does not affect Opera or MSIE 11, it's only FireFox. Unless we can find a solution then after many years it's going to be time to move away from FF as this makes it unusable.
FredMcD
  • Top 10 Contributor
4246 solutions 59404 answers

Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?


Start your Computer in safe mode. Then start Firefox. Try Safe websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Start Firefox in Safe Mode] {web link} by holding down the '''<Shift> ''(Mac=Options)''''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there? -------------- Start your '''Computer''' in safe mode. Then start Firefox. Try '''Safe''' websites. Is the problem still there? http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia
jscher2000
  • Top 10 Contributor
8695 solutions 71066 answers

The captive portal detection can be disabled, since you are not worried about a hotspot requiring authentication.

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste capt and pause while the list is filtered

(3) Double-click the network.captive-portal-service.enabled preference to switch the value from true to false

That may or may not make any difference to the delayed request, but should reduce background traffic.


Firefox's Network Monitor may help show where delays are occurring. Open the monitor in the developer tools panel BEFORE navigating to the test site. Otherwise, you will need to reload the site which may affect the results of your test.

Each request has a set of timing bars for different aspects of the total load time to see whether DNS resolution or something else might be a factor. Or just "waiting..."

https://developer.mozilla.org/docs/Tools/Network_Monitor

The captive portal detection can be disabled, since you are not worried about a hotspot requiring authentication. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''capt''' and pause while the list is filtered (3) Double-click the '''network.captive-portal-service.enabled''' preference to switch the value from true to false That may or may not make any difference to the delayed request, but should reduce background traffic. ---- Firefox's Network Monitor may help show where delays are occurring. Open the monitor in the developer tools panel BEFORE navigating to the test site. Otherwise, you will need to reload the site which may affect the results of your test. Each request has a set of timing bars for different aspects of the total load time to see whether DNS resolution or something else might be a factor. Or just "waiting..." https://developer.mozilla.org/docs/Tools/Network_Monitor

Question owner

FredMcD - I've tried Windows in Safe Mode and the problem didn't occur. That's not totally conclusive but I tried it a few times and the delay didn't happen. I think this does confirm that it's a problem with FF on the local machine.

jscher2000 - disabling the network.captive-portal-service.enabled does not make a difference, with it false I still get the delays.

I've looked at the network monitor and on the higher level there is nothing happening before the GET. I'll spend a little more time looking in the monitoring but have other things to do and need to get the office working.

FredMcD - I've tried Windows in Safe Mode and the problem didn't occur. That's not totally conclusive but I tried it a few times and the delay didn't happen. I think this does confirm that it's a problem with FF on the local machine. jscher2000 - disabling the network.captive-portal-service.enabled does not make a difference, with it false I still get the delays. I've looked at the network monitor and on the higher level there is nothing happening before the GET. I'll spend a little more time looking in the monitoring but have other things to do and need to get the office working.
cor-el
  • Top 10 Contributor
  • Moderator
17475 solutions 157940 answers

Try to set network.dns.get-ttl to false on the about:config page.

Try to set <b>network.dns.get-ttl</b> to false on the <b>about:config</b> page.

Question owner

I'm finally getting somewhere with trying to understand this frustrating problem. Not got a solution other than don't use FF yet though.

Using a network sniffer I can see that the HTTP GET is not sent to the server from the PC until the end of the "Waiting..." but according to FF monitor the GET is sent straight away and it's waiting for a reply. I used Process Explorer to monitor the network activity of FireFox and can see that all the traffic is going through local port 30606, which seems to be the ESET anti-virus proxy.

  • The delay does not always happen and I haven't found a way of consistently replicating it. It seems more likely to happen when first starting FF
  • The length of Waiting appears to correlate to the age of the PC and when it happens is always consistent for that machine. On some recent machines the delay is around 5 seconds so barely noticeable but older machines can be up to 90 seconds.
  • When FF was Waiting I launched Opera and connected to the same page. This was still routed through 30606 but the page loaded very quickly. Internet Explorer does not have these delays either.
  • I have this problem in WinXP and Win7 with FF v52 and v53 x86 and x64. I have not tried older versions of FF
  • I have tried changing the UserAgent string in FF and that does not alter the problem.
  • If I disable ESET the delays still occur and it's still routed through 30606.
  • If I uninstall ESET the delays do not seem to happen and I can see the ProcessExplorer network activity is straight to the target. With Windows in Safe Mode the problem did not appear either.
  • Installing ESET again the "Waiting" comes back.
  • All machines are running ESET 5.0.2265.0.

This appears to be a very specific interaction between FireFox and ESET.

I will raise this with ESET support now and see what they say,

I'm finally getting somewhere with trying to understand this frustrating problem. Not got a solution other than don't use FF yet though. Using a network sniffer I can see that the HTTP GET is not sent to the server from the PC until the end of the "Waiting..." but according to FF monitor the GET is sent straight away and it's waiting for a reply. I used Process Explorer to monitor the network activity of FireFox and can see that all the traffic is going through local port 30606, which seems to be the ESET anti-virus proxy. * The delay does not always happen and I haven't found a way of consistently replicating it. It seems more likely to happen when first starting FF * The length of Waiting appears to correlate to the age of the PC and when it happens is always consistent for that machine. On some recent machines the delay is around 5 seconds so barely noticeable but older machines can be up to 90 seconds. * When FF was Waiting I launched Opera and connected to the same page. This was still routed through 30606 but the page loaded very quickly. Internet Explorer does not have these delays either. * I have this problem in WinXP and Win7 with FF v52 and v53 x86 and x64. I have not tried older versions of FF * I have tried changing the UserAgent string in FF and that does not alter the problem. * If I disable ESET the delays still occur and it's still routed through 30606. * If I uninstall ESET the delays do not seem to happen and I can see the ProcessExplorer network activity is straight to the target. With Windows in Safe Mode the problem did not appear either. * Installing ESET again the "Waiting" comes back. * All machines are running ESET 5.0.2265.0. '''This appears to be a very specific interaction between FireFox and ESET.''' I will raise this with ESET support now and see what they say,
FredMcD
  • Top 10 Contributor
4246 solutions 59404 answers

An old article; In case you're using ESET security software, please try to disable and re-enable SSL/TLS protocol filtering or generally disable the interception of secure connections as described in ESET’s support article: http://support.eset.com/kb3126/

An old article; In case you're using ESET security software, please try to disable and re-enable SSL/TLS protocol filtering or generally disable the interception of secure connections as described in ESET’s support article: http://support.eset.com/kb3126/