Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I have tried all the fixes for the "your connection is not secure" and none of them work for me.

  • 1 reply
  • 1 has this problem
  • آخر ردّ كتبه cor-el

more options

I have tried all of the fixes and resets. It happens for anything an everything I try to do on mozilla. Even if I just open it up. Can you please let me know why this has just happened out of the blue, an how I can fix it.

All Replies (1)

more options

What kind of error message do you see?

Note that Firefox 51+ will mark HTTP connections with a padlock that has a strike through it and show "Connection is Not Secure" if you click the Control Center 'i' button at the left end of the location/address bar.


Did you make sure that your clock is set to the correct date (year, month) and time (time zone)?

You can check the date and time and time zone in the clock on your computer: (double) click the clock icon on the Windows Taskbar.