Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hebrew fonts don't show as expected in firefox 4.0 on Ubuntu 16.04

  • 15 replies
  • 1 has this problem
  • 47 views
  • آخر ردّ كتبه ronbarak

more options
Attached screenshots

All Replies (15)

more options

Why the rather old and vulnerable Firefox 4.0 (four.zero) from March 2011 when even Ubuntu 16.04 which is a LTS versions comes with 45.0.2.

https://www.mozilla.org/firefox/releases/

As you can see there has been a lot of security fixes (many that are critical) that the old Firefox 4.0 does not have. https://www.mozilla.org/security/known-vulnerabilities/firefox/

Ok you say a "filling Hebrew forms online is only supported with firefox up to version 4" as are you sure it was not saying you need at least Firefox 4.0 or later ?

If it does insist on Firefox 4.0 or older then perhaps the site has not been updated for almost six years to work properly in current web browsers.

Modified by James

more options

James, the necessity to use an old FF is explained in the attachments, namely: "I need to use an older firefox, because filling Hebrew forms online is only supported with firefox up to version 4." As it is a governmental site, there's not much I can do.

Modified by ronbarak

more options

You likely do not have a font installed that covers the Hebrew Unicode range, so you need to check the software installation of your Linux distribution and install a suitable font. Note that the hex code in the little boxes shows what character this is about (Hebrew: 0590-05ff).

You can look at the latest version of the DejaVu fonts (Sans and Serif).

Modified by cor-el

more options

Thanks for the suggestion cor-el. However, even with

openstack@ubuntu1604:~$ sudo -H apt-get install culmus xfonts-efont-unicode xfonts-efont-unicode-ib xfonts-intl-european msttcorefonts Reading package lists... Done Building dependency tree Reading state information... Done Note, selecting 'ttf-mscorefonts-installer' instead of 'msttcorefonts' culmus is already the newest version (0.130-1). xfonts-efont-unicode is already the newest version (0.4.2-8). xfonts-efont-unicode-ib is already the newest version (0.4.2-8). xfonts-intl-european is already the newest version (1.2.1-10). ttf-mscorefonts-installer is already the newest version (3.4+nmu1ubuntu2). 0 upgraded, 0 newly installed, 0 to remove and 23 not upgraded. openstack@ubuntu1604:~$

I still see no Hebrew fonts (see attchment showing how https://www.haifa.muni.il/Services/PSC/Arnona/pages/arnona-forms.aspx looks on my Ubuntu system).

more options

ronbarak said

James, the necessity to use an old FF is explained in the attachments, namely: "I need to use an older firefox, because filling Hebrew forms online is only supported with firefox up to version 4."

I don't read Hebrew but that is completely ridiculous. They can't possibly require such an old version.

What if you try the toolbar download from this page: http://oldgov.gov.il/FirstGov/Forms/download (Firefox עבור גרסאות 38,39,40).

Doesn't work for me on Windows, but neither do any of the other toolbar download URLs.

more options

jscher2000 said

What if you try the toolbar download from this page: http://oldgov.gov.il/FirstGov/Forms/download (Firefox עבור גרסאות 38,39,40). Doesn't work for me on Windows, but neither do any of the other toolbar download URLs.

I also failed to install the toolbar on Windows, and have an open call on this issue with gov.il's support.

more options

The extension isn't signed, so can't be installed in current releases. The toolbar has binary components only for Firefox עבור גרסאות 38,39,40 as its manifest file shows.

interfaces components/libagat.xpt
component {14af475c-c61a-4a26-a558-590c9a873c31} components/storage.js
contract @agat.co.il/storage;1 {14af475c-c61a-4a26-a558-590c9a873c31}
binary-component components/ff38/win32/agat.dll ABI=WINNT_x86-msvc appversion<39.0
binary-component components/ff38/linux/libagat-x86_32.so ABI=Linux_x86-gcc3 appversion<39.0
binary-component components/ff38/linux/libagat-x86_64.so ABI=Linux_x86_64-gcc3 appversion<39.0
binary-component components/ff39/win32/agat.dll ABI=WINNT_x86-msvc appversion=39.0
binary-component components/ff39/linux/libagat-x86_32.so ABI=Linux_x86-gcc3 appversion=39.0
binary-component components/ff39/linux/libagat-x86_64.so ABI=Linux_x86_64-gcc3 appversion=39.0
binary-component components/ff40/win32/agat.dll ABI=WINNT_x86-msvc appversion>=40.0
binary-component components/ff40/linux/libagat-x86_32.so ABI=Linux_x86-gcc3 appversion>=40.0
binary-component components/ff40/linux/libagat-x86_64.so ABI=Linux_x86_64-gcc3 appversion>=40.0

You can try the Firefox 38.9.0 ESR version as that is more recent than the Firefox 40 version.

You can try to start Firefox via a terminal window to be able to see any error messages.

more options

Thanks for the suggestion of using firefox-38.8.0esr With it, at last, I can see the Hebrew fonts.

Even with that version, I'm unable to installed the mandatory toolbar (see attached error).

cor-el said

The extension isn't signed, so can't be installed in current releases.

Is there a way to circumvent this, and thus being able to install the toolbar on firefox-38.8.0esr?

more options

I couldn't find a way to download the toolbar, but that could be due to how my Firefox identifies its default language, my location, or other reasons. Since you can't download it either using a presumably more appropriate default language and location, hopefully they will give you a better link.

more options

Doesn't this link work?

  • http://forms.gov.il/download/agtoolbar.xpi
more options

cor-el said

Doesn't this link work?
  • http://forms.gov.il/download/agtoolbar.xpi

It gives the attached error message:

more options

Can you right-click that button and use "Save Link As" as that is what I did to get the xpi file?

Note that you can only install this toolbar on a supported Firefox version.

more options

Hi cor-el, as a data point, I tried the right-click method and Firefox downloaded the error page (HTML file saved with .xpi file extension).

more options

The download link worked for me on last Friday and I got the XPI file of size 1.8 MB. Currently I get the same error page, so it looks that something has changed on the server and maybe they have removed the file because only outdated Firefox versions were supported. A toolbar that uses binary components only work with the version it is compiled against.

more options

cor-el said

Can you right-click that button and use "Save Link As" as that is what I did to get the xpi file? Note that you can only install this toolbar on a supported Firefox version.

This procedure gives a file to display the error message. ---

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.0 Transitional//EN">
<!-- saved from url=(0037)http://www.gov.il/firstgov/hklasfklas -->
<HTML><HEAD><TITLE>Error Forms</TITLE>
<META content="text/html; charset=utf-8" http-equiv=Content-Type 
pageEncoding="utf-8">
<META name=GENERATOR content="MSHTML 9.00.8112.16437">
<META name=Author content="">
<META name=Keywords content="">
<META name=Description content=""><LINK rel=stylesheet type=text/css 
href="Error_files/master.css"><LINK rel=stylesheet type=text/css 
href="Error_files/boxesNew.css"><LINK rel=stylesheet type=text/css 
href="Error_files/Shoham.css"><LINK rel=stylesheet type=text/css 
href="Error_files/GlobalElements.css"></HEAD>
<BODY>

<CENTER>
<TABLE dir=rtl border=0 cellSpacing=0 borderColor=green cellPadding=0 
width="80%" height="80%">
  <TBODY>
  <TR>
    <TD height=15></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR>
    <TD colSpan=3><IMG src="http://forms.gov.il/ErrorPage/new-headerF2.jpg"> </TD>
    <TD width=30></TD>
    <TD></TD></TR>
  <TR>
    <TD height=40></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR align=right>
    <TD></TD>
    <TD colSpan=2>גולש יקר, הפעולה אותה ביצעת אינה נתמכת ובשל כך לא ניתן להציג 
      את הדף המבוקש. </TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR align=right>
    <TD></TD>
    <TD colSpan=2>ניתן לפנות לצוות התמיכה לדיווח על הודעה זו לפי הפרטים הבאים: 
    </TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR align=right>
    <TD></TD>
    <TD colSpan=2>טלפון: 02-6664646 </TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR align=right>
    <TD></TD>
    <TD colSpan=2>דואר אלקטרוני: noc@tehila.gov.il </TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR>
    <TD></TD></TR>
  <TR dir=ltr align=left>
    <TD></TD>
    <TD colSpan=2>The requested operation is not supported, and therefore can 
      not be displayed. </TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR dir=ltr align=left>
    <TD></TD>
    <TD colSpan=2>A support team is available at : 02-6664646 or 
      noc@tehila.gov.il </TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR>
    <TD height=35></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR align=center>
    <TD width=40></TD><!--	<TD width="30px"></TD>
-->
    <TD><A href="http://www.gov.il/">לפורטל הממשלה </A></TD>
    <TD><A href="http://www.gov.il/">To E-Gov Portal</A> </TD></TR>
  <TR>
    <TD></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR>
  <TR>
    <TD height=35></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD>
    <TD></TD></TR></TBODY></TABLE></CENTER></BODY></HTML>

Modified by cor-el