ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

As of January 1st, Firefox is no longer loading my web page searches, even for saved bookmarks. Is there an update I'm missing?

  • 4 ردود
  • 2 have this problem
  • 21 views
  • آخر ردّ كتبه jscher2000

more options

Starting around the 1st of the year, my Firefox bookmarks and any web pages won't load. The browser just spins out. If I quit and then restore my previous history, it works for a session. After I put my computer on "sleep", the next time I open the browser it's all spinning wheels again. Is there an update I'm missing? I'm using 50.1.0 for Mac (OS 10.10.5).

All Replies (4)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

InkyType said

If I quit and then restore my previous history, it works for a session. After I put my computer on "sleep", the next time I open the browser it's all spinning wheels again.

What method are you using for restoring your previous history? Do you mean you Quit Firefox, then after starting it up to your home page, you use the item on the History menu to Restore Previous Session?

And the problem occurs when you let your Mac sleep while Firefox is still running?

Over there years there have occasionally been problems with Firefox being very groggy after the system resumes from sleep. I think this was solved on Windows after users were able to point to specific sites that were associated with the problem so developers could figure out what they were doing.

I have to admit I don't follow the Mac-specific problems closely, but if you notice any patterns with particular sites, it would be helpful to note those. I would think that ones which regularly update themselves or set up notifications in the background are more likely to create issues related to sleep than those which are static and wait for you to refresh/reload them.

more options

Starting in Safe Mode seems to solve the problem.

more options

If Safe Mode works, usually the culprit is one of your extensions. You can view, update, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then cast a critical eye over the list on the right side. All extensions are optional. If in doubt, disable.

Note the button above the list with a gear/cog icon: click that to Check for Updates in case this was a recently fixed bug.

Often a link will appear above at least one disabled/updated extension to restart Firefox. You can complete your work on the tab and click one of the links as the last step.

Any improvement?