X
Tap here to go to the mobile version of the site.

منتدى الدعم

"Invisible" text only shows when highlighting. Only ocurs on 49.0 and higher.

Posted

My routers web configuration page doesn't show certain text in Firefox, but displays fine in both IE and Chrome. Images attached showing an example of Firefox 50 with the "invisible" text, Firefox 50 with the "invisible" text highlighted, and IE 11 with it displaying correctly. I have already tried a completely clean install of both Firefox 50 x86 & x64 with no additional add-ons or extensions installed.

EDIT: The issue only exists on Firefox 49.0 and above. I tried 40.0 through 48.0.2 and the site displays fine. Tried 49.0 through 53.0a1 and the bug is present.

My routers web configuration page doesn't show certain text in Firefox, but displays fine in both IE and Chrome. Images attached showing an example of Firefox 50 with the "invisible" text, Firefox 50 with the "invisible" text highlighted, and IE 11 with it displaying correctly. I have already tried a completely clean install of both Firefox 50 x86 & x64 with no additional add-ons or extensions installed. EDIT: The issue only exists on Firefox 49.0 and above. I tried 40.0 through 48.0.2 and the site displays fine. Tried 49.0 through 53.0a1 and the bug is present.
Attached screenshots

Modified by D34DL1N3R

Additional System Details

Installed Plug-ins

  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.111.2 for Mozilla browsers
  • Shockwave Flash 23.0 r0
  • 5.1.50901.0

Application

  • Firefox 50.0
  • User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:50.0) Gecko/20100101 Firefox/50.0
  • Support URL: https://support.mozilla.org/1/firefox/50.0/WINNT/en-US/

Extensions

  • Application Update Service Helper 1.0 (aushelper@mozilla.org)
  • Multi-process staged rollout 1.5 (e10srollout@mozilla.org)
  • Pocket 1.0.5 (firefox@getpocket.com)
  • Web Compat 1.0 (webcompat@mozilla.org)
  • Logitech SetPoint 6.5 ({F003DA68-8256-4b37-A6C4-350FA04494DF}) (Inactive)
  • RoboForm Toolbar 7.9.23.0 ({22119944-ED35-4ab1-910B-E619EA06A115}) (Inactive)
  • Wondershare Video Converter Ultimate 7.1.0 (WSVCU@Wondershare.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: AMD Radeon HD 7900 Series
  • adapterDescription2:
  • adapterDeviceID: 0x679a
  • adapterDeviceID2:
  • adapterDrivers: aticfx64 aticfx64 aticfx64 aticfx32 aticfx32 aticfx32 atiumd64 atidxx64 atidxx64 atiumdag atidxx32 atidxx32 atiumdva atiumd6a atitmm64
  • adapterDrivers2:
  • adapterRAM: 3072
  • adapterRAM2:
  • adapterSubsysID: 201c1787
  • adapterSubsysID2:
  • adapterVendorID: 0x1002
  • adapterVendorID2:
  • clearTypeParameters: Gamma: 2.2 Pixel Structure: RGB ClearType Level: 100 Enhanced Contrast: 200
  • crashGuards: []
  • currentAudioBackend: wasapi
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.3.9600.18468
  • driverDate: 11-15-2016
  • driverDate2:
  • driverVersion: 21.19.164.1
  • driverVersion2:
  • featureLog: {u'fallbacks': [], u'features': [{u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Compositing', u'name': u'HW_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D11 Compositing', u'name': u'D3D11_COMPOSITING'}, {u'status': u'disabled', u'log': [{u'status': u'disabled', u'message': u'Disabled by default', u'type': u'default'}], u'description': u'Direct3D9 Compositing', u'name': u'D3D9_COMPOSITING'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct2D', u'name': u'DIRECT2D'}, {u'status': u'available', u'log': [{u'status': u'available', u'type': u'default'}], u'description': u'Direct3D11 hardware ANGLE', u'name': u'D3D11_HW_ANGLE'}]}
  • info: {u'AzureCanvasAccelerated': 0, u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'ApzWheelInput': 1}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes; Using D3D11 API
  • webgl2Renderer: (no info)
  • webglRenderer: Google Inc. -- ANGLE (AMD Radeon HD 7900 Series Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4257 solutions 59604 answers

Helpful Reply

Are you using any kind of page changing add-on?

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

Are you using any kind of page changing add-on? Start '''[https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode Firefox in Safe Mode]''' {web Link} by holding down the '''<Shift><br> ''(Mac=Options)'' ''' key, and then starting Firefox. A small dialog should appear. Click '''Start In Safe Mode''' (not Refresh). Is the problem still there?

Question owner

No additional extensions or plugins installed whatsoever. No change in safe mode.

No additional extensions or plugins installed whatsoever. No change in safe mode.

Modified by D34DL1N3R

FredMcD
  • Top 10 Contributor
4257 solutions 59604 answers

Type about:preferences#content<enter> in the address bar. Across from fonts and colors, press the Advanced button. On the bottom, turn on Allow Web Sites To Choose Their Own.

If there is still a problem, check the color settings.


Please try NoSquint Plus Manage site-specific zoom levels and color settings

Type '''about:preferences#content'''<enter> in the address bar. Across from '''fonts and colors,''' press the '''Advanced''' button. On the bottom, turn on '''Allow Web Sites To Choose Their Own.''' If there is still a problem, check the color settings. -------------- [https://addons.mozilla.org/en-US/firefox/addon/nosquint-plus/ Please try NoSquint Plus] Manage site-specific zoom levels and color settings

Question owner

No change. Keep in mind that everything is fresh. No default settings have been changed, no add-ons have been installed, etc. Reinstall doesn't help, safe mode doesn't help, changing font/color settings doesn't help.

I'll state again also, that versions below 49.0 do not have this issue, even with 100% exactly the same settings.

No change. Keep in mind that everything is fresh. No default settings have been changed, no add-ons have been installed, etc. Reinstall doesn't help, safe mode doesn't help, changing font/color settings doesn't help. I'll state again also, that versions below 49.0 do not have this issue, even with 100% exactly the same settings.
FredMcD
  • Top 10 Contributor
4257 solutions 59604 answers

Helpful Reply

See if this is any help; Remove History For One Site Open the History Manager <Control><Shift> H. In the search bar, enter the name of the site. Right click on one of the listings and select Forget About This Site. This should remove all information, including any passwords / settings.


Install an older version of Firefox {web link} Look for the directory of the version that you want. But remember that old versions may have security issues.

See if this is any help; '''[https://support.mozilla.org/kb/Clear+Recent+History#w_how-do-i-remove-a-single-website-from-my-history Remove History For One Site]''' Open the History Manager '''<Control><Shift> H.''' In the search bar, enter the name of the site. Right click on one of the listings and select '''Forget About This Site.''' This should remove all information, including any passwords / settings. ------------------- '''[https://support.mozilla.org/en-US/kb/install-older-version-of-firefox Install an older version of Firefox]''' {web link} Look for the directory of the version that you want. But remember that old versions may have security issues.

Question owner

No change.

No change.
FredMcD
  • Top 10 Contributor
4257 solutions 59604 answers

I called for more help.

I called for more help.
cor-el
  • Top 10 Contributor
  • Moderator
17531 solutions 158524 answers

What is the text color of the invisible text if you check that via the right-click context menu in the Inspector?

You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools -> Web Developer) with this element selected.

What is the text color of the invisible text if you check that via the right-click context menu in the Inspector? You can right-click and select "Inspect Element" to open the Inspector ("3-bar" menu button or Tools -> Web Developer) with this element selected. *https://developer.mozilla.org/Tools/Page_Inspector *https://developer.mozilla.org/Tools/Page_Inspector/How_to
jscher2000
  • Top 10 Contributor
8765 solutions 71703 answers

One of the changes in Firefox 49 was applying some style rules that sites intended for Google Chrome and Safari. These rules have properties that start with -webkit. Perhaps that's the issue? To switch that off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste webk and pause while the list is filtered

(3) Double-click the layout.css.prefixes.webkit preference to switch the value from true to false

You probably need to reload the web page to have Firefox re-render the style rules. Any difference?

One of the changes in Firefox 49 was applying some style rules that sites intended for Google Chrome and Safari. These rules have properties that start with -webkit. Perhaps that's the issue? To switch that off: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button promising to be careful. (2) In the search box above the list, type or paste '''webk''' and pause while the list is filtered (3) Double-click the '''layout.css.prefixes.webkit''' preference to switch the value from true to false You probably need to reload the web page to have Firefox re-render the style rules. Any difference?