Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Just updated Firefox to latest version and can no longer get to Norton Identity Safe login? What happened and how can I FIX IT!!!!

  • 1 reply
  • 1 has this problem
  • آخر ردّ كتبه jscher2000

more options

Worked prior to updating Mozilla version.

All Replies (1)

more options

First, could you check for updates to your Norton software to make sure it is current with any patches that might help.

There is a confusing set of reports on Norton's forum here: https://community.norton.com/en/forums/identity-safe-apparently-not-compatible-firefox-500

Automatic Private Browsing Mode

One problem users identified in that thread is that the Norton add-on doesn't work in automatic private browsing mode. Here's how you can check on that on the Options page:

"3-bar" menu button (or Tools menu) > Options

In the left column, click Privacy. Then on the right side, if you see:

  • Firefox will: Remember history -- you are NOT using automatic private browsing
  • Firefox will: Never remember history -- you are using automatic private browsing, to switch see the next line:
  • Firefox will: Use custom settings for history PLUS there's a checkmark in the box for "Always use private browsing mode" -- you are using automatic private browsing, to switch to normal mode, uncheck the box

Could it be e10s?

One of the headline changes in Firefox 48+ is e10s, which separates the browser interface process from the page content process. More and more users are gradually having this multiprocess feature switched on. Although Firefox checks your add-ons against a compatibility chart, there may be some subtleties that Firefox fails to detect. Let's check on that.

Are you using e10s?

You can check whether you have this feature turned on as follows. Either:

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, check the row for "Multiprocess Windows" and see whether the number on the left side of the fraction is greater than zero. If so, you are using e10s.

If you are using e10s:

If you think Firefox is not performing well or is using an unreasonable amount of resources now, you could evaluate whether e10s is causing this problem by turning it off as follows:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button promising to be careful.

(2) In the search box above the list, type or paste autos and pause while the list is filtered

(3) Double-click the browser.tabs.remote.autostart.2 preference to switch the value from true to false

Note: the exact name of the preference may vary, but it will start with browser.tabs.remote.autostart

At your next Firefox startup, it should run in the traditional way. Any difference?