X
Tap here to go to the mobile version of the site.

منتدى الدعم

every website connection not secure, won't load images after exception

Posted

I was having issues with pop-up adds on a select few websites and was a bit concerned i had inadvertently downloaded some adware or other malware. So i ran a local scan with ESET and looked around for methods to remove malware that may or may not have been present. One of the posts i found (i cant find it now >.<) said to check add-ons for anything unusual and to hit "Refresh Firefox" after removing them. I saw only AdblockPlus so i hit 'Refresh Firefox'

Its after that point that i immediately had issues obtaining certificates for almost every website, it didnt matter that i had been using it fine 10 minutes ago. But even if i added an exception the website would only load as raw text, no video, no images (i tried to upload a picture but its not letting me for some reason). at this point i installed chrome (which works fine) and tried reinstalling Firefox (probably not a good idea in hindsight), which did nothing noticeable to solve the issue.

At this point I've done everything suggested here https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

I was having issues with pop-up adds on a select few websites and was a bit concerned i had inadvertently downloaded some adware or other malware. So i ran a local scan with ESET and looked around for methods to remove malware that may or may not have been present. One of the posts i found (i cant find it now >.<) said to check add-ons for anything unusual and to hit "Refresh Firefox" after removing them. I saw only AdblockPlus so i hit 'Refresh Firefox' Its after that point that i immediately had issues obtaining certificates for almost every website, it didnt matter that i had been using it fine 10 minutes ago. But even if i added an exception the website would only load as raw text, no video, no images (i tried to upload a picture but its not letting me for some reason). at this point i installed chrome (which works fine) and tried reinstalling Firefox (probably not a good idea in hindsight), which did nothing noticeable to solve the issue. At this point I've done everything suggested here https://support.mozilla.org/en-US/kb/firefox-cant-load-websites-other-browsers-can

Chosen solution

hi, please don't add exceptions when all or major sites are being broken but address the root of the issue instead. in order to fix the issue you'll probably have to look into your eset settings as it's described at How to troubleshoot security error codes on secure websites

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/54.0.2840.87 Safari/537.36

More Information

Application Basics
------------------
Name: Firefox
Version: 49.0.2
Build ID: 20161019084923
Update Channel: release
User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:49.0) Gecko/20100101 Firefox/49.0
OS: Windows_NT 10.0
Multiprocess Windows: 0/1 (Disabled)
Safe Mode: false
Crash Reports for the Last 3 Days
---------------------------------
All Crash Reports
Extensions
----------
Name: Multi-process staged rollout
Version: 1.3
Enabled: true
ID: e10srollout@mozilla.org
Name: Pocket
Version: 1.0.4
Enabled: true
ID: firefox@getpocket.com
Name: Web Compat
Version: 1.0
Enabled: true
ID: webcompat@mozilla.org
Graphics
--------
Features
Compositing: Direct3D 11
Asynchronous Pan/Zoom: none
WebGL Renderer: Google Inc. -- ANGLE (NVIDIA GeForce GTX 780 Ti Direct3D11 vs_5_0 ps_5_0)
Hardware H264 Decoding: Yes; Using D3D11 API
Direct2D: true
DirectWrite: true (10.0.10586.633)
GPU #1
Active: Yes
Description: NVIDIA GeForce GTX 780 Ti
Vendor ID: 0x10de
Device ID: 0x100a
Driver Version: 21.21.13.7290
Driver Date: 9-16-2016
Drivers: nvd3dumx,nvwgf2umx,nvwgf2umx,nvwgf2umx nvd3dum,nvwgf2um,nvwgf2um,nvwgf2um
Subsys ID: 00000000
RAM: 3072
Diagnostics
AzureCanvasAccelerated: 0
AzureCanvasBackend: direct2d 1.1
AzureContentBackend: direct2d 1.1
AzureFallbackCanvasBackend: cairo
Decision Log
D3D9_COMPOSITING:
disabled by default: Disabled by default
Important Modified Preferences
------------------------------
browser.cache.disk.capacity: 358400
browser.cache.disk.filesystem_reported: 1
browser.cache.disk.smart_size.first_run: false
browser.cache.disk.smart_size.use_old_max: false
browser.cache.frecency_experiment: 2
browser.download.importedFromSqlite: true
browser.places.smartBookmarksVersion: 8
browser.startup.homepage_override.buildID: 20161019084923
browser.startup.homepage_override.mstone: 49.0.2
browser.tabs.remote.autostart.2: true
browser.urlbar.daysBeforeHidingSuggestionsPrompt: 3
browser.urlbar.lastSuggestionsPromptDate: 20161111
dom.apps.lastUpdate.buildID: 20161019084923
dom.apps.lastUpdate.mstone: 49.0.2
dom.apps.reset-permissions: true
extensions.lastAppVersion: 49.0.2
gfx.crash-guard.status.d3d11video: 2
media.benchmark.vp9.fps: 206
media.benchmark.vp9.versioncheck: 1
media.gmp-eme-adobe.abi: x86-msvc-x64
media.gmp-eme-adobe.lastUpdate: 1478845947
media.gmp-eme-adobe.version: 17
media.gmp-gmpopenh264.abi: x86-msvc-x64
media.gmp-gmpopenh264.lastUpdate: 1478845948
media.gmp-gmpopenh264.version: 1.6
media.gmp-manager.buildID: 20161019084923
media.gmp-manager.lastCheck: 1478845944
media.gmp.storage.version.observed: 1
media.hardware-video-decoding.failed: false
places.history.expiration.transient_current_max_pages: 104858
privacy.sanitize.timeSpan: 0
ui.osk.debug.keyboardDisplayReason: IKPOS: Touch screen not found.
Important Locked Preferences
----------------------------
Places Database
---------------
JavaScript
----------
Incremental GC: true
Accessibility
-------------
Activated: false
Prevent Accessibility: 0
Library Versions
----------------
NSPR
Expected minimum version: 4.12
Version in use: 4.12
NSS
Expected minimum version: 3.25
Version in use: 3.25
NSSSMIME
Expected minimum version: 3.25
Version in use: 3.25
NSSSSL
Expected minimum version: 3.25
Version in use: 3.25
NSSUTIL
Expected minimum version: 3.25
Version in use: 3.25
Experimental Features
---------------------

FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

First, let's make sure your system is clean.

You may have ad / mal-ware. Further information can be found in the Troubleshoot Firefox issues caused by malware article.

Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

First, let's make sure your system is clean. You may have ad / mal-ware. Further information can be found in the [[Troubleshoot Firefox issues caused by malware]] article. Run most or all of the listed malware scanners. Each works differently. If one program misses something, another may pick it up.

Question owner

Okay, i ran all 5 scanners and they did indeed find ad / mal-ware and have cleaned it up. I have not yet tried launching firefox in case there are additional steps i should do before doing so.

Okay, i ran all 5 scanners and they did indeed find ad / mal-ware and have cleaned it up. I have not yet tried launching firefox in case there are additional steps i should do before doing so.
FredMcD
  • Top 10 Contributor
4245 solutions 59390 answers

The bad programs may have changed some settings, so watch for that. Otherwise, start the browser. Good luck.

The bad programs may have changed some settings, so watch for that. Otherwise, start the browser. Good luck.

Question owner

unfortunately it does not seem to have improved. most https urls still bring up in insecure connection warning, and when i add an exception the site still loads only as raw text. a select few sites seem to load properly (facebook and imgur seemed to load with no issues).

unfortunately it does not seem to have improved. most https urls still bring up in insecure connection warning, and when i add an exception the site still loads only as raw text. a select few sites seem to load properly (facebook and imgur seemed to load with no issues).
philipp
  • Top 25 Contributor
  • Moderator
5306 solutions 23422 answers

Chosen Solution

hi, please don't add exceptions when all or major sites are being broken but address the root of the issue instead. in order to fix the issue you'll probably have to look into your eset settings as it's described at How to troubleshoot security error codes on secure websites

hi, please don't add exceptions when all or major sites are being broken but address the root of the issue instead. in order to fix the issue you'll probably have to look into your eset settings as it's described at [[How to troubleshoot the error code "SEC_ERROR_UNKNOWN_ISSUER" on secure websites]]

Helpful Reply

Disabling and re-enabling the SSL/TSL protocol filtering has fixed the issue. Thank you both!

Disabling and re-enabling the SSL/TSL protocol filtering has fixed the issue. Thank you both!