Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable out of date infobar drop down notice?

  • 5 replies
  • 3 have this problem
  • 306 views
  • آخر ردّ كتبه FredMcD

more options

Starting Firefox makes annoying drop down notice "Your Firefox is out of date. Update now for better performance and security." No S*** Sherlock and the reason is that dev team has ruined the browser bit by bit the last five years so I stopped updating after the tab groups were removed and the ah so familiar "use an add-on" answer was given.

So about:config value to disable this notice is all I need?


Usability first, then security.

Attached screenshots

Chosen solution

My prefs.js was missing these: app.update.enabled - false app.update.silent - false

I tried to add them earlier but Firefox was accidently running while I was modifying the prefs.js so it got overwritten.

I think these did the trick. user_pref("app.update.auto", false); user_pref("app.update.enabled", false);


Thanks for the help. (still disagree with the dev choises tough)

ps: I think I'll just start from clear prefs.js if this problem reappears.

Read this answer in context 👍 0

All Replies (5)

more options

I have never seen that notice, and I stopped updating at v46.

Type about:preferences#advanced<enter> in the address bar.

Under Advanced, Select Update. Check the settings.

more options

about:preferences#advanced Automatically update: x Search Engines (is the only option)

So that didn't work.

By any change could it be openSuSE distro nagging me? I have 'MozillaFirefox-branding-openSUSE' package installed.

Here's some detailed info about:config (prefs.js)

user_pref("app.update.auto", false); user_pref("app.update.certs.2.issuerName", ""); user_pref("app.update.lastUpdateTime.addon-background-update-timer", 1478806001); user_pref("app.update.lastUpdateTime.blocklist-background-update-timer", 1478809850); user_pref("app.update.lastUpdateTime.browser-cleanup-thumbnails", 1478839308); user_pref("app.update.lastUpdateTime.datareporting-healthreport-lastDailyCollection", 1478752847); user_pref("app.update.lastUpdateTime.experiments-update-timer", 1478839188); user_pref("app.update.lastUpdateTime.search-engine-update-timer", 1478839769); user_pref("app.update.lastUpdateTime.xpi-signature-verification", 1478806129);


hmm... tought I added these. Maybe Firefox was running and over wrote my additional settings.

app.update.enabled - false app.update.silent - false

more options

This is what that page should look like

more options

Chosen Solution

My prefs.js was missing these: app.update.enabled - false app.update.silent - false

I tried to add them earlier but Firefox was accidently running while I was modifying the prefs.js so it got overwritten.

I think these did the trick. user_pref("app.update.auto", false); user_pref("app.update.enabled", false);


Thanks for the help. (still disagree with the dev choises tough)

ps: I think I'll just start from clear prefs.js if this problem reappears.

more options

That was very good work. Well done.


These add-ons can be a great help by backing up and restoring Firefox

FEBE (Firefox Environment Backup Extension) {web link} FEBE allows you to quickly and easily backup your Firefox extensions, history, passwords, and more. In fact, it goes beyond just backing up -- It will actually rebuild your saved files individually into installable .xpi files. It will also make backups of files that you choose.

OPIE {web link} Import/Export extension preferences