ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Where can i find the system requirements for older versions of firefox

  • 2 (ردّان اثنان)
  • 1 has this problem
  • 244 views
  • آخر ردّ كتبه James

more options

I need to select the latest usable version for an older PC wihtout changing the whole system installation

الحل المُختار

Hello corec, i think not exist all versions together with the system requirements of each one, except if exist in wikipedia...

in the next link you can see all firefox versions, you can open a release and you can see the system requirements in the specific release :

... See what’s new in Firefox! Release Notes tell you what’s new in Firefox. As always, we welcome your feedback. You can also file a bug in Bugzilla or see the system requirements of this release....

https://www.mozilla.org/en-US/firefox/releases/


thank you

Read this answer in context 👍 2

All Replies (2)

more options

الحل المُختار

Hello corec, i think not exist all versions together with the system requirements of each one, except if exist in wikipedia...

in the next link you can see all firefox versions, you can open a release and you can see the system requirements in the specific release :

... See what’s new in Firefox! Release Notes tell you what’s new in Firefox. As always, we welcome your feedback. You can also file a bug in Bugzilla or see the system requirements of this release....

https://www.mozilla.org/en-US/firefox/releases/


thank you

more options

Firefox on Linux has not really had system requirement changes for a long while until Firefox 46.0 when the minimum GTX requirement for Firefox to run changed from 2.18 (two.eighteen) to 3.4 (three.four)

https://www.mozilla.org/firefox/31.0/system-requirements/ https://www.mozilla.org/firefox/45.0/system-requirements/ https://www.mozilla.org/firefox/46.0/system-requirements/ https://www.mozilla.org/firefox/49.0/system-requirements/

As you can see the requirements for the old vulnerable Firefox 31.0 you have is the same as the Firefox 45.0

Modified by James