Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox does not take any notice of the Num Lock Setting. I can no longer navigate with the number pad with numlock on or off.

  • 6 replies
  • 3 have this problem
  • 564 views
  • آخر ردّ كتبه FredMcD

more options

Win 7 64 bit. Firefox 49.0.1

Num Lock key is ignored. This is very frustrating. I learnt to use a keyboard when that was all there was. In the last few months I'm just gettting to dislike this more and more. I have googled this and saw many suggestions that the caret browsing mode (what ever that is, Something a rabbit may enjoy?) can be toggled with the F7 key. Have tried this and it makes no difference with the Function Lock on or off. Have restarted in FireFox safe mode and the behaviour does not change.

Any clues appreciated before I reluctantly jump ship?

Cheers Norm

Chosen solution

FredMcD - I tried your last suggestion - no change. jscher2000 - Yes it always outputs number - ignoring the Num Lock state.

I installed Chrome and IE. Both have the same Num Lock ignore problem as Firefox.

So I startedlooking at other things that had changed in the time frame of the problem.

Seems the culprit is WebRoots Secure Anywhere.

If I disconnect from the net and disable Secure Anywhere using the right click menu selecting 'Shut down Protection' Firefox now responds to the Num Lock key state.

Thanks to all who responded. I have identified the cause of the problem. Just need to find a fix.

Many Thanks Norm

Read this answer in context 👍 0

All Replies (6)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

Safe Mode does'nt help. I Used your shift key method, selected safe mode as specified. Problem persists. Only happens running firefox . Closing firefox and opening notepad++ the keyboard behaves normally. Thanks Norm

more options

I'm calling for more help.

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

more options

With my keyboard, NumLock ON causes numbers to appear (for example, when composing a reply), while NumLock OFF switches those keys to navigation.

Does yours always output numbers in Firefox, or is Firefox completely unaware of the number pad?

more options

Chosen Solution

FredMcD - I tried your last suggestion - no change. jscher2000 - Yes it always outputs number - ignoring the Num Lock state.

I installed Chrome and IE. Both have the same Num Lock ignore problem as Firefox.

So I startedlooking at other things that had changed in the time frame of the problem.

Seems the culprit is WebRoots Secure Anywhere.

If I disconnect from the net and disable Secure Anywhere using the right click menu selecting 'Shut down Protection' Firefox now responds to the Num Lock key state.

Thanks to all who responded. I have identified the cause of the problem. Just need to find a fix.

Many Thanks Norm

more options

That was very good work. Well done.