X
Tap here to go to the mobile version of the site.

منتدى الدعم

prevent tabs to open on start

Posted

Hello,

How can I prevent Firefox from keeping my tabs open when I restart the browser / my PC?

Thanks a lot.

Hello, How can I prevent Firefox from keeping my tabs open when I restart the browser / my PC? Thanks a lot.

Chosen solution

Those files are created automatically in the event of a crash to allow the user to return to the last session.

I'm calling for more help.

(I stopped updating Firefox at v46 because I would lose some add-ons.)

For now, do this;

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.sessionstore.max_resumed_crashes and set it to 0 Restart.

Read this answer in context 1

Additional System Details

Installed Plug-ins

  • ActiveTouch General Plugin Container Version 105
  • Adobe PDF Plug-In For Firefox and Netscape 15.16.20039
  • Citrix Receiver Plugin (Win32)
  • Citrix URL-Redirection Helper Plugin
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 10.79.2 for Mozilla browsers
  • Microsoft Lync Web App Plug-in
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • Shockwave Flash 22.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.4.194
  • 5.1.50428.0

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:45.0) Gecko/20100101 Firefox/45.0

More Information

FredMcD
  • Top 10 Contributor
4269 solutions 59868 answers

Type about:preferences#general<enter> in the address bar.

There are two settings;

  • When Firefox Starts

When the browser is started, what do you want to display? Many of us choose Show My Home Page.

  • Home Page

When a new page is opened, what do you want to be displayed?

  1. Use Current Page. Use what ever page(s) are open at that time.
  2. Use Bookmark
  3. Restore To Default. about:home shows a Mozilla home page with tools.

You can use any of these that you wish;

about:home (Firefox default home page), about:newtab (shows the sites most visited), about:blank (a blank page),

or you can enter any webpage or about: page you want.

Type '''about:preferences#general'''<enter> in the address bar. There are two settings; * '''When Firefox Starts''' When the browser is started, what do you want to display? Many of us choose '''Show My Home Page.''' * '''Home Page''' When a new page is opened, what do you want to be displayed? # '''Use Current Page'''. Use what ever page(s) are open at that time. # '''Use Bookmark''' # '''Restore To Default.''' about:home shows a Mozilla home page with tools. You can use any of these that you wish; '''about:home''' (Firefox default home page), '''about:newtab''' (shows the sites most visited), '''about:blank''' (a blank page), or you can enter any '''webpage''' or '''about:''' page you want.
Scribe 732 solutions 3484 answers

Hi, please see; Startup, home page, tabs, and download settings, and make sure that 'When Firefox starts' isn't set to 'Show my windows and tabs from last time.'

If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

Hi, please see; [[Startup, home page, tabs, and download settings]], and make sure that 'When Firefox starts' isn't set to 'Show my windows and tabs from last time.' ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!''

Question owner

I'm using about:blank as homepage... but for some reason Firefox always restores my tabs even though I don't want them.

The thing is that I use an Intranet troubleticket tool at work and I have many different cases open in tabs. At the end of the day I just close my browser.

The next morning I start the Firefox it restores all those tabs but each one redirects me to the corporate login page which causes my IP to get temporarily blocked due to too many concurrent requests.

Of course I could take the time to close all the tabs before I close Firefox but I'm thinking there should be a setting to prevent this instead.

I'm using about:blank as homepage... but for some reason Firefox always restores my tabs even though I don't want them. The thing is that I use an Intranet troubleticket tool at work and I have many different cases open in tabs. At the end of the day I just close my browser. The next morning I start the Firefox it restores all those tabs but each one redirects me to the corporate login page which causes my IP to get temporarily blocked due to too many concurrent requests. Of course I could take the time to close all the tabs before I close Firefox but I'm thinking there should be a setting to prevent this instead.

Question owner

Scribe said

Hi, please see; Startup, home page, tabs, and download settings, and make sure that 'When Firefox starts' isn't set to 'Show my windows and tabs from last time.' If your question is resolved by this or another answer, please take a minute to let us know. Thank you!

My startup setting are:

When Firefox starts: Show a blank page Home Page: about:blank

Still my tabs are restored whenever I start Firefox. This happens frequently but not all the time on all my PCs both Linux and Windows but on my work notebook it happens every time.

''Scribe [[#answer-916168|said]]'' <blockquote> Hi, please see; [[Startup, home page, tabs, and download settings]], and make sure that 'When Firefox starts' isn't set to 'Show my windows and tabs from last time.' ''If your question is resolved by this or another answer, please take a minute to let us know. Thank you!'' </blockquote> My startup setting are: When Firefox starts: Show a blank page Home Page: about:blank Still my tabs are restored whenever I start Firefox. This happens frequently but not all the time on all my PCs both Linux and Windows but on my work notebook it happens every time.
FredMcD
  • Top 10 Contributor
4269 solutions 59868 answers

You may have corrupt sessionstore file(s). Delete all sessionstore* files and the sessionstore-backups folder.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Locate the above file. Then rename or delete it. Restart Firefox.

You may have corrupt '''sessionstore''' file(s). Delete all '''sessionstore*''' files and the '''sessionstore-backups''' folder. Type '''about:support''' in the address bar and press enter. Under the page logo on the left side, you will see '''Application Basics.''' Under this find '''Profile Folder.''' To its right press the button '''Show Folder.''' This will open your file browser to the current Firefox profile. Now '''Close Firefox.''' Locate the above file. Then rename or delete it. Restart Firefox.

Question owner

OK I just tried this... the first time I restart Firefox it started with an empty session but the next start it went back to showing the tabs I had open before closing.

Is there a setting to not create these files in the first place, or have Firefox delete them before/while starting?

I'm not a programmer but I'm wondering if there is some possibility to write a script that deletes this file/folder and then starts Firefox if there isn't a built-in option for this.

I'm not sure this is relavant but I'm using Firefox ESR 45.3.0 because the normal Firefox stopped loading the extensions I need.

OK I just tried this... the first time I restart Firefox it started with an empty session but the next start it went back to showing the tabs I had open before closing. Is there a setting to not create these files in the first place, or have Firefox delete them before/while starting? I'm not a programmer but I'm wondering if there is some possibility to write a script that deletes this file/folder and then starts Firefox if there isn't a built-in option for this. I'm not sure this is relavant but I'm using Firefox ESR 45.3.0 because the normal Firefox stopped loading the extensions I need.
FredMcD
  • Top 10 Contributor
4269 solutions 59868 answers

Chosen Solution

Those files are created automatically in the event of a crash to allow the user to return to the last session.

I'm calling for more help.

(I stopped updating Firefox at v46 because I would lose some add-ons.)

For now, do this;

Type about:config<enter> in the address bar. If a warning screen comes up, press the Be Careful button. At the top of the screen is a search bar. Type browser.sessionstore.max_resumed_crashes and set it to 0 Restart.

Those files are created automatically in the event of a crash to allow the user to return to the last session. I'm calling for more help. (I stopped updating Firefox at v46 because I would lose some add-ons.) For now, do this; Type '''about:config'''<enter> in the address bar. If a warning screen comes up, press the '''Be Careful''' button. At the top of the screen is a search bar. Type '''browser.sessionstore.max_resumed_crashes''' and set it to 0 Restart.