Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

can mac osx10.7.5 accomodate firefox version 34? Do we need to uninstall firefox version 22 to activate 34?

  • 4 replies
  • 1 has this problem
  • 12 views
  • آخر ردّ كتبه James

more options

We want to upgrade from version 22 to 34. We have mac osx10.7.5

All Replies (4)

more options

The current Firefox 48.0 Release works on Mac OSX 10.6, 10.7, 10.8 however Firefox 49.0 and later will require OSX 10.9 or newer. https://support.mozilla.org/en-US/kb/firefox-osx

Why do you want 34.0 ? which was released back on December 1, 2014 https://www.mozilla.org/firefox/releases/

https://support.mozilla.org/en-US/kb/how-download-and-install-firefox-mac

more options

We followed "how to steps" to install Firefox version 48. We followed the Language...etc link... It showed that 48 had been downloaded...BUT when checking "About Firefox"...It still showed version 22. What is my next step ?

more options

How do I uninstall Firefox version 22 ?

Thank you !

more options

You were likely still running Firefox 22.0 or started up Firefox 22.0 instead of 48.0

Just follow the instructions in article.