ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Scrollbar not scrolling

  • 6 ردود
  • 25 have this problem
  • 2626 views
  • آخر ردّ كتبه foxnotonfire

more options

Since updating to v. 46 from v. 45, the scrollbar does not scroll. Instead it jumps right to the point where I clicked, as if I had done a shift-click. Doing a shift-click makes it behave like a regular scrollbar. So the two functions are inverted. Also, I do not care for the narrow scrollbar and would prefer to have the old clunky one back. Any fixes for this ? Thanks a lot. OS: LMDE2, Mate

الحل المُختار

The problem is caused by GTK 3, and can be cured by creating or editing a file

~/.config/gtk-3.0/settings.ini

with contents

[Settings] gtk-primary-button-warps-slider = false

This answer was found on

http://askubuntu.com/questions/295988/how-to-fix-gtk3-scrollbar-behavior

Read this answer in context 👍 5

All Replies (6)

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. Is the problem still there?


Do you have any 'scroll' add-ons?

more options

No the Safe mode is not going to prove any thing and Fred has not even used Linux to be aware of Linux specific quirks.

Firefox as of Firefox 46.0 and newer requires GTK 3.4 or newer to run and as a result needs a GTK 3 them to them Firefox.

If you have say a GTK 2 theme in use the some things may not look right or missing like the arrows on the scroll bar.

more options

Thank you, Fred, but safe mode did not change anything, and no, I do not have any "scroll" add-ons.


James: thanks very much for your input. But the current stable release of GTK is v. 3.20.2 and firefox requires 3.4 or up ?

Anyway, MATE is a fork of GNOME 2 (made after the release of GNOME 3) and thus uses GTK+ version 2. It has been one of the default desktop environments shipped with Mint, LMDE, Fedora and others for years. So: well done, Firefox ! We (the MATE-users) are very happy campers (NOT !). It would be great if you would stop breaking things and could just tend to security problems, leaving all else alone. After every update, something stops working and needs fixing or yet another add-on. It's sickening. Rant over.

more options

الحل المُختار

The problem is caused by GTK 3, and can be cured by creating or editing a file

~/.config/gtk-3.0/settings.ini

with contents

[Settings] gtk-primary-button-warps-slider = false

This answer was found on

http://askubuntu.com/questions/295988/how-to-fix-gtk3-scrollbar-behavior

more options

foxnotonfire said

James: thanks very much for your input. But the current stable release of GTK is v. 3.20.2 and firefox requires 3.4 or up ? Anyway, MATE is a fork of GNOME 2 (made after the release of GNOME 3) and thus uses GTK+ version 2. It has been one of the default desktop environments shipped with Mint, LMDE, Fedora and others for years. So: well done, Firefox ! We (the MATE-users) are very happy campers (NOT !). It would be great if you would stop breaking things and could just tend to security problems, leaving all else alone. After every update, something stops working and needs fixing or yet another add-on. It's sickening. Rant over.

The GTK 3.20 is more for the most current distros with latest packages or for those who do such updates themselves.

Many LTS distros as you know is still using say GTK 2.24 and if they get a GTK 3 update it may just be 3.4.

Firefox on Linux is basically a Gnome application and Firefox using GTK 3 was not a matter of IF but when and that when was Firefox 46.0. It was going to be for as early as 44.0 if I recall and initially in first Beta builds of Firefox 45.0.

The Linux distro I use has GTK 3.16 and while it is a very capable custom built computer I still choose to use XFCE since Gnome has been at 3 for some time now and dislike the way Gnome 3 and KDE looks.

Those who prefer GTK2 and GTK2 Themes on LTS distros could consider using Firefox 45 ESR. The last update for this ESR branch will be 45.8.x ESR unless Mozilla extends it which would be a first for ESR branch builds as they normally go up to 8. It only gets allowed security and stability fixes. https://www.mozilla.org/firefox/organizations/all/

By the time Firefox 45 ESR is EOL the LTS distros could be using GTK 3.4 or greater as norm.

As for breaking things, I did not as I do not work for Mozilla ;)

more options

James said

As for breaking things, I did not as I do not work for Mozilla ;)

Oh my, I see how that came across. Sorry :) I was obviously addressing Firefox  :)  :)  :)


ennoborg said

The problem ... can be cured by creating or editing a file ~/.config/gtk-3.0/settings.ini with contents [Settings] gtk-primary-button-warps-slider = false

This fixed the problem ! Thanks very much !!