Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Re-install of Firefox 31 incompatible with Adblock plus?

  • 6 replies
  • 6 have this problem
  • 520 views
  • آخر ردّ كتبه elliotlake

more options

I was happily running firefox 31 with adblock plus & element hider but the dashboard with the latest update of Square refused to work and wanted me to run firefox 38. So I downloaded that and installed it, and while it worked marginally better with the Square dashboard, it did not work well at all with lots of other things.. images wouldn't display, Twitter didn't work, tabs froze, etc. So I downloaded FF 31 again (the update seems to have deleted it) and installed that. The images show again, other things work fine.. BUT! It won't let me use Adblock Plus! The addons pages show it as compatible with FF 31, but when I try to install it, it gets halfway through and says it is incompatible.

Do I have a corrupted profile? Do I need to clean up the deletion of FF 38 and reinstall 31? I'm on dialup and all of these things will be really slow.. and I don't want to update to any newer versions until I can go back cleanly to where I was.

I hope someone can explain how to fix this; I'm scared to browse without the security of adblocking.

Thanks in advance Elliot

Chosen solution

elliotlake said

--And Adblock Plus worked just fine with FF 31 up until the reinstall after FF38; so it's incorrect to say that it doesn't work with 31.

You may have had a old version of the extension like Version 2.6.12 or older as versions since then has the extensions listed as Works with Firefox 38.0 and later. https://addons.mozilla.org/firefox/addon/adblock-plus/versions/?page=3

Read this answer in context 👍 2

All Replies (6)

more options

By using such an old version of Firefox you are exposing yourself to all the known security holes listed at https://www.mozilla.org/en-US/security/known-vulnerabilities/firefox/ (All the holes after Firefox 32). You should update to Firefox 45, and then install all updates for your add-ons. Update Firefox to the latest release

If you still have troubles, come back and we can help resolve them!

more options

It is due to fact that the current Adblock Plus versions is supporting the much more current versions of Firefox (Fx 38.0 (likely the 38.0 ESR) and newer) and not Firefox 31.0 which came out back on July 22, 2014. https://www.mozilla.org/firefox/releases/

The last time the Adblock Plus extension author still supported the old Firefox 31.0 was Nov 2015 (see page 3). https://addons.mozilla.org/firefox/addon/adblock-plus/versions/

Modified by James

more options

Thanks, no, I want to fix this before updating any further as there seem to be other problems cause by updating. Don't want to muddy the diagnostic waters.

--And Adblock Plus worked just fine with FF 31 up until the reinstall after FF38; so it's incorrect to say that it doesn't work with 31.

I'm wondering if there's a corrupted profile at work here?

more options

Chosen Solution

elliotlake said

--And Adblock Plus worked just fine with FF 31 up until the reinstall after FF38; so it's incorrect to say that it doesn't work with 31.

You may have had a old version of the extension like Version 2.6.12 or older as versions since then has the extensions listed as Works with Firefox 38.0 and later. https://addons.mozilla.org/firefox/addon/adblock-plus/versions/?page=3

more options

While you think that updating will introduce more issues, the opposite is actually true. Websites and add-ons frequently stop supporting old versions of Firefox, so when you keep running the same version, this will gradually result in a degraded internet experience. Not only is staying out of date bad for the web (devs need to continue to support ancient browsers that can't handle modern technology), it's bad for you (you are stuck using older, slower technology that is full of known security holes. Since security sounds important to you this alone is enough to update).

Like I said, update to Firefox 45.0.1. Then, update all your add-ons. Then, let us know if you are having any issues and we can help you track them down.

Looking through your add-ons list, I notice you are trying to run ublock origin and ad-block plus. I would pick one. They both do the same thing,but running both will not only degrade your performance it will cause problems with websites down the line.

Again, it is NOT smart to continue using such an old version, so please, update before continuing further. We will help resolve any issues that come of it.

more options

James said

elliotlake said
--And Adblock Plus worked just fine with FF 31 up until the reinstall after FF38; so it's incorrect to say that it doesn't work with 31.

You may have had a old version of the extension like Version 2.6.12 or older as versions since then has the extensions listed as Works with Firefox 38.0 and later. https://addons.mozilla.org/firefox/addon/adblock-plus/versions/?page=3

Thank you for this. It answered the questions I was asking (not the question someone else thought I should have been asking). --It answers: Is my profile corrupted? --NO Is Adblock not compatible with FF 31? --No, it IS compatible (see versions) --:Do I have to do another reinstall of FF to fix THIS problem? --NO. --Is it possible to have Adblock Plus with FF 31? --YES.

Mozilla peeps: maybe it's asking too much, but the addons page *could* differentiate between "newest version won't work with [your version of FF] even though this page says it will" and "version that will work with [your version of FF] is".

In any event, now I am free to choose between Ublock Origin and Adblock Plus, and know I haven't broken something in the updating.

Thank you again.