Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why does Firefox trigger a regular download pulse?

  • 17 replies
  • 1 has this problem
  • 411 views
  • آخر ردّ كتبه PeterSoul

more options

I installed Networx on my W8.1 PC, in order to try to establish why my internet download/upload total useage had increased recently. Result: an excellent, continuous view of my download & upload traffic - and one puzzle:-

Why does Firefox 44.0.2 trigger a regular download pulse of 60KB/s lasting several seconds**, exactly once a minute? Over time, this adds up! It's unrelated to any webpage that I am looking at (or that is open in another tab). It stops when I close Firefox, and then resumes either when I open up again, or else spontaeously later. Having Firefox in its safe mode doesn’t prevent it.

Does anyone have a suggestion? Thank you.

    • to be exact, it’s a symmetrical tapered pulse: 6 sec at the bottom, 3 sec at the top

Chosen solution

maybe there is an issue applying the automatic update on your machine - can you check if manually triggering an update by going to the firefox menu ≡ > help ? > about firefox works?

Read this answer in context 👍 0

All Replies (17)

more options

It seems like someone has noted something similar (link to the question).

more options

That's ten times bigger download than my pulses would amount to (if they were continuous and I left my internet connection on all the time). I wonder how they can tell which site theirs is coming from?

more options

This summarises what Firefox does automatically

and explains how to turn them off.

more options

John99, thank you -- a useful list, and I have now turned off some of the items in it. But nothing in the list seemed to relate to the once-a-minute downloads that I am seeing (and nothing that I turned off has stopped them).

Though I have just noticed that simply pulling out and reconnecting my ethernet connection to the router puts a stop to them. Until they restart sometime...

I'm still wondering if there's a way to identify the website that the download pulses are coming from?

more options

One simple test would be to set some other browser to be the default browser, and open that. Close & reopen Firefox. Now with any luck if it is something external just using the default browser that will switch from Firefox to the now default browser.

It could be a variety of things trying to connect from malware, to innocent software updates. Especially if this type of traffic is seen on other browsers then you should try somewhere else for advice.

Windows will have tools available to help you, but probably the best known tool is the cross platform Wireshark

Wireshark information is widely available including several place on their own website for instance

I have never tried Networx, but if it is this a quick look at its site seems to suggest it will show ports the PC listens on and applications active with local and remote addresses

Firefox has range of built in tools

but they are possibly not as user friendly as Networx

more options

Well, I've performed your simple test: - made IE default browser, closed & reopened FF: download pulses stopped, then soon resumed every minute, but at 0.9 KB/s peak instead of 60 KB/s as before. - closed FF: no change. - closed IE: no change. - reopened FF: no change. - reopened & made FF default browser again: pulses stopped, then soon resumed at 60 KB/s.

What should I make of this? (Don't tell me to use IE instead of FF!)

more options

Did you try with Firefox having only a single tab open a blank page use about:blank If you have loads of tabs|windows open that you do not want to close consider using a new additional profile for test purposes:

We certainly would not encourage anyone to use IE unnecessarily instead of Firefox.

Using your prefered tool try to identify what Firefox is connecting to. Maybe it is malware so try running all the tools mentioned in

more options

No, didn't think of that (though I already had a test profile set up from previously!).

But anyway: for the last few hours (after I disconnected and reinserted the ethernet plug) and with my system back to how it was, the once-a-minute pulses have been consistently around 1 KB/s (instead of 60 as they were since I started looking at them). Which is next to nothing, of course.

So I shall put this problem on hold for now. But thanks for the input.

more options

you could press ctrl + shift + j in order to open the browser console - in the network section there you could see all connections/addresses opened by the browser, maybe this contains some clues...

more options

Thank you! (1) the download pulses have reverted to 60 KB/s peak, (2) from the browser console, I can see that they are coming from http://download.cdn.mozilla.net/pub/firefox/releases/45.0.1/update/win32/en-GB/firefox-45.0.1.complete.mar

I can see from "How to stop FF from making automatic connections" how to stop checking for updates - but of course this is "not recommended".

So can I safely block this particular URL? (I believe I shall need an add-on to do it.)

more options

Chosen Solution

maybe there is an issue applying the automatic update on your machine - can you check if manually triggering an update by going to the firefox menu ≡ > help ? > about firefox works?

more options

Well, it paused at "0 of 45.2 Mb" for a minute, then it appeared to work: "Restart FF to Update", which I shall now do...

And then?

more options

please try to restart and see if you are now using 45.0.1 by going into the same "about firefox" panel again.

more options

It is indeed now 45.0.1. Does that indicate my "problem" is fixed, or there is an issue with auto updating as you suggested?

more options

Side-issue: At the end of my "simple test" earlier, as I said, I restarted FF, clicking in the box that first said: do you want to make FF the default browser.

But I now see, under Options/General, "Firefox is not your default browser". Yet I haven't been shown the starting-up box again, as above, in the several times I've restarted FF since!

And if I now click on Make Default, up comes a Set Associations box, in which three of the lines are ticked and are FF, the others being unticked and IE. So I have ticked all the boxes, and FF now seems to be the default again...

more options

With any luck the problem is now fixed. Sometimes there is a temporary issue with the updates and it can be fixed by following the advice in this old article

In your case just selecting the about Firefox option worked

As for the default browser issue Firefox will also have an option to Always check at each startup that Firefox is still the default

Oh and if you fall for the current hard sell upgrade free of charge to Windows 10 you will need to look at

more options

OK, fingers crossed, and thanks again (to both).