ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why is Firefox making an annoying sound every time I open a new link?

  • 11 ردًا
  • 1 has this problem
  • 4211 views
  • آخر ردّ كتبه jscher2000

more options

When I'm browsing and open a new page, I hear an annoying sound like someone is firing a Star Wars blaster. How do I get rid of it? It's driving me crazy.

الحل المُختار

Did you try the Safe Mode test to see whether the sounds goes away? That would definitely point the finger at one of your extensions.

In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option key when starting Firefox. (Windows: hold down the Shift key)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Peace and quiet?

Read this answer in context 👍 1

All Replies (11)

more options

Hello Ckeledjian,

Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help others with the same problem.

thank you
more options

Probably from the NoScript extension signaling it has a blocked a script on page loading.

NoScript Options > Notifications -> Audio feedback when scripts are blocked

more options

And where do I find "NoScript Options"?

more options

Via the NoScript toolbar button, at the bottom of the drop-down menu when you click on that button, then select Options.

Or in the Add-ons Manager > Extensions -> NoScript --> Options

more options

Would your instructions be different for a Mac user? I'm not seeing a NoScript toolbar.

And in my Add-ons Manager > Extensions there's no "NoScript" listed, only two Autofill functions.

more options

If NoScript doesn't appear in the Add-ons Manager it isn't installed. Something else must be the cause.

Maybe that's a sound added by MacOSX and not from Firefox? Sorry, I have never used a Mac computer.

more options

The sound only happens when I'm browsing in Firefox, not in Chrome or Safari.

more options

الحل المُختار

Did you try the Safe Mode test to see whether the sounds goes away? That would definitely point the finger at one of your extensions.

In Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is not running: Hold down the option key when starting Firefox. (Windows: hold down the Shift key)

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" button > Restart with Add-ons Disabled
  • Help menu > Restart with Add-ons Disabled

and OK the restart.

Both scenarios: A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Peace and quiet?

more options

In this thread, a sound was caused by QuickTime for some unknown reason: Stop airplane sound when new tab is open on Mac.

more options

Yes, jscher2000, restarting in Safe Mode seems to have worked. Thanks!

more options

Ckeledjian said

Yes, jscher2000, restarting in Safe Mode seems to have worked.

Okay, so most likely one of your extensions is making the sound. You could check whether they can be configured not to do that. Open the Add-ons page using either:

  • Command+Shift+a
  • "3-bar" menu button (or Tools menu) > Add-ons

In the left column, click Extensions. Then on the right, see whether there is an Options button for each extension allowing you to modify their behavior.

If that doesn't help when you exit out of Firefox and start up normally again, you could disable those extensions (if you don't need them) or tell us what they are to see whether we can find a solution.

To copy/paste your list of extensions:

Open the support information page using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter/Return

Scroll down to the Extensions heading. Then select using the mouse from extensions through the end of the table listing the extensions and copy (Command+c).

Then click in a reply and paste (Command+v). It will look a little messy but don't worry, we're used to it.