ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I turn of the incredibly ANNOYING Smart bar?

  • 10 ردود
  • 1 has this problem
  • 151 views
  • آخر ردّ كتبه Tankerton

more options

I cannot believe Mozilla did not give the option to turn off the so called `Smart Bar`. I have no need to check my history through the address bar and the only thing it does is get in the way, making it incredibly easy to click on links I no longer need to go back to. Amazing how something introduced into Firefox to uncomplicate checking your history has made browsing the web more complicated.

الحل المُختار

afaik, this is not part of firefox. can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Read this answer in context 👍 0

All Replies (10)

more options

hi, i'm not sure by the terminology if you are referring to the dropdown suggestions from history when you type into the address bar - these however can easily be tweaked and turned off: Settings for privacy, browsing history and do-not-track

more options

Phillip, that is not what I`m referencing to. It has nothing to do with privacy settings or location bar suggestions as I have all of those options unchecked. Every time I hit the arrows to go forward or backward a page, a window drops down not from the address bar but as a separate window underneath it. This is called the `Smart Bar`. See enclosed partial screen shot

more options

الحل المُختار

afaik, this is not part of firefox. can you try to replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Have to get back to this post in a minute. I`m not sure if it`s the Smart or Awesome bar

Modified by Tankerton

more options

Does this bar still show if you start Firefox in Safe Mode?


Do a clean reinstall and delete the Firefox program folder before (re)installing a fresh copy of the current Firefox release.

If possible uninstall your current Firefox version to cleanup the Windows registry and settings in security software.

  • Do NOT remove "personal data" when you uninstall your current Firefox version, because this will remove all profile folders and you lose personal data like bookmarks and passwords including data in profiles created by other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • (32 bit Windows) "C:\Program Files\Mozilla Firefox\"
  • (64 bit Windows) "C:\Program Files (x86)\Mozilla Firefox\"

Your personal data like bookmarks is stored in the Firefox profile folder, so you won't lose personal data when you uninstall and (re)install or update Firefox, but make sure NOT to remove personal data when you uninstall Firefox as that will remove all Firefox profile folders and you lose your personal data.


Do a malware check with several malware scanning programs on the Windows computer.

Please scan with all programs because each program detects different malware. All these programs have free versions.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

I`m currently using a Macbook Pro. The only add ons I have are Ghostery, ADP, NO Script. I never entered into safe mode. Running Firefox 44.02 and Yosemite 10.10.5

more options

did you right-click (or whatever the mac equivalent is) the back/forward arrows?

more options

I left click on the navigation buttons. I still get that box that shows the websites I recently visited just as it shows in the previous screen shot. The only thing that I updated was Firefox last night. I never had this problem before that

more options

Do you have any extensions installed about clearing recent history?

We have seen reports that such an extension cause this issue with the drop-down list.

Start Firefox in Safe Mode to check if one of the extensions (3-bar Menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: 3-bar Menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
more options

I checked my extensions and I started to turn them off one by one, restarting Firefox everytime I did to check them and it seems that I had one called `Secure Sanitizer` that was causing that strange behavior. I had disabled it, restarted Firefox and it the problem was gone. I had enabled it again to be sure that was causing the problem and guess what? The problem came back. `Secure Sanitizer` is now disabled and removed and the problem is no more. Thank you all for the help and suggestion :) -Tankerton P.S. can a mod change the title to the post to something indicative to Problems with address bar history with the add on `Secure Sanitizer`? -Thanks :)

Modified by Tankerton