ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox behaves different than has been set in Privacy settings

  • 18 ردًا
  • 1 has this problem
  • 49 views
  • آخر ردّ كتبه cheniek

more options

After last update to FF 44.0 I realized that application still remembers forms history even though there has been set in privacy setting to do not do so. Please find herewith attachment my settings of FF. Although after FF restart when I click in an e-mail service login window there show up my correct e-mail login as a suggestion. I did not experience this behavior previously. FF was behaving correct (exactly how was set in preferences. Awaiting Your help, Cheniek

All Replies (18)

more options

It is possible that the website stores this data in a cookie if you have saved form data disabled and also haven't stored this data in the Password Manager.

Use these steps to remove saved (form) data from a drop-down list:

  1. click the (empty) input field on the web page to open the drop-down list
  2. highlight an entry in the drop-down list with the mouse or cursor Down key
    do not click the mouse or press the Enter key
  3. press the Delete key (on Mac: Shift+Delete) to delete the highlighted entry

(my previous post in this thread was meant for another question, sorry for any confusion)

more options

You can use this extension to erase previously stored form history entries for multiple pages at a time: https://addons.mozilla.org/firefox/addon/form-history-control/

more options

Thank You both: cor-el and jscher2000. It helps but I'm interest where it comes from. I did not experience earlier this kind of a bug. cor-el, there is no way that the website stores this in cookies because cookies cleaning on FF closing is also enabled. To make things clear, all data should be erased on FF closing (these are my privacy settings). That is the point. That why I'm surprised how FF behaves. I've been keeping the same settings for a long time (1,5 year). I've never experienced similar behavior. It seems to be a kind of a bug isn't it?

more options

Hi cheniek, what is your form history setting?

If "Remember search and form history" is enabled (checked in Privacy options), Firefox should display autocomplete suggestions from your form history in a drop-down below the form field, usually showing matches when you type a character.

If "Remember search and form history" is unchecked, you should not get any suggestions from Firefox, even if some history was saved before.

It's possible that the clearing of history at shutdown is failing. Some users have reported issues with Firefox 44 not shutting down completely and generating a shutdown crash report. Have you seen anything like that?

more options

jscher2000, thank You for Your time and help trying. I described everything above. There is clearly wrote "To make things clear, all data should be erased on FF closing (these are my privacy settings)", so there is also checked "clear history on FF closing and checked all the options to clear on closing. I've not experienced crash on shut down and any crash report. Everything seems to be ok, FF closes correctly without any problems. Nothing suspicious in behavior except remembering forms settings while it shouldn't happen. Any idea?

more options

Hi cheniek, I was asking about the checkbox I marked in the attached screen shot. If "Remember search and form history" is unchecked, you should not get any suggestions from Firefox, and Firefox should not store any new form history.

Modified by jscher2000

more options

Hi jscher2000, this checkbox is marked. But it should be cleaned on FF close, isn't it? So when the option "Remember search and form history" is marked I understand it remembers history as long as FF session is on, when session is off (when FF is closed) history should be cleaned and when I start new FF session there should not be forms suggestions anymore. Please correct me if I'm wrong. Regards

more options

Hi cheniek, yes, if you turned on "Clear history when Firefox closes" and when you click the Settings button to the right you have a checkbox for "Form & Search History", then that history should be cleared at shutdown and when you visit the form for the first time in the new session, no suggestions should be available.

I don't know whether this could be a factor or is still an issue: In past threads, users have noted an odd interaction between private browsing and clearing history: history from non-private sessions may not be cleared when shutting down from a private session.

more options

As I wrote in previous posts, an option "Clear history at FF shutdown" is marked and all the checkboxes under this option are marked (which means that clearing forms history is marked as well). It is definitely a bug of FF 44.0. I do not use private sessions. Before an update to 44 there was no problem with this although all the options were set exactly the same way like are set now. It is not a critical bug of course, anyway it is quite annoying when you have an impression that you have no control under the settings- you set something but the result is different than expected. Is there anything I can try to fix this issue? It is the first time I have a problem like this with FF and I've been using this browser since 2005!

more options

Is there anybody who may help? If further details are needed just tell me. I face this problem everyday... Should I post this issue somewhere else?

more options

Can you summarize your current situation and what behavior you want regarding saved form data.

Do you want to save form data during a session, so you can make use of it during a session and clear it when you close Firefox or don't you want to use this feature at all since you write about Private Browsing mode?

If Firefox closes properly and the session has been in normal mode then form data should be kept during a normal session, but nit in a PB mode session. If you have set to clear saved form data when you close Firefox then this data should be cleared if the session was a normal mode session and not a PB mode session.

What form data is stored in formhistory.sqlite can only be checked with the SQLite Manager extension because there it is not possible to do this via the user interface like you can with passwords.

more options

cor-el, thanks for Your interest of my case. It has been described in previous posts, I do not use private browsing, yes I want to use form history during a current session, yes I want a form history to be cleared after FF close. Anyway the problem seems to be solved just by current FF update to 44.0.1. I noticed it yesterday already but wanted to make sure if it is solved permanently. Today I can confirm this that problem is solved. FF behaves as supposed to be. Thank You.

more options

Hi again! It is amazing... after another upgrade to FF 44.02 the issue reported above is back! Additionally since an upgrade to FF 44 series I noticed the problem with playing the videos on services like Youtube/Vimeo. Although the autoplay option is marked, the videos don't play automatically. I have to click on pause and again on play button in video window to play the video. It is so weird. I do not remember any similar problems with FF since year 2005 when I started using this browser! Any idea how to fix it?

more options

These are illogical symptoms to arise at the same time... In case the updater/installer caused broken or conflicting program files, I suggest trying:

Clean Reinstall

We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed.

(A) Download a fresh installer for Firefox 44.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(B) Exit out of Firefox (if applicable).

(C) I haven't tried it myself:

If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins
more options

Did you make sure that media.autoplay.enabled is true on the about:config page?

more options

I was reading about a different bug and read that Firefox is designed to clean history at shutdown but, if it doesn't finish completely for one reason or another -- such as Windows "killing" Firefox prematurely during shutdown -- Firefox is designed to resume cleaning up at startup. However, this could fail under certain conditions. The symptom several users have reported is that their custom home page does not display, just a blank page. In Firefox 45, the startup cleaning should be less prone to crashing. Not sure this is relevant to your scenario, but I thought I would mention it just in case.

more options

cor-el, You're right, my fault... I completely forgot that I changed it some time ago in about.config. forms history issue still exists unfortunately.

more options

jscher2000 said

These are illogical symptoms to arise at the same time... In case the updater/installer caused broken or conflicting program files, I suggest trying: Clean Reinstall We use this name, but it's not about removing your settings, it's about making sure the program files are clean (no inconsistent or alien code files). As described below, this process does not disturb your existing settings. Do NOT uninstall Firefox, that's not needed. (A) Download a fresh installer for Firefox 44.0.2 from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.) (B) Exit out of Firefox (if applicable). (C) I haven't tried it myself:
If you installed Firefox with the distro-based package manager, you should use the same way to uninstall it - see Install Firefox on Linux. If you downloaded and installed the binary package from the Firefox download page, simply remove the folder firefox in your home directory.

(D) Run the installer you downloaded in step (A). It should automatically connect to your existing settings.

Any improvement?

Note: Some plugins may exist only in that OldFirefox folder. If something essential is missing, look in these folders:

  • \OldFirefox\Plugins
  • \OldFirefox\browser\plugins

I need some more of free time to check if it would work. I'll let you know when I've done it. Thanks for an advice.