ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox jumps to Yahoo on any subsequent search; how do I ditch Yahoo?

  • 3 ردود
  • 1 has this problem
  • 12 views
  • آخر ردّ كتبه cor-el

more options

I'm on a Mac desktop. For years, Firefox is my search engine, but suddenly, if I'm searching for a 2nd or 3rd topic on the internet, it's no longer on Firefox - it's on Yahoo. Yahoo seems abysmal and doesn't provide a quality search. I just Googled and tried to follow some instructions, to remove add ons and turn Firefox on in "safe" mode. That didn't help - I still was pushed into Yahoo once I'd done my initial search on Firefox. I don't want to waste my time. Help! Thx.

I'm on a Mac desktop. For years, Firefox is my search engine, but suddenly, if I'm searching for a 2nd or 3rd topic on the internet, it's no longer on Firefox - it's on Yahoo. Yahoo seems abysmal and doesn't provide a quality search. I just Googled and tried to follow some instructions, to remove add ons and turn Firefox on in "safe" mode. That didn't help - I still was pushed into Yahoo once I'd done my initial search on Firefox. I don't want to waste my time. Help! Thx.

All Replies (3)

more options

Firefox is a browser, it uses search engines.

Type about:addons<enter> in the address bar to open your Add-ons Manager. Hot key; <Control>(Mac=<Command>)<Shift> A)

In the Add-ons Manager, on the left, select Extensions. Remove Yahoo Anything. Now do the same in the computers Programs Folder.

Windows: Start > Control Panel > Uninstall Programs. Mac: Open the "Applications" folder. Linux: Check your user manual.


After the problem is fixed, Bookmark and use this; Download the Mozilla Search Reset {web link} This add-on is very simple: on installation, it backs up and then resets your search preferences and home page to their default values, and then uninstalls itself. This affects the search bar, URL bar searches, and the home page.

more options

Thx - I've tried that. Once I got to Extensions - there was apparently nothing there to remove. It's an insidious problem...

more options

Do you have any Spigot software installed?

You can check for problems with preferences.

Delete possible user.js and numbered prefs-##.js files and rename (or delete) the prefs.js file to reset all prefs to the default value including prefs set via user.js and prefs that are no longer supported in current Firefox releases.


Create a new profile as a test to check if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.