X
Tap here to go to the mobile version of the site.
Scheduled maintenance: Monday, March 30, between 3:30pm and 5:30pm UTC. This site will have limited functionality while we undergo maintenance to improve your experience. If an article doesn’t solve your issue and you want to ask a question, we have our support community waiting to help you at @firefox on Twitter

منتدى الدعم

links won't work - unless I FIRST "open in new tab", then they do

Posted

For this web site: http://ulsterhabitat.org/ in the post Ulster Habitat News (facebook) (third image, first small one), the link to the facebook page will only open if: I right click on it and choose "open in new tab" (It does not matter if I give focus to the new tab or not), then I left click on the link and it works. If I left click on the link first, nothing happens. (link says "Ulster Habitat Facebook").

What I have done: run in safe mode, refreshed Firefox, reinstalled Firefox 43.0.3 (with all profile data removed - as clean as could be) with no extensions, altered settings or add-ons. Behavior is always the same.

System is Windows 7 Pro, latest up-to-date version, but Firefox also does this on a W7 Home system, and a W10 Home system, both with latest Firefox. No Firefox extensions or add-ons on the W10 machine.

Bonus: Chrome 47.0.2526.106 does not do this (it opens the link immediately). IE 11.0.26 does just what Firefox does. It would seem to me that the link should either work or not work, but not depend on opening in a new tab first. Fascinated by this. Thank you. Tim

For this web site: http://ulsterhabitat.org/ in the post Ulster Habitat News (facebook) (third image, first small one), the link to the facebook page will only open if: I right click on it and choose "open in new tab" (It does not matter if I give focus to the new tab or not), then I left click on the link and it works. If I left click on the link first, nothing happens. (link says "Ulster Habitat Facebook"). What I have done: run in safe mode, refreshed Firefox, reinstalled Firefox 43.0.3 (with all profile data removed - as clean as could be) with no extensions, altered settings or add-ons. Behavior is always the same. System is Windows 7 Pro, latest up-to-date version, but Firefox also does this on a W7 Home system, and a W10 Home system, both with latest Firefox. No Firefox extensions or add-ons on the W10 machine. Bonus: Chrome 47.0.2526.106 does not do this (it opens the link immediately). IE 11.0.26 does just what Firefox does. It would seem to me that the link should either work or not work, but not depend on opening in a new tab first. Fascinated by this. Thank you. Tim

Chosen solution

Works fine for me.

There is JavaScript code attached to the link as you can see if you open the Inspector via the right-click context menu (Inspect Element) by the presence of an 'ev' button.

You can check the Web Console (Firefox menu button or Tools > Web Developer) for JavaScript and Security error messages. CSS errors shouldn't matter in this case, so best is to hide them if there are many.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 10.1.16
  • Creative Cloud Desktop Plugin.v_3_0_0_0
  • DivX Web Player version 3.3.1.10
  • DivX VOD Helper Plug-in
  • GEPlugin
  • Google Update
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • The plugin allows you to have a better experience with Microsoft SharePoint
  • CANON iMAGE GATEWAY Mycamera Plugin
  • Nitro PDF plugin for Firefox and Chrome
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 18.0 r0
  • 5.1.41105.0
  • Skype Web Plugin 7.6.0.291
  • NPWLPG

Application

  • Firefox 43.0.3
  • User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0
  • Support URL: https://support.mozilla.org/1/firefox/43.0.3/WINNT/en-US/

Extensions

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 4000
  • adapterDescription2:
  • adapterDeviceID: 0x0166
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igdumdim32 igd10iumd32 igd10iumd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 21fa17aa
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 6.2.9200.17568
  • driverDate: 11-15-2013
  • driverDate2:
  • driverVersion: 9.18.10.3359
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: Yes
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 4000 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: No
FredMcD
  • Top 10 Contributor
4386 solutions 61564 answers

I access both pages without issue. Your protection programs may be the issue.

Start your Computer in safe mode with networking. Then start Firefox. Try Safe web sites. Is the problem still there?

Starting The Computer In Safe Mode;
Free Online Encyclopedia

I access both pages without issue. Your protection programs may be the issue. Start your '''Computer''' in safe mode with networking. Then start Firefox. Try '''Safe''' web sites. Is the problem still there? '''[http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting The Computer In Safe Mode;<br>Free Online Encyclopedia]'''

صاحب السؤال

Restarted in Safe mode with networking. Behavior is the same.

As you can, I can reach both pages - if I first open in new tab. It is NOT a bad link. If I copy it and then paste and go, it works.

Update: If I click on the link twice (not a double click), it opens the second time. True on both a W7 and W10 machine. I am not changing settings in between the clicks.

Restarted in Safe mode with networking. Behavior is the same. As you can, I can reach both pages - if I first open in new tab. It is NOT a bad link. If I copy it and then paste and go, it works. Update: If I click on the link twice (not a double click), it opens the second time. True on both a W7 and W10 machine. I am not changing settings in between the clicks.
FredMcD
  • Top 10 Contributor
4386 solutions 61564 answers

Q: Are you just clicking the link to change the current window, or middle click?

Q: Are you just clicking the link to change the current window, or middle click?

صاحب السؤال

I am not changing the current window. (Plus more testing below)

Originally: right click/open link in new tab, but I never click on the new tab. next left click on original link and it works

Second pass: I just click left on the link once, wait, then left click again - it works

More input: Android 6.0+Firefox 43 works the same way (needs two clicks) Linux Mint 17 + Firefox 37 (sorry, old) works the same way.

It certainly looks like whatever it is is persistent and either a design choice or an old bug. Chrome does not behave this way on any of these systems (but I did not check Mint).

As noted Internet Explorer 11 and Microsoft Edge 20 do what Firefox does.

It's like something is getting flipped. However, the link works fine on second and all subsequent clicks. But if I open two identical tabs, the link in each one has to be clicked twice to work.

I am not changing the current window. (Plus more testing below) Originally: right click/open link in new tab, but I never click on the new tab. next left click on original link and it works Second pass: I just click left on the link once, wait, then left click again - it works More input: Android 6.0+Firefox 43 works the same way (needs two clicks) Linux Mint 17 + Firefox 37 (sorry, old) works the same way. It certainly looks like whatever it is is persistent and either a design choice or an old bug. Chrome does not behave this way on any of these systems (but I did not check Mint). As noted Internet Explorer 11 and Microsoft Edge 20 do what Firefox does. It's like something is getting flipped. However, the link works fine on second and all subsequent clicks. But if I open two identical tabs, the link in each one has to be clicked twice to work.

صاحب السؤال

More input. On a whim, I opened Firefox, opened the page, saved the source. Then, clicked on the link (twice), used the back arrow to return to the original page and saved the source again. Did a file compare: files are identical, but they behaved differently. First one needed 2 clicks for the link to work. Second one worked with one click (because it was really the 3rd click). Tim

More input. On a whim, I opened Firefox, opened the page, saved the source. Then, clicked on the link (twice), used the back arrow to return to the original page and saved the source again. Did a file compare: files are identical, but they behaved differently. First one needed 2 clicks for the link to work. Second one worked with one click (because it was really the 3rd click). Tim
FredMcD
  • Top 10 Contributor
4386 solutions 61564 answers

Were they the same web address?

Were they the same web address?

صاحب السؤال

Yup. Can you hit a back button and go to a different address? (Anyway, I double checked - same address)

Yup. Can you hit a back button and go to a different address? (Anyway, I double checked - same address)
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance
  • Do NOT click the Reset button on the Safe Mode start window
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox menu button/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem. *Switch to the DEFAULT theme: Firefox menu button/Tools > Add-ons > Appearance *Do NOT click the Reset button on the Safe Mode start window *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

صاحب السؤال

As I stated in my first post, I am running an absolutely clean, default, no add-ons or extensions install. I also removed all personal data in %appdata% as part of the reinstallation to be as clean as possible.

However, I did start in safe mode. No change to the behavior.

As I stated in my first post, I am running an absolutely clean, default, no add-ons or extensions install. I also removed all personal data in %appdata% as part of the reinstallation to be as clean as possible. However, I did start in safe mode. No change to the behavior.
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

What security software do you have?

Can you try a different mouse?

What security software do you have? Can you try a different mouse?

صاحب السؤال

Also cleared ALL history, started in safe mode. Same behavior.

Also cleared ALL history, started in safe mode. Same behavior.

صاحب السؤال

Well, since (per posts) I have exhibited this behavior on 3 different Windows machines (2 W7, 1 W10), an Android tablet and a Linux netbook, I have used multiple mice, and a variety of security systems. In fact, in Windows Safe mode with Networking, I used a trackpad and the mouse was disconnected. The W7 machines are MS Security Essentials, W10, Android and Linux is whatever is default.

Have you been able to reproduce this?

Well, since (per posts) I have exhibited this behavior on 3 different Windows machines (2 W7, 1 W10), an Android tablet and a Linux netbook, I have used multiple mice, and a variety of security systems. In fact, in Windows Safe mode with Networking, I used a trackpad and the mouse was disconnected. The W7 machines are MS Security Essentials, W10, Android and Linux is whatever is default. Have you been able to reproduce this?
cor-el
  • Top 10 Contributor
  • Moderator
17846 solutions 161524 answers

Chosen Solution

Works fine for me.

There is JavaScript code attached to the link as you can see if you open the Inspector via the right-click context menu (Inspect Element) by the presence of an 'ev' button.

You can check the Web Console (Firefox menu button or Tools > Web Developer) for JavaScript and Security error messages. CSS errors shouldn't matter in this case, so best is to hide them if there are many.

Works fine for me. There is JavaScript code attached to the link as you can see if you open the Inspector via the right-click context menu (Inspect Element) by the presence of an 'ev' button. *https://developer.mozilla.org/Tools/Page_Inspector You can check the Web Console (Firefox menu button or Tools > Web Developer) for JavaScript and Security error messages. CSS errors shouldn't matter in this case, so best is to hide them if there are many.

صاحب السؤال

Fabulous. Your note got me to a solution, although I think there is still a problem.

My notes: The JavaScript was from a WordPress plugin called WP Slimstat (which collects traffic stats). I used inspect element (per your advice), and noticed that there was a field "data-slimstat-clicked=false", which turned to "true" after the first click, and then the link worked. I turned off Slimstat and the original problem link works first time.

But (if anyone cares), the exact same JS existed on the title link in the first post, and it has always worked fine (on first click). So somehow the code is being interpreted inconsistently. And whatever it is is common (probably) to the JS implementation in Firefox (cross platform, since I saw this in W7, W10, Android and Linux), IE and Edge, but Chrome does it differently.

So, thanks for the pointer. Tim (Now I need to find a new stats plugin)

Fabulous. Your note got me to a solution, although I think there is still a problem. My notes: The JavaScript was from a WordPress plugin called WP Slimstat (which collects traffic stats). I used inspect element (per your advice), and noticed that there was a field "data-slimstat-clicked=false", which turned to "true" after the first click, and then the link worked. I turned off Slimstat and the original problem link works first time. But (if anyone cares), the exact same JS existed on the title link in the first post, and it has always worked fine (on first click). So somehow the code is being interpreted inconsistently. And whatever it is is common (probably) to the JS implementation in Firefox (cross platform, since I saw this in W7, W10, Android and Linux), IE and Edge, but Chrome does it differently. So, thanks for the pointer. Tim (Now I need to find a new stats plugin)