Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Unblock popups from local file (file:///d:/*). Couldn't add local url to exceptions, and couldn't add "<files>" either.

  • 7 replies
  • 3 have this problem
  • 18 views
  • آخر ردّ كتبه frugal

more options

Hi there, Got a local file on my hard drive, with some JS that is trying to open a link in a new tab. By default, this is blocked by FireFox as a forbidden popup window. Trying to add as an exception from the yellow "popup blocked" bar does not help. In previous versions of FireFox, I entered the options|Content|Exceptions and added "<files>" to the exceptions list. In my current version (43.0.3), when I do that, it is replaced by "http://<files>" and doesn't work either. Help will be much appreciated! Thanks, jo.

All Replies (7)

more options

Try using 5 slashes like this. See if that works.

file://///D:/file name

more options

Thanks, but no, it didn't help. Actually I've already tried it, as I saw this tip in another forum. Firefox continues blocking them.

more options

Have you tried disabling the popup blocker temporarily when you open that local file and then see if the popup does open as expected?

more options

I tried it now, and yes, the popup opens as expected.

more options

Then add whatever worked to the Exceptions list as "Allow".

more options

Does Firefox show a pop-up block icon at the right end of the location/address bar?

more options

This is not just a file problem it is happening since firefox update 44.0

In my case it is my banking website, when I try to open my visa payment in separate tab firefox blocks the popup, I give exception to "allow fully" and it still blocks it. I suspect the browser is not checking the exceptions list or it is not completely adding the exception allow. It shows up in the list of exceptions but it does not act on that list. when activily opening the popup

This is a browser issue that started with the 44.0 update and after. There was no problem prior to this update.

This is not the only issue 44.0 has caused in everyday usage.

I am viewing this as a bug/s that needs fixing.