X
Tap here to go to the mobile version of the site.

منتدى الدعم

firefox email link does not show in mail client as hyperlink

Posted

When I select File/Email Link in Firefox (vers. 43.0.2), mail client (Thunderbird 38.5.0) opens a Write message window with the link shown as plain text. I've tried other mail clients (Windows Live Mail 2012 and Windows 10 mail) and get the same result. I can highlight the link in Thunderbird and use Insert/Link to created a clickable hyperlink, but this defeats the convenience off Email Link in Firefox. This problem only started when I ungraded from Windows 7 to Windows 10. The Email Link worked as expected in Windows 7. I have no problem receiving clickable links in messages received by Thunderbird. Any suggestions?

When I select File/Email Link in Firefox (vers. 43.0.2), mail client (Thunderbird 38.5.0) opens a Write message window with the link shown as plain text. I've tried other mail clients (Windows Live Mail 2012 and Windows 10 mail) and get the same result. I can highlight the link in Thunderbird and use Insert/Link to created a clickable hyperlink, but this defeats the convenience off Email Link in Firefox. This problem only started when I ungraded from Windows 7 to Windows 10. The Email Link worked as expected in Windows 7. I have no problem receiving clickable links in messages received by Thunderbird. Any suggestions?

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 15.9.20069
  • Citrix Online App Detector Plugin
  • Foxit PhantomPDF Plug-In For Firefox and Netscape
  • Foxit Reader Plug-In For Firefox and Netscape
  • Plugin for Glance screen sharing service
  • Google Update
  • Intel web components for Intel® Identity Protection Technology
  • Intel web components updater - Installs and updates the Intel web components
  • Next Generation Java Plug-in 11.66.2 for Mozilla browsers
  • NPWLPG
  • Picasa plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 20.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.2.1.171
  • 5.1.41105.0
  • iTunes Detector Plug-in

Application

  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

FredMcD
  • Top 10 Contributor
4334 solutions 60978 answers

Helpful Reply

When you create the e-mail, do not use the send as Plain Text setting. You must use the send as HTML setting.

After you place a link in the mail, go to the end of the link, and press <Enter>

When you create the e-mail, do not use the ''send as '''Plain Text''''' setting. You must use the ''send as '''HTML''''' setting. After you place a link in the mail, go to the end of the link, and press <Enter>

Question owner

That works if I set the Global Addressing setting in Thunderbird to send as Plain Text and HTML. I'm not placing the link in the mail since Firefox does that with Email Link, so there's no need to press <Enter>. I'm still puzzled about what changed since I upgraded to Windows 10 from Win7. Of course I also updated both Firefox and Thunderbird when I did the update, so there are too many variables. But thanks for getting me pointed in the right direction!

That works if I set the Global Addressing setting in Thunderbird to send as Plain Text and HTML. I'm not placing the link in the mail since Firefox does that with Email Link, so there's no need to press <Enter>. I'm still puzzled about what changed since I upgraded to Windows 10 from Win7. Of course I also updated both Firefox and Thunderbird when I did the update, so there are too many variables. But thanks for getting me pointed in the right direction!
FredMcD
  • Top 10 Contributor
4334 solutions 60978 answers

rgw1024 said

. . . . I upgraded to Windows 10 from Win7. Of course I also updated both Firefox and Thunderbird . . . .

To the average user: Upgrade = what can we mess up this time  :-)

''rgw1024 [[#answer-823692|said]]'' <blockquote> . . . . I upgraded to Windows 10 from Win7. Of course I also updated both Firefox and Thunderbird . . . . </blockquote> To the average user: Upgrade = what can we mess up this time :-)
Roann 0 solutions 7 answers

Helpful Reply

When you create the e-mail, do not use the send as Plain Text setting. You must use the send as HTML setting.

After you place a link in the mail, go to the end of the link, and press <Enter> I have this problem too. It does work if position my cursor at the end of link & press enter like it says here BUT I didn't have to do this in the past. Is there some change I need to make to settings in Firefox to make mailed links automatically herperlinks?

Helpful Reply When you create the e-mail, do not use the send as Plain Text setting. You must use the send as HTML setting. After you place a link in the mail, go to the end of the link, and press <Enter> I have this problem too. It does work if position my cursor at the end of link & press enter like it says here BUT I didn't have to do this in the past. Is there some change I need to make to settings in Firefox to make mailed links automatically herperlinks?