X
Tap here to go to the mobile version of the site.

منتدى الدعم

Help - Can't unblock mixed content 43.0.1

Posted

So I am on a unsecure computer just playing games, and don't care about security there is NO info on this computer

I am on yahoo games, and several games try to load and quit half way, yet a few actually work. On the ones that don't work, I see a little grey lock beside the flash plug in with orange exclamation point. When I hover over it, I can "this website does not supply identity information". When I click on grey lock I get "Connection not Secure in red". Of course I don't care, so just want to route this so the game works. I see this article and others like it:

https://support.mozilla.org/en-US/kb/mixed-content-blocking-firefox

So I follow what it says, only when I click on the arrow on the right, the "disable protection for now" button is NOT there. WTF

I tried going to options, don't see anything there to render this. Tried changing some of the permissions, then reloading the page, shutting down Firefox etc. Nothing works, AND it says "you have not granted this site any special permissions", even though I have. HELP please

So I am on a unsecure computer just playing games, and don't care about security there is NO info on this computer I am on yahoo games, and several games try to load and quit half way, yet a few actually work. On the ones that don't work, I see a little grey lock beside the flash plug in with orange exclamation point. When I hover over it, I can "this website does not supply identity information". When I click on grey lock I get "Connection not Secure in red". Of course I don't care, so just want to route this so the game works. I see this article and others like it: https://support.mozilla.org/en-US/kb/mixed-content-blocking-firefox So I follow what it says, only when I click on the arrow on the right, the "disable protection for now" button is NOT there. WTF I tried going to options, don't see anything there to render this. Tried changing some of the permissions, then reloading the page, shutting down Firefox etc. Nothing works, AND it says "you have not granted this site any special permissions", even though I have. HELP please

Additional System Details

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape 11.0.8
  • Google Update
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • DRM Netscape Network Object
  • DRM Store Netscape Plugin
  • Panda ActiveScan 2.0 Plugin for Firefox
  • Shockwave Flash 19.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • Npdsplay dll
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:43.0) Gecko/20100101 Firefox/43.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5346 solutions 23604 answers

ردّ مُفيد

hi, the padlock with the orange warning sign means that there is passive mixed content (like pictures or video) present on the site, which is NOT blocked - so there is nothing to unblock either. so the issue with those yahoo games is possibly to be found elsewhere. you could try to clear the cache & cookies from yahoo.com and reload the page. also update your plugins.

hi, the padlock with the orange warning sign means that there is passive mixed content (like pictures or video) present on the site, which is NOT blocked - so there is nothing to unblock either. so the issue with those yahoo games is possibly to be found elsewhere. you could try to [[Clear the cache - Delete temporary Internet files to fix common website issues|clear the cache]] & [[Delete cookies to remove the information websites have stored on your computer|cookies from yahoo.com]] and reload the page. also [https://www.mozilla.org/en-US/plugincheck/ update your plugins].

ردّ مُفيد

Thanks Phillip, but it sure doesn't seem that way

Every game that works, has a green lock, every one that does not, has the grey one, this is not a coincidence, tried clearing cache, updating plugins etc

I mean it says the connection is not secure as well, and as usual this is a sticking Flash issue (worst program ever invented for computers) so it appears to be blocking the flash video from running, yet it says "Flash is enabled on".

Thanks Phillip, but it sure doesn't seem that way Every game that works, has a green lock, every one that does not, has the grey one, this is not a coincidence, tried clearing cache, updating plugins etc I mean it says the connection is not secure as well, and as usual this is a sticking Flash issue (worst program ever invented for computers) so it appears to be blocking the flash video from running, yet it says "Flash is enabled on".
philipp
  • Top 25 Contributor
  • Moderator
5346 solutions 23604 answers

can you give us a sample url where this is happening?

can you give us a sample url where this is happening?

صاحب السؤال

Note too, I even went to play one of the same non-working games at the manufacturers website, and it did NOT work there either, so it is NOT a Yahoo issue either

Note too, I even went to play one of the same non-working games at the manufacturers website, and it did NOT work there either, so it is NOT a Yahoo issue either

صاحب السؤال

https://ca.games.yahoo.com/game/kingsroad.html

starts to load, and then lock shows up and it quits

Here too: https://www.rumblegames.com/kingsroad/play

https://ca.games.yahoo.com/game/kingsroad.html starts to load, and then lock shows up and it quits Here too: https://www.rumblegames.com/kingsroad/play
philipp
  • Top 25 Contributor
  • Moderator
5346 solutions 23604 answers

as suspected the grey padlock will be there for informational purposes only, and all elements of the page are loaded - the following information is showing up in the network console: Loading mixed (insecure) display content "http://telemetry.rumblegames.com/crossdomain.xml" on a secure page Loading mixed (insecure) display content "http://telemetry.rumblegames.com/telemetry/rapiEvent/noteEvent" on a secure page even if i choose to block insecure display content in firefox, the game would still load...

i'd still ask you to go through the steps mentioned above since your system information shows that you are using flash 19 for example, but in the meantime flash 20 has already been released.

also see if you can replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here... Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

as suspected the grey padlock will be there for informational purposes only, and all elements of the page are loaded - the following information is showing up in the network console: <sub>Loading mixed (insecure) display content "http://telemetry.rumblegames.com/crossdomain.xml" on a secure page Loading mixed (insecure) display content "http://telemetry.rumblegames.com/telemetry/rapiEvent/noteEvent" on a secure page</sub> even if i choose to block insecure display content in firefox, the game would still load... i'd still ask you to go through the steps mentioned above since your system information shows that you are using flash 19 for example, but in the meantime flash 20 has already been released. also see if you can replicate this behaviour when you launch firefox in safe mode once? if not, maybe an addon is interfering here... [[Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems]]

صاحب السؤال

Okay, I went through each step again (had to remove Flash 19, I dont get why it doesn't install over top of itself...) and no dice.

So I removed 19, installed 20 Cleared Yahoo cookies Cleared Cache Tried it in safe mode with plug ins disabled

NADA

One thing to note, I was not accurate in my original description of what happens here with the Kings Road game specifically, the lock actually shows up right away (it starts green and quickly turns grey). Then the game starts to load, as soon as the "loading icon" hits the half way mark, the picture disappears but the music keeps playing to the end of the chime. Then it just sits there with a black screen and does nothing

Here is another example w/ the grey lock

https://ca.games.yahoo.com/game/general-war.html

Once I pick a server, this one hits 70% loading, and then just the bottom bar keeps flashing left to right, but top stays stuck at 70%, sits like that forever (so display does not go blank)

Another grey lock:

https://ca.games.yahoo.com/game/mythborne.html

Pick a server, then just sits there saying "connecting to server"

Another grey lock, https://ca.games.yahoo.com/game/fragoria.html This one tried to connect to server and then says, "registration server error".

Another grey lock: https://ca.games.yahoo.com/game/storm-throne.html

Initial screen loads, then I get a connecting to server screen, where it never connects, even when refreshing.

Another https://ca.games.yahoo.com/game/the-last-stand-dead-zone.html stuck on loading

Another https://ca.games.yahoo.com/game/blade-hunter.html sticks at 3%

This one below runs with the "unity player" and starts off green lock, once the initial screen loads, it changes to yellow and a new screen tried to load, only to never actually do it, funny all these coincidences don't you think?

https://ca.games.yahoo.com/game/battle-islands.html

I've tried these MANY times, with the same results, and remember I went to manufacturer's website too

Here are a couple that work, green locks:

https://ca.games.yahoo.com/game/imperia-online.html

https://ca.games.yahoo.com/game/rise-of-champions.html

Somehow it seems the grey lock is stopping me from connecting to servers maybe, is this a privacy setting issue maybe, or?

Edit - Okay it took me a long time, but I finally found one that works with a Grey lock, albeit very slowly and choppy https://ca.games.yahoo.com/game/the-keeper-of-4-elements-flash.html


So I don't know what to make of this, I can only find 3 that work so far

Okay, I went through each step again (had to remove Flash 19, I dont get why it doesn't install over top of itself...) and no dice. So I removed 19, installed 20 Cleared Yahoo cookies Cleared Cache Tried it in safe mode with plug ins disabled NADA One thing to note, I was not accurate in my original description of what happens here with the Kings Road game specifically, the lock actually shows up right away (it starts green and quickly turns grey). Then the game starts to load, as soon as the "loading icon" hits the half way mark, the picture disappears but the music keeps playing to the end of the chime. Then it just sits there with a black screen and does nothing Here is another example w/ the grey lock https://ca.games.yahoo.com/game/general-war.html Once I pick a server, this one hits 70% loading, and then just the bottom bar keeps flashing left to right, but top stays stuck at 70%, sits like that forever (so display does not go blank) Another grey lock: https://ca.games.yahoo.com/game/mythborne.html Pick a server, then just sits there saying "connecting to server" Another grey lock, https://ca.games.yahoo.com/game/fragoria.html This one tried to connect to server and then says, "registration server error". Another grey lock: https://ca.games.yahoo.com/game/storm-throne.html Initial screen loads, then I get a connecting to server screen, where it never connects, even when refreshing. Another https://ca.games.yahoo.com/game/the-last-stand-dead-zone.html stuck on loading Another https://ca.games.yahoo.com/game/blade-hunter.html sticks at 3% This one below runs with the "unity player" and starts off green lock, once the initial screen loads, it changes to yellow and a new screen tried to load, only to never actually do it, funny all these coincidences don't you think? https://ca.games.yahoo.com/game/battle-islands.html I've tried these MANY times, with the same results, and remember I went to manufacturer's website too Here are a couple that work, green locks: https://ca.games.yahoo.com/game/imperia-online.html https://ca.games.yahoo.com/game/rise-of-champions.html Somehow it seems the grey lock is stopping me from connecting to servers maybe, is this a privacy setting issue maybe, or? Edit - Okay it took me a long time, but I finally found one that works with a Grey lock, albeit very slowly and choppy https://ca.games.yahoo.com/game/the-keeper-of-4-elements-flash.html ---- So I don't know what to make of this, I can only find 3 that work so far

صاحب السؤال

Here is another one that doesn't work:

http://www.r2games.com/play/?game=106

This one had grey lock on yahoo, but at this link it shows a "world" icon

At both places, both bars quickly load to 100%, then birds fly across the screen and it stays stuck there, not going into the game itself. It gives two options right on that screen to try to resolve loading issues, both of which don't work

Hope you are someone can figure this out for me

Here is another one that doesn't work: http://www.r2games.com/play/?game=106 This one had grey lock on yahoo, but at this link it shows a "world" icon At both places, both bars quickly load to 100%, then birds fly across the screen and it stays stuck there, not going into the game itself. It gives two options right on that screen to try to resolve loading issues, both of which don't work Hope you are someone can figure this out for me
philipp
  • Top 25 Contributor
  • Moderator
5346 solutions 23604 answers

please test the behaviour in safemode...

please test the behaviour in safemode...

صاحب السؤال

Hi Philip. Please see my long post:

So I removed 19, installed 20 Cleared Yahoo cookies Cleared Cache Tried it in safe mode with plug ins disabled

Hi Philip. Please see my long post: So I removed 19, installed 20 Cleared Yahoo cookies Cleared Cache Tried it in safe mode with plug ins disabled
cor-el
  • Top 10 Contributor
  • Moderator
17775 solutions 160795 answers

You can check the log in the Web Console for error messages about mixed content and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked.

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.


There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate or otherwise interferes with internet connections.

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps.

You can check the log in the Web Console for error messages about mixed content and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked. *https://developer.mozilla.org/Tools/Web_Console *https://developer.mozilla.org/Tools/Network_Monitor Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log. ----- There is security software like Avast and Kaspersky and BitDefender and ESET that intercept secure connections and send their own certificate or otherwise interferes with internet connections. Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) to see if that helps. *http://www.bleepingcomputer.com/tutorials/how-to-start-windows-in-safe-mode/ *http://www.7tutorials.com/4-ways-boot-safe-mode-windows-10

صاحب السؤال

Corel my good friend! I am sure you don't remember me but you have helped me out of a jam 3 or maybe 4 times at least, including making my everyday experience more pleasant by helping me solve a difficult profile customization issue

Okay here is what I find in Web Developer:

Use of getPreventDefault() is deprecated. Use defaultPrevented instead. jquery.js:3:6598 uncaught exception: [object Object] <unknown> Given URL is not allowed by the Application configuration: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains.

Does this help? I will try booting computer into safe mode as well

p.s When my AV (avast) updated last, it was causing my computer to shut off randomly, so I currently have shields disabled. I agree it does seem like that kind of issue, an interference of sorts

Corel my good friend! I am sure you don't remember me but you have helped me out of a jam 3 or maybe 4 times at least, including making my everyday experience more pleasant by helping me solve a difficult profile customization issue Okay here is what I find in Web Developer: Use of getPreventDefault() is deprecated. Use defaultPrevented instead. jquery.js:3:6598 uncaught exception: [object Object] <unknown> Given URL is not allowed by the Application configuration: One or more of the given URLs is not allowed by the App's settings. It must match the Website URL or Canvas URL, or the domain must be a subdomain of one of the App's domains. Does this help? I will try booting computer into safe mode as well p.s When my AV (avast) updated last, it was causing my computer to shut off randomly, so I currently have shields disabled. I agree it does seem like that kind of issue, an interference of sorts

صاحب السؤال

Here is the log to another one that does NOT work:

Error: Permission denied to access property "toString"

swfobject.js:4:2711

Error: Permission denied to access property "toString" <unknown> Loading mixed (insecure) display content "http://telemetry.rumblegames.com/crossdomain.xml" on a secure page[Learn More] kingsroad.html Loading mixed (insecure) display content "http://telemetry.rumblegames.com/telemetry/rapiEvent/noteEvent" on a secure page[Learn More]


In the network log, there are a lot of green locks, but a few grey, and they are always this one:

http://telemetry.rumblegames.com/telemetry/rapiEvent/noteEvent


Another one that does not work:

Loading mixed (insecure) display content "http://r2cdn2.r2games.com/en/www/images/bg.jpg" on a secure page[Learn More] mythborne.html This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] www.r2games.com This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] log2.r2games.com This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] mythborne-web.r2games.com Error: Permission denied to access property "toString"

swfobject.js:201:9

Error: Permission denied to access property "toString" <unknown> Use of getPreventDefault() is deprecated. Use defaultPrevented instead.

===========

On a game that is working, I get this:

Error: Permission denied to access property "toString"

swfobject.js:4:2634

Error: Permission denied to access property "toString"

No grey locks in Network info

Here is another working one:

This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] www28.imperiaonline.org Empty string passed to getElementById(). gamecore-2fdb234d0da7b89b04a5114f72e2c1a9973d7f6d.js:3:4010 Use of getPreventDefault() is deprecated. Use defaultPrevented instead. gamecore-2fdb234d0da7b89b04a5114f72e2c1a9973d7f6d.js:4:598 Use of getAttributeNode() is deprecated. Use getAttribute() instead.

No grey locks in Network info


This leads me to believe it is a stinking Flash issue maybe? (Given msg above, "Given URL is not allowed by the Application configuration: One or more of the given URLs is not allowed by the App's settings. ")

Here is the log to another one that does NOT work: Error: Permission denied to access property "toString" swfobject.js:4:2711 Error: Permission denied to access property "toString" <unknown> Loading mixed (insecure) display content "http://telemetry.rumblegames.com/crossdomain.xml" on a secure page[Learn More] kingsroad.html Loading mixed (insecure) display content "http://telemetry.rumblegames.com/telemetry/rapiEvent/noteEvent" on a secure page[Learn More] ---- In the network log, there are a lot of green locks, but a few grey, and they are always this one: http://telemetry.rumblegames.com/telemetry/rapiEvent/noteEvent ----- Another one that does not work: Loading mixed (insecure) display content "http://r2cdn2.r2games.com/en/www/images/bg.jpg" on a secure page[Learn More] mythborne.html This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] www.r2games.com This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] log2.r2games.com This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] mythborne-web.r2games.com Error: Permission denied to access property "toString" swfobject.js:201:9 Error: Permission denied to access property "toString" <unknown> Use of getPreventDefault() is deprecated. Use defaultPrevented instead. ======================= On a game that is working, I get this: Error: Permission denied to access property "toString" swfobject.js:4:2634 Error: Permission denied to access property "toString" No grey locks in Network info Here is another working one: This site makes use of a SHA-1 Certificate; it's recommended you use certificates with signature algorithms that use hash functions stronger than SHA-1.[Learn More] www28.imperiaonline.org Empty string passed to getElementById(). gamecore-2fdb234d0da7b89b04a5114f72e2c1a9973d7f6d.js:3:4010 Use of getPreventDefault() is deprecated. Use defaultPrevented instead. gamecore-2fdb234d0da7b89b04a5114f72e2c1a9973d7f6d.js:4:598 Use of getAttributeNode() is deprecated. Use getAttribute() instead. No grey locks in Network info ---- This leads me to believe it is a stinking Flash issue maybe? (Given msg above, "Given URL is not allowed by the Application configuration: One or more of the given URLs is not allowed by the App's settings. ")

صاحب السؤال

Season's Greetings

So to add to the above, I finally closed all my open windows and rebooted Windows into Safe mode, here is what I found

- Basically no change, all things were pretty much the same, with maybe a couple small changes:

- I "think" one of the games that did not work before, now did, all other ones still did not

- In two cases, I got the "Connection untrusted" Window, and the only choice was "Get me out of here", there was no "I know what I am doing continue anyway" option. This did not happen the same way in non-safe mode.

Hoping that helps somehow? Still would like to resolve this

Thanks again

Season's Greetings So to add to the above, I finally closed all my open windows and rebooted Windows into Safe mode, here is what I found - Basically no change, all things were pretty much the same, with maybe a couple small changes: - I "think" one of the games that did not work before, now did, all other ones still did not - In two cases, I got the "Connection untrusted" Window, and the only choice was "Get me out of here", there was no "I know what I am doing continue anyway" option. This did not happen the same way in non-safe mode. Hoping that helps somehow? Still would like to resolve this Thanks again

صاحب السؤال

Hi Cor-el. Do I have you stumped on the Yahoo game issue?

I hope you have some idea on what is going on, I'm wondering if some of the game are running on Java, or other platforms, and maybe that is why some work, and some don't, maybe it is the platform unless all Yahoo games are running Flash, I don't think so.

==

Also one new issue if you would, ever since updating FF to 43.0.4 (I swear I should just never update FF), now embedded Videos don't load full size on webpages, instead of a "full square", they look more like a rectangle, their height reduced. Also possibly related not sure, You tube the whole website will NOT load properly at all. I tested it on chrome and it loads perfectly, not on FF, see attached pic. Ideas?

Hi Cor-el. Do I have you stumped on the Yahoo game issue? I hope you have some idea on what is going on, I'm wondering if some of the game are running on Java, or other platforms, and maybe that is why some work, and some don't, maybe it is the platform unless all Yahoo games are running Flash, I don't think so. ====== Also one new issue if you would, ever since updating FF to 43.0.4 (I swear I should just never update FF), now embedded Videos don't load full size on webpages, instead of a "full square", they look more like a rectangle, their height reduced. Also possibly related not sure, You tube the whole website will NOT load properly at all. I tested it on chrome and it loads perfectly, not on FF, see attached pic. Ideas?
cor-el
  • Top 10 Contributor
  • Moderator
17775 solutions 160795 answers

That last screenshot shows that CSS files are blocked somehow. That can be caused by an extension or by other (security) software on your computer.

You can check the log in the Web Console for error messages and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked.

Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.

That last screenshot shows that CSS files are blocked somehow. That can be caused by an extension or by other (security) software on your computer. You can check the log in the Web Console for error messages and the Network Monitor (Firefox/Tools > Web Developer) to see if content fails to load or is possibly blocked. *https://developer.mozilla.org/Tools/Web_Console *https://developer.mozilla.org/Tools/Network_Monitor Use Ctrl+F5 or Ctrl+Shift+R to reload the page and bypass the cache to generate a fresh log.