Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I keep deleting history, but the URL bar still gives suggestions to websites I've visited.

  • 2 replies
  • 1 has this problem
  • آخر ردّ كتبه cor-el

more options

I've deleted everything from my browsing history. That includes cookies, cache, etc. Despite me deleting all of this, I still get suggestions when I type in the URL search bar. I don't think this should be happening since I deleted everything. They're not bookmarked, so there is no reason for them to still be popping up. How can I fix this?

All Replies (2)

more options

Hi midnightmaverick, what kind of suggestions are they? For example:

  • URLs on the "autocomplete" drop-down list
  • Top-level site addresses (host names) in the address bar (autofill in the address bar, separate from the drop-down list)

According to a bug filed in 2013 (932036), Firefox may fail to remove visited host names from the places.sqlite database -- the file which stores history and bookmarks -- when the database has become corrupted.

If you have allowed plenty of time for the history to be cleared, your database might be corrupted and it would be logical to test that theory by removing it. (You can keep a copy elsewhere or rename it if you think you might later want to reverse the test.)

Open your current Firefox settings (AKA Firefox profile) folder using either

  • "3-bar" menu button > "?" button > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, click the "Show Folder" button. This should launch a new window listing various files and folders in Windows Explorer.

Leaving that window open, switch back to Firefox and Exit, either:

  • "3-bar" menu button > "power" button
  • (menu bar) File > Exit

Pause while Firefox finishes its cleanup, then rename places.sqlite to something like BADplaces.sqlite (or move it to a different folder). If you see any companion files like places.sqlite-shm or places.sqlite-wal, delete them.

Start Firefox back up again. Firefox should create a new places.sqlite database and restore your last bookmark backup to it. Does autofill behave more normally?

more options

You can remove all data stored in Firefox from a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History > Show All History" or "View > Sidebar > History") or via the about:permissions page.

Using "Forget About This Site" will remove all data stored in Firefox from that domain like bookmarks, cookies, passwords, cache, history, and exceptions, so be cautious. If you have a password or other data from that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of the involved files.

If you revisit a 'forgotten' website then data from that website will be saved once again.