X
Tap here to go to the mobile version of the site.

منتدى الدعم

Content Type "PDF file" Keeps Getting Added; Impossible to Preview in Firefox

Posted

Awhile ago, Firefox stopped previewing or opening .pdf files correctly. Instead, it would always ask if I wanted to open or save the file. Selecting to open would just have the same result, and so on. This was regardless of if the file was local or on the internet.

So I went to Options>Applications and searched "pdf" and two results came up under Content Type. The first was "PDF file" which can only either "Always ask," "Save File," or open in a different program. The other was "Portable Document Format" which was set to "Preview in Firefox." I concluded the first Content Type was the problem, but I had no idea how to fix it. Eventually I tried refreshing Firefox, and this got rid of the problem temporarily.

It seems that this error keeps occurring after some time, and constantly having to refresh and change my settings is frustrating. This is a problem because I want to use Firefox to view pdf files without using 3rd party software. Your help is appreciated!

Awhile ago, Firefox stopped previewing or opening .pdf files correctly. Instead, it would always ask if I wanted to open or save the file. Selecting to open would just have the same result, and so on. This was regardless of if the file was local or on the internet. So I went to Options>Applications and searched "pdf" and two results came up under Content Type. The first was "PDF file" which can only either "Always ask," "Save File," or open in a different program. The other was "Portable Document Format" which was set to "Preview in Firefox." I concluded the first Content Type was the problem, but I had no idea how to fix it. Eventually I tried refreshing Firefox, and this got rid of the problem temporarily. It seems that this error keeps occurring after some time, and constantly having to refresh and change my settings is frustrating. This is a problem because I want to use Firefox to view pdf files without using 3rd party software. Your help is appreciated!

Chosen solution

I found a solution after searching very thoroughly. Before I had tried things like editing or deleting mimeTypes.rdf from the profile folder, but it did not work. Finally read somewhere that Firefox must be closed in order for this to work.

If anyone ever has the same problem, try following the same steps so that you do not have to refresh:

1. Locate the Profiles folder. I found this by clicking the three bars in the tool bar, then the ? button at the bottom, then Troubleshooting Information, then Show Folder next to Profile Folder. Alternatively, you can reach Troubleshooting Information by hitting alt, selecting Help, then Troubleshooting Information; you can also type "about:support" in the address bar.

2. Close Firefox. Wouldn't work for me unless this was done.

3. Delete mimeTypes.rdf from the Profile Folder. You could also rename it something else in case you wanted this as a backup. Firefox will automatically make a new mimeTypes.rdf the next time you start it.

4. Start Firefox, go to "about:preferences#applications" by typing this in the address, and search for "pdf." The second content type was not there for me after doing this. Hopefully this works for others too.

Read this answer in context 0

Additional System Details

Installed Plug-ins

  • Hola VLC media player Web Plugin
  • Intel web components updater - Installs and updates the Intel web components
  • Intel web components for Intel® Identity Protection Technology
  • Media Go Detector Plug-in
  • Shockwave Flash 19.0 r0
  • Shockwave Flash 18.0 r0
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.4.144
  • WildTangent Games App V2 Presence Detector

Application

  • Firefox 41.0.2
  • User Agent: Mozilla/5.0 (Windows NT 10.0; WOW64; rv:41.0) Gecko/20100101 Firefox/41.0
  • Support URL: https://support.mozilla.org/1/firefox/41.0.2/WINNT/en-US/

Extensions

  • HP SimplePass 1.0 (firefox@bho.com) (Inactive)

Javascript

  • incrementalGCEnabled: True

Graphics

  • adapterDescription: Intel(R) HD Graphics 5300
  • adapterDescription2:
  • adapterDeviceID: 0x161e
  • adapterDeviceID2:
  • adapterDrivers: igdumdim64 igd10iumd64 igd10iumd64 igd12umd64 igdumdim32 igd10iumd32 igd10iumd32 igd12umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterSubsysID: 22e0103c
  • adapterSubsysID2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: True
  • directWriteEnabled: True
  • directWriteVersion: 10.0.10240.16430
  • driverDate: 8-31-2015
  • driverDate2:
  • driverVersion: 10.18.15.4281
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'direct2d 1.1', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'direct2d 1.1', u'AzureSkiaAccelerated': 0}
  • isGPU2Active: False
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • supportsHardwareH264: True
  • webglRenderer: Google Inc. -- ANGLE (Intel(R) HD Graphics 5300 Direct3D11 vs_5_0 ps_5_0)
  • windowLayerManagerRemote: True
  • windowLayerManagerType: Direct3D 11

Modified Preferences

Misc

  • User JS: No
  • Accessibility: Yes

Chosen Solution

I found a solution after searching very thoroughly. Before I had tried things like editing or deleting mimeTypes.rdf from the profile folder, but it did not work. Finally read somewhere that Firefox must be closed in order for this to work.

If anyone ever has the same problem, try following the same steps so that you do not have to refresh:

1. Locate the Profiles folder. I found this by clicking the three bars in the tool bar, then the ? button at the bottom, then Troubleshooting Information, then Show Folder next to Profile Folder. Alternatively, you can reach Troubleshooting Information by hitting alt, selecting Help, then Troubleshooting Information; you can also type "about:support" in the address bar.

2. Close Firefox. Wouldn't work for me unless this was done.

3. Delete mimeTypes.rdf from the Profile Folder. You could also rename it something else in case you wanted this as a backup. Firefox will automatically make a new mimeTypes.rdf the next time you start it.

4. Start Firefox, go to "about:preferences#applications" by typing this in the address, and search for "pdf." The second content type was not there for me after doing this. Hopefully this works for others too.

I found a solution after searching very thoroughly. Before I had tried things like editing or deleting mimeTypes.rdf from the profile folder, but it did not work. Finally read somewhere that Firefox must be closed in order for this to work. If anyone ever has the same problem, try following the same steps so that you do not have to refresh: 1. Locate the Profiles folder. I found this by clicking the three bars in the tool bar, then the ? button at the bottom, then Troubleshooting Information, then Show Folder next to Profile Folder. Alternatively, you can reach Troubleshooting Information by hitting alt, selecting Help, then Troubleshooting Information; you can also type "about:support" in the address bar. 2. Close Firefox. Wouldn't work for me unless this was done. 3. Delete mimeTypes.rdf from the Profile Folder. You could also rename it something else in case you wanted this as a backup. Firefox will automatically make a new mimeTypes.rdf the next time you start it. 4. Start Firefox, go to "about:preferences#applications" by typing this in the address, and search for "pdf." The second content type was not there for me after doing this. Hopefully this works for others too.