ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is totally slow and not responding

  • 6 ردود
  • 4 have this problem
  • 185 views
  • آخر ردّ كتبه biggie

more options

Hi!

I need a little help. My FF is totally slow. I don't know where the problem is. I have open only a few tabs and it is loading too long, maybe 20 seconds and more and also "not responding" for a couple of seconds. I have never had these problems in such a way. FF was slow many times in 10 years of my using of this browser, but this is extreme for me. I tried to get rid of any unnecessary plugins and extensions, it helped for a few days and come again. Then I tried, for me the last solution, restarting/reseting FF to factory defaults... it also helped perfectly, but only for a few days and come again and I'm here, frustrated from FF. This problems I have on more computers and PC's are pretty new. 2x different HP ProBook 455 G2 with AMD A8 APUs and 1x HP ProBook 450 G2 with i3 Intel, if this could help. Plugins and extensions are only basic as I say, so this can't be a problem in my opinion.

Thank you very much for every respond.

الحل المُختار

OK just new version of 42 solved problems...

Read this answer in context 👍 0

All Replies (6)

more options
more options

Thanks for reply.

Yes, there is still a problem. Maybe just a little I feel that FF is not freezing / responding so much, but is still so much slow. I have shared a data of my system for this question, so you can check up on right side question details, if it can helps. But as I have said, I made a reset of FF and then it went fine, even after instalation of my plug-ins.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem so others will know.

more options

I mean it went fine after reset FF, even after instalation of my plug-ins, but only few days and have still these problems as after reseting and cleaning FF. Maybe this is a problem of whole Firefox as it is.

more options

...as before reseting... sry...

more options

الحل المُختار

OK just new version of 42 solved problems...